Xonotic Forums
[SOLVED] Campaign Bug - Printable Version

+- Xonotic Forums (https://forums.xonotic.org)
+-- Forum: Support (https://forums.xonotic.org/forumdisplay.php?fid=3)
+--- Forum: Xonotic - Help & Troubleshooting (https://forums.xonotic.org/forumdisplay.php?fid=4)
+--- Thread: [SOLVED] Campaign Bug (/showthread.php?tid=2056)

Campaign Bug - Squigger - 08-22-2011

So I was playing the 0.5 campaign that I got from the git version (which is 10 times better than the 0.1 campaign Big Grin ) when I ran into a problem. I was playing the campaign until I got to the mission where you have ONS in Red Planet. When I tried that mission it was just me in Red Planet with no ONS aspects.

However, I saw that the ONS map was updated to be courtfun on the git server, so I updated and compiled via git, but then an even worse consequence occured.

Now everytime that I try to do that ONS courtfun level it goes through a never ending loading cycle with the never ending loading screens cycling through.

Is there any way that I can fix this? Smile

RE: Campaign Bug - Cortez666 - 08-22-2011

red planet doesnt have ons support anymore.

RE: Campaign Bug - Squigger - 08-22-2011

I know, its just that the problem got even worse when the ONS map was changed to courtfun.

RE: Campaign Bug - Cortez666 - 08-22-2011

just wait till someone updates the campaign. should be done soon.

RE: Campaign Bug - Mirio - 08-22-2011

Yes its broken because Red-Planet does not support ONS anymore.
You can fix it for yourself too if you open the campaignxonoticbeta.txt (in maps.pk3) and replace "red-planet" with "courtfun" and you put Courtfun instead of Red-Planet in the description too.
But I guess its fixed today/next days.
Glad you like it. Big Grin

RE: Campaign Bug - mand1nga - 08-24-2011

This is fixed already (replaced red-planet with courtfun). Thanks a lot for reporting.

Please note that the preffered way for reporting bugs is to submit an issue to http://dev.xonotic.org

(08-22-2011, 10:04 AM)Squigger Wrote: I know, its just that the problem got even worse when the ONS map was changed to courtfun.


RE: Campaign Bug - Squigger - 08-24-2011

That instead of me being on red planet with no bots or ons aspects when I would play red planet ons, that Xonotic itself would basically crash when i tried to play courtfun ons.

Whenever I would try to play courtfun ons level, it would start the loading screen, but then it would fail to load, and then endlessly cycle throughout all the other loading screens which made me helpless in trying to do anything else in the game.

RE: Campaign Bug - mand1nga - 08-24-2011

That is really not supposed to happen. I tried ons@courtfun myself yesterday and I didn't have any problem at all. Looks like we're dealing with two problems here:

A) Crash when trying to play ons on this map. If this is the case please submit a ticket with the complete console log output

B) First of all be sure to be using the campaign file that is distributed with GIT and nothing else. If it still persists, could you describe the issue better? Does it just keep cyclying through all the loading screens with no chance to stop it?

RE: Campaign Bug - Squigger - 08-24-2011

I just re downloaded the entire git, and it seems to work fine now. I guess it was something to do with my older git files. Thank you for your help with this Big Grin.