Xonotic Forums
[SOLVED] RegisterNotification_Done error - Printable Version

+- Xonotic Forums (https://forums.xonotic.org)
+-- Forum: Support (https://forums.xonotic.org/forumdisplay.php?fid=3)
+--- Forum: Xonotic - Help & Troubleshooting (https://forums.xonotic.org/forumdisplay.php?fid=4)
+--- Thread: [SOLVED] RegisterNotification_Done error (/showthread.php?tid=5031)

RegisterNotification_Done error - Keziolio - 08-05-2014

Hi, i can't join on half of the servers because to this error


I'm on Linux, it does not work on both glx and sdl.
Is there any way to fix that?

RE: RegisterNotification_Done error - Mr. Bougo - 08-06-2014

I'll need more log. Don't post screenshots of your console, do a text dump and put it on pastebin.com for example, or in a code tag in this thread.

To do a dump, type in the console
condump crash.log
or any other filename. You'll find the log file in your data directory. If you don't know where that is, type
which config.cfg
If you're using linux, your data directory should be in $HOME/.xonotic/data/

Please let me know more about your situation too. What version of Xonotic are you using? What servers specifically are problematic and are not? Is it really "half the servers"?

RE: RegisterNotification_Done error - Keziolio - 08-06-2014

Sorry, didnt knew about that command.

Log file: http://pastebin.com/wMBSz6KQ

I'm using xonotic 0.7.0, downloaded from xonotic.org pressing the "Download Now!" button.

I can't connect to 3/4 of the servers, the only that works are:
[0.6.0] (DieTunichtguten.org)|{CTF Minsta+Hook}
[MoN] Overkill [MOD]
[MoN] Vehicle Gameplay
And some others.

The servers that i can't connect are for example:
Evil Ant Colony 0.7.0 CTF (Minsta & Hook) Server
(Prophets) Runaway from Divination [XDeFrag]
Super Mario Bros. USA
And almost all the others

I tried to rename the .xonotic folder, after doin that all the servers were working, then i tried to copy "config.cfg" from the old folder to te new .xonotic folder, and the problem has come back.
So i post you also that file (config.cfg) http://pastebin.com/G65Qc4LV seeing that the problem is there.


RE: RegisterNotification_Done error - Mr. Bougo - 08-06-2014

Okay. This is a compatibility bug related to your use of the italian language translation. Some notification items are malformed (contain a newline character at the end) and the verification code triggers a CSQC backtrace.

Because the checking code is in CSQC, and the CSQC code are sent by the game servers, that checking code varies depending on the server's version. This is what causes your problem. With your current config, you can only play on servers.

Here's what you can do:
  • Set the language to english
  • OR open the console and type:
    notification_errors_are_fatal 0
    This might make the notification look strange due to an extra linebreak being present, but it shouldn't be too bad I think? If you try that, let me know.
  • OR get an italian translation file from our git servers. I'll make you a pk3 file for this in the next post because it involves overriding existing files due to name changes.
    EDIT: Nevermind, this last solution won't work, because 0.7.0 servers will then crash on you because your translation is *missing* the newlines. Pick one of the two solutions above.

EDIT: Thanks for the very helpful report by the way! I filed a bug report: http://dev.xonotic.org/issues/2017

RE: RegisterNotification_Done error - Keziolio - 08-06-2014

"notification_errors_are_fatal 0" worked with nothing strange enough to be noticed while playing, thanks!

RE: RegisterNotification_Done error - Mr. Bougo - 08-06-2014

Yup, apparently the newlines are fixed by the same code anyway. Glad we figured this out! Have fun! Smile