Xonotic Forums
[SOLVED] model not moving with entity - Printable Version

+- Xonotic Forums (https://forums.xonotic.org)
+-- Forum: Creating & Contributing (https://forums.xonotic.org/forumdisplay.php?fid=10)
+--- Forum: Xonotic - Development (https://forums.xonotic.org/forumdisplay.php?fid=12)
+--- Thread: [SOLVED] model not moving with entity (/showthread.php?tid=6322)

model not moving with entity - dingus - 07-30-2016

I have some code that updates a projectile's origin after each timestep, which very roughly looks like so:

projectile.nextthink = time;
vector newposition = weird_curve_fn(projectile.curveparam);
projectile.curveparam += projectileSpeed * frametime;
setorigin(projectile, newposition);
LOG_INFO("origin = ", vtos(projectile.origin), "\n");

However, when I run the code, the projectile's model never moves. I know the origin is being set because I have that print statement, and it indeed prints new coordinates each frame.

Is there something obvious that I am missing here? How could this be happening?

RE: model not moving with entity - Mario - 07-30-2016