Xonotic Forums
Bots get stuck - Printable Version

+- Xonotic Forums (https://forums.xonotic.org)
+-- Forum: Creating & Contributing (https://forums.xonotic.org/forumdisplay.php?fid=10)
+--- Forum: Xonotic - Development (https://forums.xonotic.org/forumdisplay.php?fid=12)
+--- Thread: Bots get stuck (/showthread.php?tid=7125)



Bots get stuck - Lyberta - 02-27-2017

So I usually play with bots since server list is empty. I've noticed that bots get really stuck in gamemodes where there are no items to pickup such as LMS, CA, FT, sometimes other modes. Are there plans to fix them? Maybe just make them go to random waypoints when there are no items or enemies in sight.


RE: Bots get stuck - martin-t - 02-27-2017

Terencehill made lots of fixes to the bot code in latest git but without proper waypoints they'll still get stuck, not much can be done about that. They need direct line of sight to at least one waypoint. It seems that items also act as waypoints so with them enabled there is less chance of getting stuck. If you wanna see where the problem is, try g_waypointeditor 1 and restart map (not sure if it works on a server, locally for sure). A lot of maps don't have waypoints at all and those that have them might have them badly placed so there are still blind spots.


RE: Bots get stuck - Lyberta - 02-27-2017

(02-27-2017, 02:41 PM)martin-t Wrote: Terencehill made lots of fixes to the bot code in latest git but without proper waypoints they'll still get stuck, not much can be done about that. They need direct line of sight to at least one waypoint. It seems that items also act as waypoints so with them enabled there is less chance of getting stuck. If you wanna see where the problem is, try g_waypointeditor 1 and restart map (not sure if it works on a server, locally for sure). A lot of maps don't have waypoints at all and those that have them might have them badly placed so there are still blind spots.

I've only used vanilla 0.8.1 with no custom content. Gonna get git version and try.


RE: Bots get stuck - Lyberta - 02-27-2017

OK, git is much better but some maps are still broken, for example Running Man CTF.


RE: Bots get stuck - martin-t - 02-27-2017

Well, maybe the waypoints just suck. Nothing stopping you from improving them. We also found out that in ctf bot behavior is heavily affected by minor changes in the waypoints - place them a bit too far apart and they refuse to attack the flag.

Btw, if you're developing a custom mod or something, base it on current git, not 0.8.1. There were *massive* changes in the codebase since then to make it more sane and maintainable.