Xonotic Forums
Auto-deploy server - Printable Version

+- Xonotic Forums (https://forums.xonotic.org)
+-- Forum: Support (https://forums.xonotic.org/forumdisplay.php?fid=3)
+--- Forum: Xonotic - Server Administration (https://forums.xonotic.org/forumdisplay.php?fid=16)
+--- Thread: Auto-deploy server (/showthread.php?tid=7596)

Auto-deploy server - 5ika - 12-15-2017

I'm trying to have an auto-deployed server on every Jelastic compatible hosters.
My configuration works find at the first launch and I can connect to the server from the game.
But when I restart the server, there is a problem with authentication keys and the keygen server.
The logs display "Server listening" but I can't connect to the server.
On first launch, this is what I have : https://pastebin.com/PTXH0DtP (it works with some errors)
And after restart : https://pastebin.com/H60w6Gdv
I tried to remove the auto-generated file key_0.d0si without success.
So How to validate my server at each restart ? Or is it possible to avoid the authentication ?
Thanks Big Grin

RE: Auto-deploy server - Jelasticman - 12-29-2017

Hello 5ika,
Could you please provide as your environment name and hostername. Or you can write ticket to your local hoster and they can redirect it to us. We will try to exclude this problem from our side. Thank you.
Best regards,
Team Jelastic.

RE: Auto-deploy server - 5ika - 12-29-2017

Hi Team Jelastic,
It's amazing how Jelastic is everywhere  Big Grin
The hoster is Hidora (Switzerland) and I'm in the team.
There is no running environment currently but you can see my WIP manifest here : https://github.com/HidoraSwiss/manifest-xonotic/blob/master/manifest.jps
Do you prefer a ticket on the Jelastic Support platform ?
Thank you !

RE: Auto-deploy server - Jelasticman - 12-29-2017

Hi again 5ika,
Quote:Do you prefer a ticket on the Jelastic Support platform ?

Yes, it would be better in the future.
Currently, we investigating your manifest and provide an answer in this forum thread. Please, stay tuned for updates.

RE: Auto-deploy server - Jelasticman - 01-01-2018

Hello 5ika,
We haven't any problem with xonotic server and actually with JPS manifest. Maybe after rebooting the server you forgot typing the port on the client side? Because as we see you are using endpoint. 
We have tried running xonotic server on the VPS server with real ip and tried configure it manually with endpoint, and also, we haven't any problem after rebooting server.
Best regards.

RE: Auto-deploy server - 5ika - 01-04-2018

Hi Jelastic Team,
I've tried again and it effectively works. I sometimes need to restart the client but the problem is trivial.
The manifest is functional now : https://github.com/HidoraSwiss/manifest-xonotic
Thank you for your time,
Best regards