Xonotic Forums
[SOLVED] Weird key hold issue with official version - Printable Version

+- Xonotic Forums (https://forums.xonotic.org)
+-- Forum: Support (https://forums.xonotic.org/forumdisplay.php?fid=3)
+--- Forum: Xonotic - Help & Troubleshooting (https://forums.xonotic.org/forumdisplay.php?fid=4)
+--- Thread: [SOLVED] Weird key hold issue with official version (/showthread.php?tid=7731)



Weird key hold issue with official version - Bloodthorn - 05-18-2018

Hello again,

due to this issue I had to switch Xonotic versions from the Fedora 27 one to the official one as a standalone package.
While that thankfully fixed the other issue a new one has popped up now with this version:

When I press certain keys for more than about 1 second, the game will have issues.
Specifically and most notably, when I press my hotkey for zoom ('e') the camera will start zooming in and out in quick succession while the zoom overlay is still shown, which makes it really hard to use the zoom function to hit anything.
A similar problem occurs when I press 'Tab' for more than 1 second: this time, any text displayed on screen will start to wobble.

The other version did not have this issue (same keybindings), but I can't go back to it, because it caused the last issue.
Switching zoom to a different key does not solve the issue unfortunately.

Any ideas?


RE: Weird key hold issue with official version - martin-t - 05-19-2018

There are 2 client executables - sdl and glx. Each uses a different input handling method, have you tried both?


RE: Weird key hold issue with official version - Bloodthorn - 05-20-2018

Yeah I have and the problem doesn't occur when using glx but that executable has terrible performance so that I cannot play properly with it.
When I used the version of the game distributed with Fedora 27 I used the sdl executable and it didn't have the input issue...any idea what could be causing it in this version (the official version)?


RE: Weird key hold issue with official version - Bloodthorn - 05-20-2018

Or, another way of coming at this could be: what must I do to include the encryption support available in the official version in the fedora version?

I went back to using the fedora version now because I would rather the game be unable to maintain my stats profile than mess up my input handling, but I would, of course, prefer to have it all working.


RE: Weird key hold issue with official version - martin-t - 05-20-2018

Idk what to do about that fedora package, you might wanna try talking to the maintainer to see why he's not including the crypto lib. It's nice that people package xon for us when we have nobody with the needed expertise but we typically don't have any contact with them.

There are 2 more things you could try:
  • Autobuilds - built the same way as release but newer code
  • Compiling xonotic yourself - this sometimes fixes issues for people but is slightly more effort (the guide is pretty comprehensive though, you just copy paste lines into terminal)



RE: Weird key hold issue with official version - Bloodthorn - 05-20-2018

Thanks for your answer!

So I tried the autobuild, but that was a desaster...many more bugs and problems that made the game unstable and unplayable than with the other versions.

Next I tried building it myself by following the instructions on the site (that are not complete btw. as I had to install some packages that were not listed there and the ones that are listed for Fedora don't seem to exist in the standard repos); I am now stuck with this compile time error:
configure: error: GNU MP not found, see http://gmplib.org/, or try --with-openssl
which is weird, because I have the package gmp-1:6.1.2-6.fc27.x86_64 installed and that seems to be the newest build according to the GMP website.
I don't really compile stuff often and am kinda lost as to what to do next...do I need a different GMP version or what do you think is the problem?

Edit: okay I fixed that problem and now have a fully working build and it seems that there are no more problems now! Thanks for your help!

In case someone else has a similar issue: if you're using Fedora you need to install the following packages to be able to compile successfully:
Code:
libjpeg-turbo-devel SDL2-devel gcc-c++ gmp-devel libtool automake autoconf

and the following file with the name xonotic.desktop placed in /usr/share/applications/ will allow you to start the game from the search:
Code:
Name=Xonotic
Comment=Multiplayer, deathmatch oriented first person shooter
Encoding=UTF-8
Icon=/home/username/gitbuilds/xonotic/misc/logos/xonotic_icon.svg
Exec=/home/username/gitbuilds/xonotic/all run
Terminal=false
Type=Application
Categories=Game;ActionGame;
Just switch [username] with your user name and make sure the path to your git build is correct.


RE: Weird key hold issue with official version - martin-t - 05-20-2018

Hehe, i was wondering why the fedora deps list was so short. Is your list complete? For now i added it to the wiki, i guess libjpeg-turbo-devel replaces libjpeg62-devel and libjpeg62-static-devel; SDL2-devel replaces libSDL2-devel; but are libalsa2-static-devel and x11-proto-devel necessary? I could remove them is not.


RE: Weird key hold issue with official version - Bloodthorn - 05-20-2018

libalsa2-static-devel is not installed AFAICT and the compilation worked but x11-proto-devel was already installed, I guess, under the name xorg-x11-proto-devel


I also may have installed other relevant packages in the past...I dunno so the list may still be incomplete but this way at least it is more current.


RE: Weird key hold issue with official version - martin-t - 05-21-2018

This is the issue with languages without a package manager - they just waste people's time. I removed alsa and the libjpeg62 stuff and did the laziest thing about x11-prote-devel i could without installing fedora in a VM and spending an afternoon going through compiler error messages and installing packages one by one based on them. Anyway, thanks.


RE: Weird key hold issue with official version - Bloodthorn - 05-21-2018

Yeah it's fine...I can barely use the command line and somehow I managed so it's doable and even easier now for the next guy. Smile


RE: Weird key hold issue with official version - Lyberta - 05-22-2018

(05-21-2018, 07:41 AM)martin-t Wrote: This is the issue with languages without a package manager - they just waste people's time. I removed alsa and the libjpeg62 stuff and did the laziest thing about x11-prote-devel i could without installing fedora in a VM and spending an afternoon going through compiler error messages and installing packages one by one based on them. Anyway, thanks.

C and C++ now have a package manager. People just need to migrate to it.