Xonotic Forums
[SOLVED] libc++ update - Printable Version

+- Xonotic Forums (https://forums.xonotic.org)
+-- Forum: Support (https://forums.xonotic.org/forumdisplay.php?fid=3)
+--- Forum: Xonotic - Help & Troubleshooting (https://forums.xonotic.org/forumdisplay.php?fid=4)
+--- Thread: [SOLVED] libc++ update (/showthread.php?tid=7754)



libc++ update - Bloodthorn - 06-21-2018

Hello again,
I recently updated my Fedora to 28 and now I'm having trouble compiling Xonotic; the issue is that Fedora 28 uses a newer libc++ (8 instead of 7) but Xonotic requires 7.

So here's my question: will you guys upgrade to libc++ 8 any time soon (in which case I'd just wait for that to happen) or do you wanna stay on 7 for the foreseeable future (in which case I'd need to figure out how to get the older library back)?


RE: libc++ update - Lyberta - 06-21-2018

What compile error are you getting?


RE: libc++ update - Bloodthorn - 06-22-2018

(06-21-2018, 08:48 PM)Lyberta Wrote: What compile error are you getting?

Code:
+ cd /home/user/gitbuilds/xonotic/gmqcc
+ make -j8 gmqcc
make: *** No rule to make target '/usr/include/c++/7/new', needed by 'ast.o'.  Stop.

In my investigation I noticed that /usr/include/c++/7 doesn't exist anymore, since I upgraded to Fedora 28, which replaced gcc-c++ 7 with version 8 (located in /usr/include/c++/8).

So my question is whether you guys are planning to upgrade that in your repo anytime soon or not. If not then I guess I'd have to install the older version again from a non-maintained package, which I don't like to do.

Or are there any other options?


RE: libc++ update - Lyberta - 06-22-2018

Just "make clean". You have outdated build artifacts. Also, libc++ and libstdc++ are different projects and looks like you are using libstdc++.


RE: libc++ update - Bloodthorn - 06-22-2018

(06-22-2018, 06:30 AM)Lyberta Wrote: Just "make clean". You have outdated build artifacts. Also, libc++ and libstdc++ are different projects and looks like you are using libstdc++.

Thanks! That solved it, I can now compile Xonotic as before; I don't normally compile stuff manually so I'm pretty clueless. In case someone stumbles upon this in the future: What I did specifically was to run 'all clean' and then the usual sequence ('all checkout', 'all update', 'all compile -r sdl').