Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Xonotic locking up Ubuntu 10.04

I've been having this problem where running Xonotic (preview or git) on my desktop will lock up Ubuntu and make it totally unresponsive to keyboard/mouse/ping/ssh. It usually locks up during the loading period when I first start the game. Sometimes it will get further than that, and I can join a game, but then it will lock up shortly afterwards when loading a map. I tried changing to newest Nvidia drivers from Nvidia site, that didn't fix it. It was suggested that my GPU may be getting too hot (suggested on IRC) but it doesn't go above 50 C when gaming. I don't have any problems retrieving and compiling the source from git, only when I try "./all run" (or the preview executable) do I run into these issues, and no other game has ever made it lock up. Anyone else have a similar problem? From what I can tell this seems to be unique to my desktop. I didn't have the problem on my laptop when I tried running the preview.

Here's my system:
Ubuntu 10.04
Asrock 939Dual-SATA2
Athlon 64 X2 3800+ @ 2.5ghz
2gb Ram
Nvidia Geforce 210 (512mb)
80gb HD.
Screen res = 1920x1080

Any help would be greatly appreciated, as in the current state I can't really run/play/do anything with Xonotic at all Sad

Can you try another 3D-Shooter? Or some other app that puts significant amount of load onto your GPU? If the system still locks up, it's the GPU Big Grin
He can talk the talk, but can he caulk the caulk?

I have never experienced that problem. It probably won't help, but you can try running with ./all run glx or ./all run sdl
(01-05-2011, 07:17 PM)naryl Wrote: > Ubuntu is an ancient African word that means "cant configure debian"

Actually it's for "I can't install Gentoo".

All the other games i've tried (nexuiz, sauerbraten, assaultcube) work fine 100%. This issue is specific to xonotic, and the lockup still happens with either glx/sdl.

This happened to me a few times as well on 10.04 Ubuntu but with an older git version (haven't updated to test since) of Xonotic but I was able to ctrl alt f2 and reboot. Using the 0.1.0 preview I haven't had a lock up.

OS 10.04 Ubuntu 32 bit
Older Xonotic git 32-SDL version
Playing res 800x600
GPU Intel 4500MHD 128mb
CPU Intel T5800 2.0GHz
3GB Ram
<[-z-]> have you seen the documentary "happy"?
<Samual_> no
<Samual_> it sounds horrible

Well, I think my issue may be solved. Strange issue, as it would appear that my onboard ethernet controller was causing the lockup. I noticed that these lines always appeared right before the crash in my kern.log (I believe merlijn suggested I check that in IRC):

Jan 24 03:28:07 JayNix-Desktop kernel: [   19.962827] 0000:05:05.0: tulip_stop_rxtx() failed (CSR5 0xfc664010 CSR6 0xff972113)
Jan 24 03:28:07 JayNix-Desktop kernel: [   19.962839] eth1: Setting full-duplex based on MII#1 link partner capability of 45e1.
Jan 24 03:28:15 JayNix-Desktop kernel: [   27.104010] eth1: no IPv6 routers present

So I disabled my onboard ethernet controller and threw in a discrete card. Ta-da, problem fixed. I've run Xonotic several times and loaded 10+ games with no issues. Strange, very strange. But anyway, now that my dev machine is running Xonotic properly, I can start being useful!

Edit: I'm gonna need to run some more tests to confirm total stability.... but it's certainly better than it was.

You might want to look into disabling IPv6 system-wide if you're not set up for it yet (just try to remember to re-enable it if you need that one day!). I guess it's a good idea in general to disable the IPv6 modules if they aren't used anyway, speeds things up a little.

Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED] Input flickering in Ubuntu 20.04 NAPALM 3 1,785 03-28-2021, 11:38 AM
Last Post: SpiKe
  [SOLVED] No stats for the player Ubuntu 19.04 - just don't use the flathub version Fiorentino 2 3,171 04-20-2020, 07:42 AM
Last Post: Fiorentino
Exclamation [BUG] *ubuntu 18.04/nVidia v415-Desktop Screen Corruption After Exiting Game? JeZxLee 1 3,218 01-06-2019, 05:15 AM
Last Post: SpiKe
Bug [BUG] Permission Denied line 131 Ubuntu 14 ilyasofficial 2 3,236 10-22-2017, 06:39 AM
Last Post: martin-t
  [SOLVED] Ubuntu 16.0.4 Compile RedScale12 8 6,511 09-06-2016, 08:40 PM
Last Post: RedScale12
  [NEEDS INFO] How to ubuntu xonotic server install? Turan 4 5,520 03-17-2016, 08:01 AM
Last Post: Turan
  [SOLVED] Source Code Xonotic on Ubuntu 15.04 Ryan 2 4,592 09-16-2015, 10:48 AM
Last Post: Beagle
  [SOLVED] Ubuntu running problem rembak 7 10,299 03-29-2014, 04:30 AM
Last Post: adem
  [SOLVED] Ubuntu 12.04 Install Issue Red Viper 6 8,134 03-08-2014, 03:20 AM
Last Post: Halogene
  [NEEDS INFO] Compiling NetRadiant (Ubuntu 11.10) uDelta 2 4,786 07-15-2013, 10:50 AM
Last Post: machine!

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-