Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Major bugs caused by server lag on some machines

#1
Exclamation 
So while I'm away to my grandparents house for the easter, I decided to play a local match of Xonotic on my laptop. The laptop is slower than my main computer (although quite modern and fast), and Xonotic was more laggy with some visual effects. The real problem however, was some form of server-side lag, which caused a lot of weird bugs to happen... including entities and weapons braking.

This is something I would consider calling a 'red bug alert' for, after the horrid things I had just seen earlier Tongue Breakage I noticed during my local match with bots includes:

- Electro getting stuck while running out of ammo for the beam, and attempting to auto-switch while still holding the primary fire button. The gun would not switch, but stay stuck with firing animation, while per-weapon crosshairs adapted to the new weapon (making things even uglier). After releasing the fire button, this issue stopped and the gun switched properly.

- Shotgun melee would not do any damage. I clearly noticed bots using it on me (while I tried it on them), and no form of damage was ever taking place.

- Some shotgun shell castings kept lagging back and forth, moving forever this way (until fading).

- Some bots would sit and not do anything (bot AI lag perhaps). Only if standing next to them for long enough would they start moving and shooting at you.

- Worst and scariest bug of them all! An elevator on Red Planed disappeared during the match after several minutes of gameplay. No idea where and how... the whole entity was just gone. WTF?

Unless something got broken in the latest engine, these are issues I've never noticed before. It might be due to my laptop being slower, or darkplaces not getting along with its CPU or something. I didn't know such issues existed though, and IMO they are a stopper for using Xonotic properly on certain machines.

Are these known problems, and ever happened to anyone else? Is there any way to fix or debug them?
<spackObot> Congratulations to Samual and Taoki, your lovescore is 98.463%!
Samual (~dioteckte@...) quit #xonotic.pickup (gonna kill myself now)
Reply

#2
I've seen some similar stuff happen online if I get a ping of like 150 or something. A lot of the weapons become USELESS, the machine gun especially.
ECKZBAWKZ HUGE LIST OF ACHIEVEMENTS GOES HERE....


Oh wait.
Reply

#3
(04-27-2011, 07:49 PM)MirceaKitsune Wrote: - Electro getting stuck while running out of ammo for the beam, and attempting to auto-switch while still holding the primary fire button. The gun would not switch, but stay stuck with firing animation, while per-weapon crosshairs adapted to the new weapon (making things even uglier). After releasing the fire button, this issue stopped and the gun switched properly.

- Some bots would sit and not do anything (bot AI lag perhaps). Only if standing next to them for long enough would they start moving and shooting at you.
I noticed these on a local game on my relatively fast computer. The electro bug only seems to happen when using the bolt-style electro.
(01-05-2011, 07:17 PM)naryl Wrote: > Ubuntu is an ancient African word that means "cant configure debian"

Actually it's for "I can't install Gentoo".
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  Game Server's Packet to XonStats Antares* 2 1,477 04-30-2017, 10:33 AM
Last Post: Antibody
  Custom Weapon Balance - Live on /v/ server Antares* 30 8,506 09-30-2016, 11:52 AM
Last Post: Antares*
  dpmaster.deathmask.net master server IP change Willis 2 3,596 03-15-2016, 02:23 PM
Last Post: Willis
  New feature review/test: Private Server List BuddyFriendGuy 17 9,510 01-07-2016, 08:05 AM
Last Post: BuddyFriendGuy
  Are server mods possible? oaties 4 3,723 03-12-2012, 12:33 PM
Last Post: Cortez666
  Planning for major weapon updates Samual 70 64,463 04-19-2011, 11:39 AM
Last Post: theShadow
  assault test (US server is now avaiable) Cortez666 45 31,594 01-30-2011, 01:39 PM
Last Post: Mirio
  A breakdown of two major balances (Fruitiex and LeeStricklin) Lee_Stricklin 28 20,777 01-05-2011, 09:34 AM
Last Post: CuBe0wL
  After an git update, all Nexuiz server can't be used. liberty 17 12,048 04-04-2010, 02:12 PM
Last Post: nox

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-