Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Error compiling DP after update GIT on linux

#1
Hi, first I want to thank you to all of xonotic team for your big work.
Since last week I got compiling error after update GIT. The compiling was a success just befor the weekend test (XWIT). I'll apreciate if a "programing guru" would help me to resolve my probleme. Here the end of the log of the process. Sry for my poor english.

LDFLAGS="-g -ggdb -fno-math-errno -ffinite-math-only -fno-rounding-math -fno-signaling-nans -fno-trapping-math -DSVNREVISION=`{ test -d .svn && svnversion; } || { test -d .git && git describe --always --dirty; } || echo -` -DBUILDTYPE=debug -lm -ljpeg ../misc/builddeps/dp.linux32/lib//libd0_blind_id.a ../misc/builddeps/dp.linux32/lib//libgmp.a ../misc/builddeps/dp.linux32/lib//libd0_rijndael.a -lrt -ldl" LEVEL=2
error: unknown option `dirty'
usage: git describe [options] <committish>*

-+-+-+-+-+-+ and -+-+-+-+-+-+

gcc -DSUPPORTIPV6 -o darkplaces-dedicated builddate.c sys_linux.o vid_null.o thread_null.o snd_null.o cd_null.o bih.o cap_avi.o cap_ogg.o cd_shared.o crypto.o cl_collision.o cl_demo.o cl_dyntexture.o cl_gecko.o cl_input.o cl_main.o cl_parse.o cl_particles.o cl_screen.o cl_video.o clvm_cmds.o cmd.o collision.o common.o console.o csprogs.o curves.o cvar.o dpsoftrast.o dpvsimpledecode.o filematch.o fractalnoise.o fs.o ft2.o utf8lib.o gl_backend.o gl_draw.o gl_rmain.o gl_rsurf.o gl_textures.o hmac.o host.o host_cmd.o image.o image_png.o jpeg.o keys.o lhnet.o libcurl.o mathlib.o matrixlib.o mdfour.o menu.o meshqueue.o mod_skeletal_animatevertices_sse.o mod_skeletal_animatevertices_generic.o model_alias.o model_brush.o model_shared.o model_sprite.o mvm_cmds.o netconn.o palette.o polygon.o portals.o protocol.o prvm_cmds.o prvm_edict.o prvm_exec.o r_explosion.o r_lerpanim.o r_lightning.o r_modules.o r_shadow.o r_sky.o r_sprites.o sbar.o sv_demo.o sv_main.o sv_move.o sv_phys.o sv_user.o svbsp.o svvm_cmds.o sys_shared.o vid_shared.o view.o wad.o world.o zone.o -g -ggdb -fno-math-errno -ffinite-math-only -fno-rounding-math -fno-signaling-nans -fno-trapping-math -DSVNREVISION=- -DBUILDTYPE=debug -lm -ljpeg ../misc/builddeps/dp.linux32/lib//libd0_blind_id.a ../misc/builddeps/dp.linux32/lib//libgmp.a ../misc/builddeps/dp.linux32/lib//libd0_rijndael.a -lrt -ldl
dpsoftrast.o: In function `DPSOFTRAST_Interpret_Draw':
/home/user/jeux/xonotic/darkplaces/dpsoftrast.c:4907: undefined reference to `__sync_add_and_fetch_4'
/home/user/jeux/xonotic/darkplaces/dpsoftrast.c:5324: undefined reference to `__sync_add_and_fetch_4'
collect2: ld a retourné 1 code d'état d'exécution
make[2]: *** [darkplaces-dedicated] Erreur 1
make[2]: quittant le répertoire « /home/user/jeux/xonotic/darkplaces »
make[1]: *** [bin-debug] Erreur 2
make[1]: quittant le répertoire « /home/user/jeux/xonotic/darkplaces »
make: *** [sv-debug] Erreur 2

I can show or attach all the log file if necessary. Thank you for your attention.
Reply

#2
Looks like you have to update your version of git. Or wait a bit, I don't think we really need that feature.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#3
(06-01-2011, 05:45 AM)divVerent Wrote: Looks like you have to update your version of git. Or wait a bit, I don't think we really need that feature.

Thank you for your tip, I updated GIT to the v1.7.5.4 but I have the same result when compiling Xono:
/home/user/jeux/xonotic/darkplaces/dpsoftrast.c:4907: undefined reference to `__sync_add_and_fetch_4'
/home/kuku/jeux/xonotic/darkplaces/dpsoftrast.c:5324: undefined reference to `__sync_add_and_fetch_4'

So I will wait a bit as you told me and see later if its works. Also I'll wait for an other tip to debug that ;-)
Ciao
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEEDS INFO] Linux install Old_Geekdad 7 237 01-16-2019, 06:03 PM
Last Post: Zoommair
  [SOLVED] Menu fails to load after recent update Bloodthorn 2 311 09-25-2018, 08:11 AM
Last Post: Bloodthorn
  [SOLVED] Cannot run game anymore after new git update Bloodthorn 2 407 07-25-2018, 07:20 AM
Last Post: Bloodthorn
  [SOLVED] libc++ update Bloodthorn 4 475 06-22-2018, 06:48 AM
Last Post: Bloodthorn
Exclamation [SOLVED] Graphics issues on Intel Kaby Lake (HD630) hardware on Linux cefiar 9 3,645 04-19-2018, 02:42 AM
Last Post: cefiar
  [SOLVED] How To Disable Travelling "Update Now" Notification garyt53 11 2,299 02-22-2018, 11:30 AM
Last Post: ScrewTheUpdate
  [SOLVED] linux compile/link error BuddyFriendGuy 3 1,116 11-27-2017, 08:55 PM
Last Post: Lyberta
  [NEED HELP] Netradiant compiling? Raxno 2 1,092 11-11-2017, 04:50 AM
Last Post: It'sMe
  [NEEDS INFO] Custom map - Host Error: Mod_MAP_Mode: not yet implemented teratorn 6 2,016 03-07-2017, 04:29 AM
Last Post: SpiKe
  [NEEDS INFO] W key are not working in fedora24 linux akillah 2 1,534 03-06-2017, 08:35 PM
Last Post: -z-

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-