Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED]map compile final "some textures doesn't show up"

#1
Hi, I have a problem when iI compile a specific map in final xonotic aprouved mode.
There is some textures at some places that doesn't show up. Let see the images to compare between compile single and compile final.
[Image: tOWRhbw]
[Image: tOWRhcA]

I have modified lights on different ways, I had add a sun, I took of a sun, I placed 2 suns, I took off half of the lights, I took off all lights, I changed intensity, radius, I set up lights as I saw in afterslime maps, I tried to use ".map.option" files from evil space map and also the one used for xoylent map... I have used google (as always I do). I'am stucked!

When I compile single for the 3 steps, it missed the shadows but all transparents textures effect works. I have tried all xonotic aprouved compilation mode and I got the same result.

I have about 30 warning
WARNING: Styled light found targeting light2
and tons of
WARNING: Hit per-surface style limit (4)
and after compile the program has writen 82 "lm_0**.tga in the "mymap/maps/mymaps/" directory and I think (I am sure) it is too much! too many tga files.

I don't really anderstand what happen but I guess one of our experiment mappers can help me to get ride of that.
Reply

#2
I guess you just used too many (different?) styled lights. I think you can use up to 4 of them in a close area.
ydnar Wrote:It means that your map has too many styled lights in close proximity, affecting nearby surfaces.
It's just a warning, however, and the unused styled lights will just not affect the surfaces.
To correct it, eliminate the additional styled lights, or use the same styles on multiple lights.
(from the Splash Damage Forums)

The grey tiled looking textures mean that is something wrong with the shader. Either there is a missing texture or you wrote a wrong shader.

EDIT: The cause why you have so many lightmaps (tga-files) is that all the styled lights generate different brightnesses, and this needs some more lightmaps (one for each "frame"!).
Reply

#3
ydnar Wrote:It means that your map has too many styled lights in close proximity, affecting nearby surfaces.
It's just a warning, however, and the unused styled lights will just not affect the surfaces.
To correct it, eliminate the additional styled lights, or use the same styles on multiple lights.
(from the Splash Damage Forums)

I found that on the Net an I did take off all the lights! (I think i did!)
May be I just had a dark map and I started over with a previous copy of the map with all the lights! I'll check it out tonight.

(07-05-2011, 03:00 PM)Maddin Wrote: The grey tiled looking textures mean that is something wrong with the shader. Either there is a missing texture or you wrote a wrong shader.

Just to specify that this a 4 sides brush with the same texture on each side and the texture does not show up on all side! the shader is good Because it is the same as the 4 big towers and it is the same as the big forcefeild in the bottom of the map.
I think it is related at what you pointed me at (styled light) uphere and downhere.

(07-05-2011, 03:00 PM)Maddin Wrote: EDIT: The cause why you have so many lightmaps (tga-files) is that all the styled lights generate different brightnesses, and this needs some more lightmaps (one for each "frame"!).

I'am not sure what is a styled light, I saw in lots map when editing them. a 5force light and just beside a 90 force light linked to a null target for light direction. The same patern at all 3 or 4 meters aside where a visible lights could be seen in the game.

....¤....¤.....¤....¤....¤..... null target
....|....|.....|....|.....|.... link
....*....*....*....*....*.... light 90
....*....*....*....*....*.....lights 5
I've done the same thing were I had little spot lights.

Well,
I have made so many tests maybe I forgot the result with only few lights. I'll test it tonight and thank you Maddin for your reply, that's give me a bit more confidence in my self. I though some magical think was on me to make me fail :-)
I'll tell you all about the result.
Reply

#4
You are new to mapping, right? I also had weird problems at the beginning; sometimes it´s just like the devil is teasing us. Tongue
Reply

#5
(07-05-2011, 05:09 PM)Maddin Wrote: You are new to mapping, right? I also had weird problems at the beginning; sometimes it´s just like the devil is teasing us. Tongue
Hurra!
Thank you again Maddin, you helped me, everythings is good I compiled a new nice map. You where right on all you said.

You are right, I am new to mapping, I start it because I wanted a specific map for xonotic. Dokujisan asked me last year if I wanted to map so recently I answered to myself "why not!" and I stopped to play and I spend all my spare time to map. I have 3 maps on the grill and I have models and textures to do for some of them. Happily here I find all the help or informations I need for my new "playground".
Reply

#6
Why do I already know this feelings... ?Rolleyes

This websites may be interesting for you (and other mappers), even though they are for Jedi Knight/Quake3:
Map-Craft - Tutorials
RichDiesal´s JK2Radiant Mapsource
Reply

#7
(07-06-2011, 11:09 AM)Maddin Wrote: Why do I already know this feelings... ?Rolleyes

This websites may be interesting for you (and other mappers), even though they are for Jedi Knight/Quake3:
Map-Craft - Tutorials
RichDiesal´s JK2Radiant Mapsource

Wink
Reply

#8
DarkPlaces does not support styled lightmap lights. Lightstyles only work for realtime lights (see: rtlights file, r_editlights). This is likely why it fails for you.

In fact, Q3A already has no support for lightstyles, but there is a hack in q3map2 that makes them work by a kind of texture blending. This hack does not work for DarkPlaces.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#9
Good to know. Smile
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Photo [NEED HELP] When in game, the guns keep firing, sometimes doesn't fire when pointed at a target. U1Y5Y5 3 333 09-12-2017, 01:28 PM
Last Post: SpiKe
  [BUG] xonotic-maps ebuild does not compile ZyX 0 468 05-01-2017, 10:10 PM
Last Post: ZyX
  [SOLVED] Ubuntu 16.0.4 Compile RedScale12 8 1,669 09-06-2016, 08:40 PM
Last Post: RedScale12
  [SOLVED] Xonotic doesn't work with overwolf Ch4mp 2 1,198 08-12-2016, 02:44 AM
Last Post: Ch4mp
  [SOLVED] cannot compile git code dingus 5 1,636 07-27-2016, 05:13 PM
Last Post: sev
  [SOLVED] Can't See Custom User Models/Textures Deathsbreed 4 1,183 05-07-2016, 11:06 AM
Last Post: Deathsbreed
  [SOLVED] [Solved]How to install or runn Xonotic Kaddafi 10 3,101 10-10-2015, 12:09 PM
Last Post: Halogene
  [SOLVED] Can't compile my map machine! 1 1,346 05-09-2015, 08:47 AM
Last Post: Mirio
  [SOLVED] Can't compile under OS X Yosemite BuddyFriendGuy 1 1,887 04-23-2015, 01:00 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] NetRadiant fails to compile with latest nvidia driver Maddin 6 2,812 03-25-2015, 06:02 AM
Last Post: Maddin

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-