Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Some comments on output from self-compiled SDL client

#1
Bug 
Ok, so I compiled the game on my GNU/Linux box. First time I run the SDL client, it was not able to load almost any texture, but I run it a second time and it worked. Now I wonder about some of the output I got:

Code:
Failed to init SDL joystick subsystem:

I have no joystick. Is this message because of that? Or do I have to install anything other than common SDL? I’m worried because I’m actually packaging the game for a distribution, so people with joysticks might end up using the same binary.

There are some more things:

Code:
couldn't exec data/campaign.cfg

Warning: Could not expand $scr_centersize
Warning: Could not expand $* in alias scoreboard_columns_set
Invalid program name client !
client program not loaded.
couldn't exec autoexec/*.cfg
couldn't exec autoexec.cfg
there is no public key 0

Then, when I start single player mode, first scenario:

Code:
models/turrets/terrainbase.md3: could not load texture "evil8_base/e8_base1"

couldn't exec maps/g-23.cfg

And finally I have no cross to aim. Which might be because a preference I set with 0.1.0preview, I’m not sure, but where would I put it back? I can’t find such a setting.

So, any help with the cross or any of the messages is appreciated Smile
Reply

#2
None of these messages are serious.

data/campaign.cfg e.g. doesn't exist on first start, which is normal. It is later created in the user home.

As for no crosshair, try moving away your config.cfg and try again.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#3
(09-09-2011, 05:56 AM)divVerent Wrote: None of these messages are serious.

data/campaign.cfg e.g. doesn't exist on first start, which is normal. It is later created in the user home.

As for no crosshair, try moving away your config.cfg and try again.

Great, thanks, deleting the file did the job.
Reply

#4
Couldn't exec map is what I always see. If that appears it means it works, really, if I don't get that, I get an error.
Reply

#5
That couldn't exec is actually some Nexuiz legacy and no longer needed for Xonotic. I'll remove that code.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [BUG] Devastator/mortar glitch (0.8.2 client/0.8.1 server) gd 4 1,751 05-23-2017, 10:40 PM
Last Post: kaadmy
  [NEEDS INFO] Some maps wont download through the client. end user 7 5,801 02-22-2013, 10:37 AM
Last Post: end user
Wink [SOLVED] What is the difference between SDL and GLX client? unfa 9 18,638 02-28-2012, 01:55 PM
Last Post: Droid

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-