Create an account


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Internet connection lost when launching game

#1
Hello, after playing Nexuiz with a few of my schoolmates several years ago, me and a friend wanted to start playing again. After downloading this game (Xonotic) and running it, the server list is empty. Also, my internet connection gets cut off. I tried on multiple computers in my home and the same problem occurs. This happened too several years ago with Nexuiz when trying to play on my own internet. My friend was able to play on multiplayer servers just fine.
Reply

#2
(02-27-2012, 05:08 PM)As1anSwagger Wrote: Hello, after playing Nexuiz with a few of my schoolmates several years ago, me and a friend wanted to start playing again. After downloading this game (Xonotic) and running it, the server list is empty. Also, my internet connection gets cut off. I tried on multiple computers in my home and the same problem occurs. This happened too several years ago with Nexuiz when trying to play on my own internet. My friend was able to play on multiplayer servers just fine.

Got same problem once on Windows with 26000 forwarded port. Check router /firewall
Reply

#3
As1anSwagger,

What router/firewall do you have? Have you updated the firmware on the device? A firmware update on your router may fix the issue or it may be a hardware issue. Go to the manufacturers site and look up the model. You also may be able to replace this firmware with more reliable firmware such as dd-wrt or tomato.
I have had an issue with a set of firmware bugs on Linksys and D-links that caused the router to crash. In the end it lead me to replace them with devices with much more RAM and flash in them. Generally consumer SOHO (small and home office routers) suck and have very crappy procs, ram, etc. You can test this yourself by doing the following:

Test as follows:

Open up 2 command prompts/consoles and type ping -t http://www.google.com (if on windows you need the -t) or ping http://www.google.com (Osux or Linux) (leave this window open) in the other ping your default gateway or your router which is usually in the IP space of 192.168.1.x. [You can find out your default gateway (router) by going to a command line/console and typing ipconfig /all or ifconfig -a (Linux/Unix/Bsd/OsuX).]

Start up Xonotic go to your Settings >> Video and then untick Full Screen. Make it so you can see the ping output and then you will see the ping output. If you no longer can get to Google or your default router goes down with either a Destination Host Unreachable or Request Timed Out message - you know that it is your cr@ppy router. =P You can then spend hours on the phone with incompetent support that will do a hard reset on your router because that is all this is listed in the "support" script and then they will hang up on you. @ssH0l3z! Then I would recommend turning your router into a paperweight and buy something that will run dd-wrt or tomato. I'm kiddin'! =X

Seriously, though - let me know how it goes or if you have any questions.
@Vargos

You only need port forwarding if you are setting up a server. Otherwise you don't need to open *ANY* ports on your firewall.
Reply

#4
I actually meant that not needs to forward port.
Reply

#5
evit, I think going dd-wrt or tomato is overkill. Keep in mind that it's not even ingame traffic that kills his net, but just the server list in the menu. And I don't see how your ping test confirms that it's a router problem, it might just as well be the NIC or his internet line.

As1anSwagger, you should definitely check your router's log if there's one (enable it if necessary). Also check if the internet goes down on other computers in your network at the same time.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#6
You can try changing the cl_netfps setting on the console to 30 instead of the default, 60. That reduces the number of packets sent, and may prevent the router crash.
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud
Reply

#7
(02-28-2012, 02:19 AM)Mr. Bougo Wrote: evit, I think going dd-wrt or tomato is overkill. Keep in mind that it's not even ingame traffic that kills his net, but just the server list in the menu. And I don't see how your ping test confirms that it's a router problem, it might just as well be the NIC or his internet line.

As1anSwagger, you should definitely check your router's log if there's one (enable it if necessary). Also check if the internet goes down on other computers in your network at the same time.

Mr. Bougo,

It is a valid course of action to test this but replacing with DD-wrt/Tomato just yet might be premature. What do you suggest he do call his ISP? Good luck!

If the whole network goes down because of the connection to the master server then I know it's not a problem with his NIC or his "Internet" but his router/firewall. Pinging on the internal network and the Internet will show where the fault is without question.

Just as a point of reference start up your machine and then run Wireshark or tcpdump before you start up Xonotic and look at what happens.

I've seen this very problem a few times with crappy SOHO routers and so I think a bit of testing doesn't ever hurt.
Reply

#8
If his ISP cuts his net or if his router goes K.O. or if his NIC dies, pinging google will fail. That's why I said pinging the internet doesn't show the point of failure. Router logs will be more helpful, especially if it's his router auto-throttling traffic or something similar.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] frozen/lost frames BuddyFriendGuy 1 265 04-22-2020, 05:48 PM
Last Post: BuddyFriendGuy
Exclamation [SOLVED] macOS Sierra: -basedir /path/to/game iqxonotic 10 25,589 04-02-2020, 02:54 PM
Last Post: martin-t
Question [NEED HELP] Certain maps crash my game :( flexo 0 964 03-03-2020, 04:06 PM
Last Post: flexo
  [BUG] The game seems doesn't recognize virtual 7.1 noctiveqc 2 726 02-17-2019, 02:10 AM
Last Post: martin-t
Exclamation [BUG] *ubuntu 18.04/nVidia v415-Desktop Screen Corruption After Exiting Game? JeZxLee 2 1,004 01-06-2019, 05:15 AM
Last Post: SpiKe
  [NEED HELP] Custom Game Modes 3agle427 5 1,240 12-30-2018, 12:44 AM
Last Post: Lyberta
  [SOLVED] Game displays [x] joined the [y] team upon connecting Bloodthorn 3 1,127 09-17-2018, 01:52 AM
Last Post: Lyberta
  [SOLVED] Cannot run game anymore after new git update Bloodthorn 2 1,057 07-25-2018, 07:20 AM
Last Post: Bloodthorn
  [BUG] Connection failure Bloodthorn 0 1,048 06-10-2018, 05:06 AM
Last Post: Bloodthorn
  [NEEDS INFO] Game Crash On Load Castor 0 1,051 05-31-2018, 09:06 AM
Last Post: Castor

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-