Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Audio crackling

#1
Hi all,

I've just discovered Xonotic and it looks great! Unfortunately the audio quality's not so good. On the menu it's fine, but after playing for a little while it starts crackling. It sounds to me like an audio buffer underrun of only a couple of samples, but it sounds like a very loud Geiger counter near a very active source! It's worse if I run in a higher resolution.

I can't see a way of enlarging the audio buffer however. Is this possible?
Reply

#2
Can you give us some more information on your OS and sound configuration?
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
Sure, I'm running Arch Linux with kernel 3.3.1. Using ALSA 1.0.25 with SPDIF output to an external amplifier.

Upon further experimentation, lowering the audio sample rate to 44.1kHz (from 48kHz) seems to help. Lower sample rates (22k) don't give me any in-game audio (just menu music) but 44.1k seems to be ok and avoid the crackling.

Obviously I'd prefer 48k though since that's what everything else on the system uses, so I take it there's no way of correcting the miscalculated audio buffer size? Or is there anything else I can test?
Reply

#4
and you have cross checked ya equipment with other games/tunes?

you sure ya wires havnt been half eaten by ya cat?

also make sure ya sample rate is matched across the game and the audio nerd thingo , because if they are , say one is at 48 , and the other is 44.1 then YA MAY HAVE ISSUES

also if you listen to http://soundcloud.com/chooksta then that can induce unwanted noise too :p


t

:^
Reply

#5
Yes system has been working unchanged for a couple of years now, and only Xonotic has problems. ALSA is running through dmix set to 48k so I would think 48k would be more reliable, but setting Xonotic to 44.1k and having ALSA upsample to 48k fixes the noise. I don't know what the audio nerd thingo is.
Reply

#6
a soundcard is the audio nerd thing :p

t


:^
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Audio messed up Bla1 3 1,709 11-15-2015, 06:05 PM
Last Post: Bla1
  [SOLVED] Audio issues with Linux ImageJPEG 10 6,217 02-24-2012, 05:00 AM
Last Post: Mr. Bougo
  [NEEDS INFO] Possible audio bug on Windows 8 Preview build Lee_Stricklin 2 3,569 09-21-2011, 01:03 PM
Last Post: Lee_Stricklin

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-