Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] We need a FAQ item for the "black map" problem in maps with fog

#1
Seriously.

It keeps coming up
http://forums.xonotic.org/showthread.php?tid=2941
http://forums.xonotic.org/showthread.php?tid=2955
http://forums.xonotic.org/showthread.php?tid=3074
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#2
Actually, no. Fog was working well in 0.5. Somewhere, somebody broke it on the engine side between 0.5 and 0.6. This is a serious bug. We should find the commit that broke it - unfortunately, I can't help here, because I don't have this problem Sad

It already has a ticket on the bug tracker btw.: http://dev.xonotic.org/issues/1215
[Image: 561.png]
"One should strive to achieve; not sit in bitter regret."
Reply

#3
Augh. That means we have to teach somebody to use git bisect.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#4
This might have fixed the problem http://svn.icculus.org/twilight?view=rev&revision=11818
Reply

#5
Now that is odd. icculus has that commit, our own dakrplaces branches don't. oO Neither div0-stable nor master was updated since 2 weeks, so we cannot even test if the fix commited by divVerent works at all.
[Image: 561.png]
"One should strive to achieve; not sit in bitter regret."
Reply

#6
I hope this will be figured soon (though it never affected me, so I can't test it really). Next up, motion blur.
Reply

#7
(05-30-2012, 07:13 AM)C.Brutail Wrote: Neither div0-stable nor master was updated since 2 weeks, so we cannot even test if the fix commited by divVerent works at all.
Can you just do a diff of that revision versus current git to make a patch to test?

For future reference and search engines: This particular issue only comes up when OpenGL 2.0 is disabled. More of an issue on older and more broken graphics card drivers where OpenGL 2.0 may not be supported.

Another issue with the OpenGL 1.x paths currently is that warp zones do not render at all. This makes glowplant for example unplayable. Are the OpenGL 1.x paths tested frequently enough to be able to be fully supported?
I'm at least a reasonably tolerable person to be around - Narcopic
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Question [NEED HELP] Certain maps crash my game :( flexo 0 964 03-03-2020, 04:06 PM
Last Post: flexo
  [NEED HELP] cl_gunalign doesn't seem to work on some servers/maps Aguaumreal 2 665 09-10-2019, 03:42 AM
Last Post: Aguaumreal
  [NEED HELP] Windows 10 -basedir problem BlazedRasta 2 1,127 06-13-2019, 05:12 AM
Last Post: martin-t
  [NEED HELP] setting up server with custom maps le Bork 2 816 01-31-2019, 01:06 PM
Last Post: morosophos
  Chat key bind problem BuddyFriendGuy 4 1,066 01-26-2019, 11:12 PM
Last Post: BuddyFriendGuy
  [SOLVED] Xonotic load downloaded maps Bla1 3 2,526 10-01-2017, 06:11 PM
Last Post: Mirio
  [BUG] xonotic-maps ebuild does not compile ZyX 0 1,195 05-01-2017, 10:10 PM
Last Post: ZyX
Bug [SOLVED] troubleshooting how to install maps Eonman 2 2,952 03-06-2017, 10:14 PM
Last Post: -z-
  [SOLVED] invertigo black sky BuddyFriendGuy 6 2,546 01-11-2017, 02:21 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] Dedicated server problem. kreestenrx1234 2 1,676 04-27-2016, 03:30 PM
Last Post: BuddyFriendGuy

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-