Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
load issues (100%) while trying to start the server

hey there, i ´m trying to bring up my own xonotic server on current ubuntu. so i cloned the xonotic/xonotic.git, updated, got the overkill mod and compiled the server.

now when i try to bring it up as dedicated server, i run into 100% load, get plenty of "program not loaded" lines and the server does not come up.

the tail of the server output looks like this:

client: program is not loaded
execing autoexec/empty.cfg
execing autoexec.cfg
Loaded public key key_0.d0pk
Loaded private ID key_0.d0si for key_0.d0pk
Loaded public key key_15.d0pk [...]
there is already a signed private key for 0
SpawnServer: no map file named maps/_init/_init.bsp
execing server.cfg
"maxplayers" set to "20"
Host_Mingled: time stepped forward (went from 0.000000 to 1339687960.845915, difference 1339687960.845915)

notice the missing of the lines where ip and port are reported, it seems like the server is hanging there. would be great if someone could give me a hint.


Oh wow, that's strange.

This here is not normal at all:
SpawnServer: no map file named maps/_init/_init.bsp

The server startup relies on this dummy map to load completely. Are you sure that all the needed repositories are cloned properly? Does ./all update show anything strange happenning? Try ./all checkout. You do have a clone of the map repo in data/xonotic-maps.pk3dir, right?
[Image:]640K ought to be enough for anybody.
     ― Linux Torvalds

hey mr. bougo !

what i did:
git clone git://
cd xonotic
./all update -l best
./all compile -c -r dedicated

well, i find lots of files in the data/xonotic-data.pk3dir/ but i haven´t actually cloned the map repo you´re mentioning. isn´t the xonotic.git above containing all needed files?

i just updated again, recompiled. tail of what the compile output was:

+ /var/xonotic-git/xonotic/all update-maps
Found main repo = git://
Repository . enabled because it already exists
Repository data/xonotic-data.pk3dir enabled because it already exists
Repository data/xonotic-music.pk3dir enabled because it already exists
Repository data/xonotic-nexcompat.pk3dir disabled by default, create data/xonotic-nexcompat.pk3dir.yes to enable
Repository darkplaces enabled because it already exists
Repository netradiant enabled because it already exists
Repository div0-gittools disabled by default, create div0-gittools.yes to enable
Repository d0_blind_id enabled because it already exists
Repository data/xonotic-maps.pk3dir enabled because it already exists
Repository mediasource disabled by default, create mediasource.yes to enable
Repository fteqcc enabled because it already exists
fatal: Invalid object name 'HEAD'.
List of maps that got deleted (if any) and currently are in /var/xonotic-git/xonotic/data.old:
total 0

what about the invalid object name 'HEAD' ??

Can you do ./all update and ./all checkout please? It seems your maps repo is broken, hence the git error message.
[Image:]640K ought to be enough for anybody.
     ― Linux Torvalds

+ cd /var/xonotic-git/xonotic/data/xonotic-maps.pk3dir
WTF? Not even branch master doesn't exist in data/xonotic-maps.pk3dir

checking the whole thing out again.

Don't! You're wasting bandwidth on your link and on Xonotic's servers! You already have most of the data, you don't need to redownload everything.

Just remove xonotic-maps.pk3dir and run ./all update again. Or maybe even try ./all clean --reclone before doing that.
[Image:]640K ought to be enough for anybody.
     ― Linux Torvalds

Possibly Related Threads...
Thread Author Replies Views Last Post
  RaspberryPi4 Server ablyveiled 1 24 3 hours ago
Last Post: Freddy
Rainbow Kotangєns' independent server Kotangens 0 227 07-30-2020, 06:22 AM
Last Post: Kotangens
  [NEED HELP] I can't create my server. Kotangens 11 658 07-22-2020, 04:42 AM
Last Post: Kotangens
Information [SOLVED] Server stops when I close command prompt on my PC Jewel 2 316 06-01-2020, 07:11 AM
Last Post: Jewel
  Server Hosting Issue Saevus 2 396 04-30-2020, 06:16 PM
Last Post: Saevus
  Server error "Weapon stats writing failed: -404" FlufyBuny 2 900 04-08-2020, 02:41 PM
Last Post: jwabbitt
  Docker Xonotic Dedicated Server ich777 13 1,921 04-02-2020, 02:59 PM
Last Post: FAF
  [NEED HELP] Server dont appear in server browser abslimit 0 438 03-15-2020, 04:13 AM
Last Post: abslimit
  How To Open Server? Lyviq 0 433 03-11-2020, 05:19 PM
Last Post: Lyviq
  [SOLVED] Opensuse Leap 15.1 and Server.cfg ldegroot 3 746 08-01-2019, 02:52 PM
Last Post: ldegroot

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-