Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Sound troubles Ubuntu

#1
Hi, I'm new to the game and absolutely love it! I use Ubuntu 12.04 and when I first downloaded the game it was working fine but now, about a week later, i have been having sound issues. For some reason the sound just disappears. It started only when i would go in to certain random single player games but now has progressed to happening even on the opening screen. Has anyone else had this issue and if so is there a solution in the works?
Reply

#2
On most systems running xonotic-linux-sdl instead of xonotic-linux-glx helps for sound problems.
My contributions to Xonotic: talking in the forum, talking some more, talking a bit in the irc, talking in the forum again, XSkie
Reply

#3
As far as I know, sdl is now the default. Where did you get Xonotic, dadx4?

It could be a problem with PulseAudio. I had a discussion with another player running Mint having a similar issue, with the sound suddenly disappearing. Killing PulseAudio fixed the problem, so I suggested her to remove Pulse from her system. It does have some drawbacks, though: no audio indicator in the panel, gnome-alsamixer needed to control the volume in a GUI, and the volume and mute keys on the keyboard have to be configured manually.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#4
Quote:As far as I know, sdl is now the default.

How can it be the default? When you unpack the game you get 2 scripts: xonotic-linux-glx.sh and xonotic-linux-sdl.sh & you're free to exec the one that you like, also seeing that the sdl is a symlink to the glx one, many new ppl (unknowingly to the bash magic that is done inside the script) run the glx one.

BTW: PulseAudio is actually a great piece of software, only in Debian and derivs (especially including the *buntus) it's crappily integrated and causes loads of problems.
My contributions to Xonotic: talking in the forum, talking some more, talking a bit in the irc, talking in the forum again, XSkie
Reply

#5
I got my Xonotic right from the Xonotic download site. I'm starting to lose my patience with Ubuntu because of the pulse audio issues. I switched to it from windows for a nice stable trouble free OS and something I could play with as I learned it better.

I found Xonotic when I was looking for a FPS that didn't require WINE or POL, both that default to Pulse Audio when games are run. Now the question is, how do I shut off the Pulse Audio? I'm fairly new to linux in general.
Reply

#6
(07-23-2012, 07:40 AM)Cyber Killer Wrote:
Quote:As far as I know, sdl is now the default.

How can it be the default? When you unpack the game you get 2 scripts: xonotic-linux-glx.sh and xonotic-linux-sdl.sh & you're free to exec the one that you like, also seeing that the sdl is a symlink to the glx one, many new ppl (unknowingly to the bash magic that is done inside the script) run the glx one.

BTW: PulseAudio is actually a great piece of software, only in Debian and derivs (especially including the *buntus) it's crappily integrated and causes loads of problems.

Oopsie. The ./all script in git runs sdl by default and sdl is the "officially" recommended binary. But you're right, in releases it's not very well defined at all.

dadx4: open a terminal and type sudo killall pulseaudio. Run Xonotic and see if it works fine. If it does, PA is your problem. I suggest you seek assistance in the Ubuntu forums.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#7
Thank you vey much, I'll give it a try!
Reply

#8
dadx4: before messing with your sound setup I really recommend trying to run the sdl version (xonotic-linux-sdl.sh) if you haven't done that before.
My contributions to Xonotic: talking in the forum, talking some more, talking a bit in the irc, talking in the forum again, XSkie
Reply

#9
I'm having this same problem.

Running in terminal outputs no issues at the time of bug.

I tried killing pulseaudio with "killall pulseaudio," and "pulseaudio --kill," but it just starts right back up again.

I tried running xonotic-linux-sdl.sh, but i get "./darkplaces-sdl not found," and I'm not sure how to install it. I tried apt-get but it can't find the package.

Please continue this thread. This game is awesome.

Edit: I'm running Mint 13 by the way.
Reply

#10
Ugh, PulseAudio. If it comes back after you kill it, I really don't know what to tell you. I'd either find a way to get rid of PulseAudio or, if that fails, get rid of the distro that forces it on you.

About sdl, how exactly did you install Xonotic? "./darkplaces-sdl" means that you want to launch the executable file "darkplaces-sdl" in the current directory, which you obviously don't have. In the terminal, what happens when you type "xonotic" (without quotes) and then press tab twice? If xonotic-sdl shows up, try that.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#11
pulseaudio started back up according to 'ps -x,' but all sound from everything was killed.

I installed xonotic with apt-get. Checking tab-autocomplete was the first thing I did when I read the suggestion, and all I got was 'xonotic '

I wasn't running the game from the install directory. I did that now, but I get "You have reached this menu due to missing or unlocatable content/data. You may consider adding -basedir /path/to/game to your launch command line." I do have the glx and sdl darkplaces engines in the directory.
Reply

#12
(02-22-2013, 04:51 PM)HitmanNumber86 Wrote: I tried killing pulseaudio with "killall pulseaudio," and "pulseaudio --kill," but it just starts right back up again.
Just came across a possible solution:
Pulse Audio - Arch Wiki Wrote:Prevent Pulse from restarting after being killed
Sometimes you may wish to temporarily disable Pulse. In order to do so you will have to prevent Pulse from restarting after being killed.
$ echo autospawn=no > ~/.pulse/client.conf
https://wiki.archlinux.org/index.php/PulseAudio

Coincidental perhaps but I reinstalled Arch last weekend and had tonnes of problems with PulseAudio initially, this being the firts time I'd used it and was very tempted to totally uninstall it but found a few workarounds for things.

That Arch Wiki page is full of workarounds for so many problems. I still have broken sound in WMA and WMV files because of PulseAudio and VLC not playing well.

Maybe a PulseAudio sticky thread is called for summarising issues and workarounds?
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#13
(02-22-2013, 06:09 PM)HitmanNumber86 Wrote: pulseaudio started back up according to 'ps -x,' but all sound from everything was killed.

I installed xonotic with apt-get. Checking tab-autocomplete was the first thing I did when I read the suggestion, and all I got was 'xonotic '

I wasn't running the game from the install directory. I did that now, but I get "You have reached this menu due to missing or unlocatable content/data. You may consider adding -basedir /path/to/game to your launch command line." I do have the glx and sdl darkplaces engines in the directory.

Yeah, "xonotic" in your distro is probably a wrapper script that launches the engine from the right directory. I don't use Mint so I can't help you, but I usually suggest people to get Xonotic from the Xonotic web site instead to avoid this sort of stuff.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#14
I wrote the conf file, and the audio in-game worked, but it was unbelievably quiet, and volume control didn't work, so I may be able to test if that's the issue later, but Flash videos didn't play any audio at all. I couldn't get pulseaudio back up again (I don't really know what I'm doing here), and I'm not going to reboot every time I quit Xonotic.

I'm looking for pulseaudio alternatives now, but I don't like the idea of using a sound server that this distro wasn't built on. A lot of people try Ubuntu based distros first, so I'm wondering if any Xonotic devs may be able to pinpoint the issue. Also, where is the pulseaudio error log?

[rant] I'm really not taking kindly to the PA devs, right now. It looks like 3.0 just came out for windows, but Linux only gets 1:1.1. [/rant]

Mr. Bougo I missed your response.

I'll try it from the site, if I can't figure out how to work around a wrapper script (I'm trying to learn new shit), as well as figure out if pulseaudio is the issue. If I can pinpoint the exact problem I'll write a bug report, and hopefully the devs can get it fixed quickly. I just want to help this game progress.
Reply

#15
(02-22-2013, 07:42 PM)HitmanNumber86 Wrote: I wrote the conf file, and the audio in-game worked, but it was unbelievably quiet, and volume control didn't work, so I may be able to test if that's the issue later, but Flash videos didn't play any audio at all.

This will be because PulseAudio is no longer controlling volume. If anything this is a good thing. Instead volume will be controlled by ALSA. You can run alsamixer from the command line but also your desktop environment may have a built in mixer application.

(02-22-2013, 07:42 PM)HitmanNumber86 Wrote: I couldn't get pulseaudio back up again

If you use a text editor to edit the file .pulse/client.conf in your home directory you can remove the autospawn=no line from it again.

(02-22-2013, 07:42 PM)HitmanNumber86 Wrote: Also, where is the pulseaudio error log?

By default it will be logging to the standard syslog. I doubt you will see errors though as it is probably working as intended, just with sound not working through some things. It is a really maddening piece of software to troubleshoot I agree.
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#16
Okay, from time to time I also have sound problems on my Ubuntu 12.10, which I assume are also related to pulseaudio. First thing I try is killing pulseaudio, which of course restarts automatically after that. This isn't much of a problem, because I want pulseaudio to be running. Sometimes restarting it already solves some problems.

If it doesn't help, I came across the solution to empty the ~/.pulse directory, which contains some pulseaudio runtime data. These files start with a random hash value (like 22ea5f...), and you can just remove all of them, or just rename your .pulse directory instead. Then restart pulseaudio by killing it. This fixed my sound problems every time, not only if Xonotic was behaving weird, but also other software!
[Image: 9216.png] Web: YouTubeSoundCloudFlickrzykure.de[unconnected]
IRC: #uc.xonotic #xonotic #xonotic.de #xonotic.pickup
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Exclamation [BUG] *ubuntu 18.04/nVidia v415-Desktop Screen Corruption After Exiting Game? JeZxLee 2 359 01-06-2019, 05:15 AM
Last Post: SpiKe
  [NEED HELP] Xonotic reverts to Stereo sound after having set it to 5.1 STP_KITT 0 384 11-27-2018, 05:35 PM
Last Post: STP_KITT
  [SOLVED] Character Sound Files Castor 9 1,150 06-05-2018, 05:22 PM
Last Post: Castor
Bug [BUG] Permission Denied line 131 Ubuntu 14 ilyasofficial 3 1,398 10-22-2017, 06:39 AM
Last Post: martin-t
  [SOLVED] Surround sound refuses to work with C-Media CMI-8788 soundcards Lee_Stricklin 2 1,256 03-06-2017, 08:24 PM
Last Post: Lee_Stricklin
  [SOLVED] Ubuntu 16.0.4 Compile RedScale12 8 2,639 09-06-2016, 08:40 PM
Last Post: RedScale12
  [NEEDS INFO] How to ubuntu xonotic server install? Turan 4 2,699 03-17-2016, 08:01 AM
Last Post: Turan
  [SOLVED] Source Code Xonotic on Ubuntu 15.04 Ryan 2 2,606 09-16-2015, 10:48 AM
Last Post: Beagle
  [SOLVED] Ubuntu running problem rembak 7 6,773 03-29-2014, 04:30 AM
Last Post: adem
  [SOLVED] Ubuntu 12.04 Install Issue Red Viper 6 4,903 03-08-2014, 03:20 AM
Last Post: Halogene

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-