Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Problem with Serveur ( Windows )

#1
Hi i'm french and i'm sorry for my bad english Wink
I want to play with my friend on xonotic and the server not execute the server.cfg.
I'll try the exec server.cfg command but the server.cfg can be found.
The file server.cfg is in the folder Xonotic\data
Thank you for your help(assistant) beforehand
Reply

#2
You should read the documentation then. Readme.txt is in the "server" directory.
Reply

#3
I read well it but I do not understand or I make a mistake. I copy the right script ( dedicated.bat ) in my system into my
Xonotic main directory and i copy the server.cfg edited previously edited in Xonotic\data and when i lunch dedicated.bat the server.cfg doesn't lunch
Reply

#4
Did you copy server_windows.bat into the same directory as your xonotic.exe?
Reply

#5
That's very strange. Can you run the xonotic client on the same machine? If so, open the Xonotic console (shift escape) and type which server.cfg
Reply

#6
at Mr Bougo no i don't run xonotic client on the same machine. The dedicated is on a windows server
at asyyy yes i copy the dedicatdd. bat on thd same directory as my client
tomorrow i take pictures of my configuration if you would to see than corectly parametre
Reply

#7
Okay... Please give me a file listing from the base directory then. Open a command prompt in the Xonotic directory and do
Code:
tree > tree.txt
and copypaste tree.txt in here or on a pastebin (http://pastebin.ca for example)


EDIT: Also, we can speak french if you want.
Reply

#8
J'aime le lapin et le fromage avec mon cerial les mardis

Bongo n'est pas utile
Reply

#9
Mr Bougo
http://pastebin.ca/2248238

This is my config file http://uploaded.net/file/jp9jotr5
Reply

#10
(11-04-2012, 05:43 AM)jeantallu Wrote: Mr Bougo
http://pastebin.ca/2248238

This is my config file http://uploaded.net/file/jp9jotr5

I have no idea what your PC and pastebin did with the encoding of the output, but here it is recoded to utf-8. I had to do recode u8..1252/,850..u8 on the file to get it encoded right. It seems you pasted something encoded in codepage 850, and it got translated (by whom?) back to utf8 as codepage 1252. Whatever. http://pastebin.ca/2248281

Can you redo this with the /f parameter? This one doesn't show the files.
Code:
tree /f > tree

Also, please don't use services like Uploaded to upload text files, it's annoying as hell. Put them in a pastebin. I can't access your config files because their servers are "overloaded" unless I pay for premium so that they can serve me a couple kilobytes of data. I hate these services, sending me the file would cost them less than serving me an error page.

EDIT: Still overloaded. As it stands now, I'm unable to help you further. Please post a tree with /f as I said above, and upload your config to pastebin.ca.



Okay, here we go. Here is the reuploaded config file: http://pastebin.ca/2248287

Did you really name the file nicoo.cfg? It has to be named server.cfg, because that's the file Xonotic tries to load.

As an aside (and sorry if this wasn't an accident) I see this line in your config:
Code:
//rcon_password "jeantallu"     // you can use rcon if this password is set.  you need to set the same password in your client if you want to issue rcon commands
There are three horribly wrong things going on here:
  1. You posted a server config without hiding the rcon_password
  2. That is a weak password. Don't use weak passwords.
  3. You did not uncomment the line (remove the two slashes at the beginning of the line), so this line does not set the variable
Reply

#11
Thank you so much i find my error i doesn't remove the two slashes at the beginning of the line.
Now it's ok. :-)
Reply

#12
Uh, that's unrelated though.

Il faut absolument que le fichier de configuration s'appelle "server.cfg" pour qu'il puisse être chargé par le serveur. Ensuite, quand il est chargé, les lignes qui commencent par "//" dans le fichier sont ignorées. Le problème que tu avais n'a rien à voir avec ces lignes: le fichier complet n'était carrément pas chargé, probablement parce qu'il n'avait pas le bon nom.
Reply

#13
A question still I have to add cards(maps) in xonotic / dated on the waiter(server) but when a customer connects he cannot download cards(maps).
I have to look at the mapping.txt file but I do not understand to activate very well how the download
Reply

#14
Hehe, setting up cards on the waiter for customers, good one. The words are map, server and client Smile

If you want to have maps on your server that are not part of the Xonotic release, you need to have them loaded on the server's side by putting the pk3 file in the data directory (same directory as your server.cfg). You also need to set up map download for clients if they don't know the map. For this you need a web server.

If you can host a web server yourself, that's of course the better option. You can set the cvar sv_curl_defaulturl in your server.cfg to be a prefix for the map download urls. For example, if you set it to http://example.com/ and you play the map "mymap" in mymap.pk3, the client will download the file http://example.com/mymap.pk3. If you use a CGI or PHP script to serve files, the defaulturl could be something like http://example.com/map.php?file= for example.

If your maps are hosted in different places, you need to use curl_urls.txt. That's a file in the data directory that assigns a url prefix to map name patterns. So for example if you host a bunch of maps by mapper xyz that are in pk3s called map1-xyz.pk3, map2-xyz.pk3 etc. and are all hosted at http://example.com/xyzmaps/, you can have this line in curl_urls.txt:
Code:
*-xyz.pk3        http://example.com/xyzmaps/
so that the clients get the file http://example.com/xyzmaps/map3-xyz.pk3 when map3 is played for example.

I'm repeating what's in the mapdownload.txt documentation file here, please ask specific questions if you don't understand. The basic idea is that you need to tell clients where to download the map files, so tell me what your problem is with that.
Reply

#15
Thank you for your explanations now it's ok but in the command prompt opened during the launch of the server_windows.bat i have a series of errors which display.
I made a screen shot to show you.
This
http://imageshack.us/a/img197/8449/errorfg.jpg
and this
http://img37.imageshack.us/img37/7373/error2un.jpg
Reply

#16
That's alright, everyone gets these and they are no big problem.

Here's something you might want to know: you can copy text from the command prompt by right clicking the title bar, then in "edit" you can click "select" (or something similar), then select the text you want to copy and press enter. You can then paste it here.

You can also dump the entire xonotic console log to a text file with the condump command: condump mylog.txt will make the file "mylog.txt" in the data directory.
Reply

#17
Okay, please don't do that select thing and use condump instead, I didn't expect it to cut lines like that and it's really hard to read.

Anyway, as I told you, you should not worry about these errors.
Reply

#18
Thank you for your help ;-)
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Message of the day problem DeadTOm 5 3,891 02-26-2014, 12:40 PM
Last Post: DeadTOm
Question [SOLVED] XDF Server - Problem with player collision -maniac|Su- 2 3,340 11-23-2013, 04:38 PM
Last Post: -maniac|Su-
  How do I host a single map on a hosted Windows Server tbutlerPBL 19 12,244 07-22-2013, 03:38 PM
Last Post: Mr. Bougo
  Rcon via HLSW Problem Highlander 11 11,288 10-20-2012, 06:08 PM
Last Post: kidx
Tongue Serveur help proxene 1 2,107 09-27-2012, 11:32 AM
Last Post: Mr. Bougo
  Rcon2IRC [Windows] Mario 1 4,319 01-10-2012, 07:18 AM
Last Post: Sless

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-