Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Cant start server in linux

Im having a hell of a time setting up a dedicated server in linux! I have moved the config to the right place and moved the startup script to the right place. When I boot up the server I keep getting the error saying the file has not been moved, when it has. What should I do?

Be sure, that xonotic folder and are in correct user. I had once same problem coz started server as root=)

xxen0nxx, can you please tell me where you got Xonotic, where exactly it's located and where you moved the files? I have to ask you for details because there is obviously something wrong with the location of the files and I can't guess what if I don't know what exact steps you followed to get this problem.

Vargos: I don't think your comment is general. I don't know what you did, but following the instructions from the docs should let you run the server as root just fine. But running it as root is a bad idea anyway, so don't do that Tongue

I got Xonotic from the website download. I had put the server.cfg into the ~/Xonotic/data folder and the sh file in ~/Xonotic

And where did you extract Xonotic? In your home directory?


Bougo, same to ur comments.
Meaning of my message wuz that if you put xonotic in home/user and then start it as a root command try to look up sh in root folder

xxen0nxx: do you use sh /home/username/Xonotic/ ?

xxen0nxx, which error do you get? As far as I know, there are two possible related errors that can be displayed when running the server.

I keep getting this even though I have done what it says to do.

This script is not properly set up yet.
Please refer to the instructions in readme.txt.
In short:
- copy server.cfg to the data directory and adjust its settings
- move this file to the main directory of your Xonotic installation

Okay, have a look inside the server_linux script:

case "$(uname -m)" in
  x86_64)       executable="xonotic-linux64-dedicated" ;;
  *)            executable="xonotic-linux32-dedicated" ;;

cd "`dirname "${0}"`"

if ! [ -x "$executable" ]; then
        if [ -x "../$executable" ] && { [ -f ~/.xonotic/data/server.cfg ] || [ -f ../data/server.cfg ]; }; then
                cd ..
                echo "This script is not properly set up yet."
                echo "Please refer to the instructions in readme.txt."
                echo "In short:"
                echo "- copy server.cfg to the data directory and adjust its settings"
                echo "- move this file to the main directory of your Xonotic installation"
                exit 1

exec ./${executable} +serverconfig server.cfg "${@}"

Do you have an executable file called xonotic-linux32-dedicated (or linux64 if uname -m returns x86_64) in the same directory as That is, ~/Xonotic/xonotic-linux32-dedicated if you have ~/Xonotic/ . The script thinks you do not.

Maybe you can add a line just after the cd dirname one that just says pwd? That will tell you where it's looking for the xonotic-linux32-dedicated file.

O_o i got a output that was ~/Xonotic so its looking in the right dir. I also have the executable in the right place.

ok i fixed that issue with chmod +x but that arose to another issue. Now when I run the sh script i get Segmentation Fault.

Wow, okay.

It's supposed to be executable, so something must have gone wrong when you extracted the game. Can you checksum the release zip archive you downloaded?
openssl md5
should return
Quote:MD5( 2dac2c1ad4388255d3ad4d038dea3f77

If you get the right checksum, try extracting it again (using the unzip command).

yes! got it working. Thanks alot!

Possibly Related Threads…
Thread Author Replies Views Last Post
Question [NEED HELP] Own server FinBiteLeaf 3 1,457 12-08-2022, 09:25 AM
Last Post: FinBiteLeaf
  [NEEDS INFO] Xonotic settings file on linux ArchBerrie 2 4,578 07-15-2021, 03:18 AM
Last Post: ArchBerrie
  Impossible to connect to the Xonotic 0.8.2 server NoBrain 3 1,980 06-16-2021, 02:23 AM
Last Post: nj
  [NEED HELP] Offensive Servername - Block Server? conidad 1 1,403 03-30-2021, 10:59 AM
Last Post: _para
  [NEED HELP] server denied rcon access ristiisa 3 1,796 11-20-2020, 09:53 AM
Last Post: ristiisa
  [NEED HELP] cant start the game/ session lock problem skyghost47 1 2,322 10-24-2020, 11:50 PM
Last Post: BuddyFriendGuy
  USB Mouse input on Linux dagelf 1 2,086 10-07-2020, 06:14 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 1,439 08-18-2019, 03:14 AM
Last Post: FAF
  [NEED HELP] Missclick on Linux Mint Mate 19 RanDoom 4 2,713 04-23-2019, 01:41 PM
Last Post: RanDoom
  [NEED HELP] Decrease server log level falco 1 1,734 04-17-2019, 06:11 PM
Last Post: BuddyFriendGuy

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-