Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Compiling on debian squeeze - missing libjpeg-turbo8-dev

#1
I'm trying to install the required dependencies and I'm getting this error E: Unable to locate package libjpeg-turbo8-dev on my server which is a bare bones Debian 6.

I use this from the wiki

sudo apt-get install build-essential xserver-xorg-dev x11proto-xf86dri-dev x11proto-xf86dga-dev x11proto-xf86vidmode-dev libxxf86dga-dev libxcb-xf86dri0-dev libxpm-dev libxxf86vm-dev libsdl1.2-dev libsdl-image1.2-dev libclalsadrv-dev libasound2-dev libxext-dev libsdl1.2debian libjpeg-turbo8-dev git-core unzip wget

Is there a different package I can use instead of libjpeg-turbo8-dev?
[MoFo] Servers - North America - Hosted in Kansas USA - Admin DeadDred [MoFo]
Reply

#2
libjpeg8-dev. Maybe. Not sure it works.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
(02-27-2013, 03:29 PM)Mr. Bougo Wrote: libjpeg8-dev. Maybe. Not sure it works.

This is what I got so far

The following packages have unmet dependencies:
libsdl-image1.2-dev : Depends: libjpeg-dev
Depends: libtiff4-dev but it is not going to be installed
libsdl1.2-dev : Depends: libdirectfb-dev (>= 0.9.22) but it is not going to be installed
E: Broken packages


Maybe I should just install Ubuntu server 12.10? Although I like the nice a stable Debian.

I selected libjpeg-dev so will see what happens.
[MoFo] Servers - North America - Hosted in Kansas USA - Admin DeadDred [MoFo]
Reply

#4
You do need version 8. Make sure your system is up to date. Ask Debian support if it fails, you seem to be having an issue with official packages.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#5
(02-27-2013, 05:08 PM)Mr. Bougo Wrote: You do need version 8. Make sure your system is up to date. Ask Debian support if it fails, you seem to be having an issue with official packages.

I'm gonna try Ubuntu server 12.4. Might as well learn how OVH reinstalls os's.
[MoFo] Servers - North America - Hosted in Kansas USA - Admin DeadDred [MoFo]
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Compiling on Elbrus DJs3000 1 323 07-03-2020, 04:57 AM
Last Post: poVoq
  [NEED HELP] Netradiant compiling? Raxno 2 1,652 11-11-2017, 04:50 AM
Last Post: It'sMe
  [SOLVED] Mortar model missing Dr. Midget 12 2,511 05-01-2017, 09:16 AM
Last Post: Lyberta
Sad [NEED HELP] Help with compiling. ImSoAwesome 2 1,819 09-06-2016, 02:54 AM
Last Post: ImSoAwesome
  [SOLVED] sdl.dll missing wind8.1 maek234 4 4,069 07-05-2014, 04:15 AM
Last Post: Mr. Bougo
  [SOLVED] Installing Xonotic git in debian Ari 5 5,649 01-30-2014, 10:27 PM
Last Post: Ari
  [SOLVED] Missing shader previews / lack of authoritative Netradiant help Greaserpirate 6 4,605 09-17-2013, 01:11 AM
Last Post: Mr. Bougo
  [NEEDS INFO] Compiling NetRadiant (Ubuntu 11.10) uDelta 2 3,398 07-15-2013, 10:50 AM
Last Post: machine!
  [FIXED] Map compiling problems machine! 3 4,117 07-02-2013, 11:52 AM
Last Post: Ingar
  [SOLVED] Compiling NetRadiant: Missing dependencies Maddin 16 10,564 06-04-2013, 12:54 PM
Last Post: aa

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-