Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server crashing when vehicles allowed to capture

#1
Damn wrong forum, plz move thread to server forum.

I've set up my vehicle server to allow flag capture with vehicles but seems it crashes once in a while when the vehicle cap a flag.


THis is the last line before the server shuts down. I'm runnong .07 git but not the latest. I guess I should update it but its hard to test it when there's no players after the crash for a while lol.

PHP Code:
^7dropped_origin '2048 -2048 1765.03125'
^7nearestwaypoint entity 1288
^7last_respawn   1149.2135
^7Host_ErrorserverProgram error in function TeamScore_AddToTeam:
^
7Adding score to invalid team!
^
7Tipread above for entity information
^7
^7QuakeC crash report for server:
^
7s63885scores.qc:102STORE_F    GLOBAL27897GLOBAL27898
^7s63886scores.qc:102: ^5IFNOT      GLOBAL27897statement 63921
^7s63887scores.qc:102: ^2AND        GLOBAL27898GLOBAL27898GLOBAL27897
^7s63888scores.qc:102: ^5IFNOT      GLOBAL27897statement 63893
^7s63889scores.qc:104: ^5IFNOT      gameover (=0), statement 63891
^7s63890scores.qc:105: ^5RETURN     GLOBAL17241
^7s63891scores.qc:106STORE_S    GLOBAL23501GLOBAL4
^7s63892scores.qc:106: ^3CALL1      error (=error())
^
7   scores.qc:106 TeamScore_AddToTeam statement 11
^7   scores.qc:123 TeamScore_Add statement 3
^7   scores.qc:362 PlayerTeamScore_Add statement 9
^7mutators/gamemode_ctf.qc:535 ctf_Handle_Pickup statement 154
^7mutators/gamemode_ctf.qc:847 ctf_FlagTouch statement 66
^7Host_ShutdownServer
^7LHNET_Writesendto returned errorNetwork is unreachable
^7LHNET_Writesendto returned errorNetwork is unreachable
^7Client "^x5C0arshico^7" dropped
^7^7^x5C0arshico^7^4 disconnected
^7relink0 bots seen.
^
7Client "Underdead" dropped
^7^7Underdead^4 disconnected
^7relink0 bots seen.
^
7Client "lagresseur" dropped
^7^7lagresseur^4 disconnected
^7relink0 bots seen.
^
7Client "Player_REH" dropped
^7^7Player_REH^4 disconnected
^7relink0 bots seen.
^
7Client "" dropped
^7^7^4 disconnected
^7relink0 bots seen.
^
7Client "DeadDred" dropped
^7^7DeadDred^4 disconnected
^7relink0 bots seen.
^
7Client "^xF1DTaraxacum^7" dropped
^7^7^xF1DTaraxacum^7^4 disconnected
^7^7^xF1DTaraxacum^7^7 lost the ^1RED^7 flag
^7relink0 bots seen.
^
7Quake ErrorHost_ErrorserverProgram error in function TeamScore_AddToTeam:
^
7Adding score to invalid team!
^
7Tipread above for entity information
^7
^7Host_ShutdownServer
====== Log stopped (Wed Jul 31 17:57:21 2013) ====== 
[MoFo] Servers - North America - Hosted in Kansas USA - Admin DeadDred [MoFo]
Reply

#2
(07-31-2013, 11:12 AM)end user Wrote: Damn wrong forum, plz move thread to server forum.

Fixed.
[Image: 249.png] Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out my Newbie Corner!
<ZeRoQL> i think i got 1 proper quad and that cunt halogen fuck me over with a laser
Reply

#3
Ok another players said it also crashed when he jumped into t a speedster with a flag.
[MoFo] Servers - North America - Hosted in Kansas USA - Admin DeadDred [MoFo]
Reply

#4
That particular feature haven't been tested in some time and its apparently broken. I'm not sure if theres anyone maintaining vehicles code at all anymore, so for now i would just turn it off. Also if you want any sort of chance for this to get fixed, take it to the tracker.
Reply

#5
(08-01-2013, 02:02 AM)tZork Wrote: That particular feature haven't been tested in some time and its apparently broken. I'm not sure if theres anyone maintaining vehicles code at all anymore, so for now i would just turn it off. Also if you want any sort of chance for this to get fixed, take it to the tracker.

I've updated the git version and hasn't happened in a few games so hopefully was a anomoly. I also have flag passing with vehicles set so will try that off.
[MoFo] Servers - North America - Hosted in Kansas USA - Admin DeadDred [MoFo]
Reply

#6
Please report the bug, though, and update this thread with the url to the bug report.
Reply

#7
Ok well I got the same thing using overkill mod (zykure/overkillmerge branch) but with no modifications to vehicles.

Quake Error: Host_Error: server: Program error in function TeamScore_AddToTeam:
Adding score to invalid team!
Tip: read above for entity information


I haven't tried a vanilla xon vehicles as I don't know enough people to test it when I need to.

I'll post a bug report today.
[MoFo] Servers - North America - Hosted in Kansas USA - Admin DeadDred [MoFo]
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  Docker Xonotic Dedicated Server ich777 15 2,510 10-08-2020, 11:15 AM
Last Post: BuddyFriendGuy
  BuddyFriendGuy Fun Server BuddyFriendGuy 22 7,957 10-08-2020, 11:14 AM
Last Post: BuddyFriendGuy
Rainbow Kotangєns' independent server Kotangens 2 432 10-07-2020, 05:08 AM
Last Post: L497
  RaspberryPi4 Server ablyveiled 2 636 08-19-2020, 10:36 PM
Last Post: ballerburg9005
Question [NEED HELP] Server uses 40% CPU whereas Nexuiz server runs with max 10% e-pig 6 2,060 08-19-2020, 10:17 PM
Last Post: ballerburg9005
  [SOLVED] I can't create my server. Kotangens 11 1,043 07-22-2020, 04:42 AM
Last Post: Kotangens
Information [SOLVED] Server stops when I close command prompt on my PC Jewel 2 497 06-01-2020, 07:11 AM
Last Post: Jewel
  Server Hosting Issue Saevus 2 547 04-30-2020, 06:16 PM
Last Post: Saevus
  Server error "Weapon stats writing failed: -404" FlufyBuny 2 1,051 04-08-2020, 02:41 PM
Last Post: jwabbitt
  [NEED HELP] Server dont appear in server browser abslimit 0 558 03-15-2020, 04:13 AM
Last Post: abslimit

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-