Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Unable to run Xonotic game in PC-BSD 10.0.2

#1
I am new user but I saw Xonotic game was available in App Cafe of PC-BSD 9.2. This is one of my favourite game. It seems like required libraries are missing. First I thought SDL is missing. But when I try to install it, it says:

Code:
sdl-1.2.15_4,2 already installed


Whenever I try to run it from terminal, it says:

Code:
pcbsd-user /usr/home/user/Games/Xonotic# sh xonotic-linux-glx.sh
ps: illegal argument: pulseaudio
usage: ps [-aCcdefHhjlmrSTuvwXxZ] [-O fmt | -o fmt] [-G gid[,gid...]]
          [-M core] [-N system]
          [-p pid[,pid...]] [-t tty[,tty...]] [-U user[,user...]]
       ps [-L]
Game is Xonotic using base gamedir data
Xonotic Linux 03:08:11 Jun  5 2013 - release
Kernel does not support lowering nice level again - cannot use niceness
Skeletal animation uses SSE code path
DPSOFTRAST available (SSE2 instructions detected)
execing quake.rc
execing default.cfg
execing defaultXonotic.cfg
execing sRGB-disable.cfg
menu: program is not loaded
execing weapons.cfg
execing cdtracks.cfg
execing mutator_new_toys.cfg
execing balanceXonotic.cfg
execing effects-normal.cfg
execing physicsX.cfg
execing turrets.cfg
execing unit_machinegun.cfg
execing unit_hk.cfg
execing unit_hellion.cfg
execing unit_mlrs.cfg
execing unit_flac.cfg
execing unit_fusreac.cfg
execing unit_plasma.cfg
execing unit_plasma2.cfg
execing unit_tesla.cfg
execing unit_phaser.cfg
execing unit_walker.cfg
execing unit_ewheel.cfg
execing vehicles.cfg
execing vehicle_racer.cfg
execing vehicle_raptor.cfg
execing vehicle_spiderbot.cfg
execing vehicle_bumblebee.cfg
execing crosshairs.cfg
execing gamemodes.cfg
execing ctfscoring-samual.cfg
execing notifications.cfg
execing commands.cfg
execing _hud_common.cfg
execing _hud_descriptions.cfg
execing hud_luminos.cfg
couldn't exec config.cfg
"maxplayers" set to "16"
execing data/campaign.cfg
execing config_update.cfg
execing font-xolonium.cfg
Warning: Could not expand $scr_centersize
Warning: Could not expand $scr_centersize
client: program is not loaded
execing autoexec/empty.cfg
execing autoexec.cfg
Loaded public key key_0.d0pk (fingerprint: Xon//KssdlzGkFKdnnN4sgg8H+koTbBn5JTi37BAW1Q=)
Loaded private ID key_0.d0si for key_0.d0pk (public key fingerprint: 8AEWoHwWzey9DiZ8O3/T4EPs5GUXqEK9fh+nWV3rAGQ=)
NOTE: this ID has not yet been signed!
Only need a signature for an existing key...
Signature generation in progress...
Client using an automatically assigned port
Client opened a socket on address 0.0.0.0:0
LHNET_OpenSocket_Connectionless: setsockopt(IPV6_V6ONLY) returned error: Protocol not available
Client failed to open a socket on address [0:0:0:0:0:0:0:0]:0
Loading OpenGL driver libGL.so.1
Unable to open symbol list for libGL.so.1
Unable to load GL driver "libGL.so.1"
Desired video mode fail, trying fallbacks...
Loading OpenGL driver libGL.so.1
Unable to open symbol list for libGL.so.1
Unable to load GL driver "libGL.so.1"
Loading OpenGL driver libGL.so.1
Unable to open symbol list for libGL.so.1
Unable to load GL driver "libGL.so.1"
Loading OpenGL driver libGL.so.1
Unable to open symbol list for libGL.so.1
Unable to load GL driver "libGL.so.1"
Loading OpenGL driver libGL.so.1
Unable to open symbol list for libGL.so.1
Unable to load GL driver "libGL.so.1"
Loading OpenGL driver libGL.so.1
Unable to open symbol list for libGL.so.1
Unable to load GL driver "libGL.so.1"
Loading OpenGL driver libGL.so.1
Unable to open symbol list for libGL.so.1
Unable to load GL driver "libGL.so.1"
Quake Error: Video modes failed
Invalid response from keygen server:
Reply

#2
As the logs say, you're missing OpenGL drivers. Do you have libgl installed? (The package might be named differently)
Reply

#3
When I did search, it retuned the following lines.
Code:
pcbsd-user /usr/home/user/Games/Xonotic# pkg search libgl
libglade2-2.6.4_7
libglade2-reference-2.6.4_1
libglademm-2.6.7_6
libglapi-9.1.7
libglesv2-9.1.7_1
libgltext-0.3.1_5
linux-f10-libglade2-2.6.3_1

Do you think libgl is in the list?
Reply

#4
I don't know, you know your distro better than I do. Is there no tool to search for a file in package repositories? You're looking for /usr/lib/libGL.so.1
Reply

#5
It seems like there is still something missing in repository. Xonotic is available in 9 but not in 10. I'll wait.
Reply

#6
Xonotic does not have to be available as a package for your system, really. If anything, we prefer that you get the game from our homepage because that will make your setup less exotic and therefore easier to troubleshoot should you ask for further support.

Do you have any driver package installed for your graphics card?
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
Question [NEED HELP] Certain maps crash my game :( flexo 3 1,248 10-24-2020, 11:53 PM
Last Post: BuddyFriendGuy
  [NEED HELP] cant start the game/ session lock problem skyghost47 1 156 10-24-2020, 11:50 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Unable to turn on gamepad for gameplay JJ^4884 1 173 10-09-2020, 07:11 AM
Last Post: Freddy
  [NEED HELP] Sound dissapears mid game mastablasta 0 160 10-01-2020, 12:27 PM
Last Post: mastablasta
Exclamation [SOLVED] macOS Sierra: -basedir /path/to/game iqxonotic 11 27,202 09-09-2020, 02:04 PM
Last Post: dixius99
  [BUG] The game seems doesn't recognize virtual 7.1 noctiveqc 2 834 02-17-2019, 02:10 AM
Last Post: martin-t
Exclamation [BUG] *ubuntu 18.04/nVidia v415-Desktop Screen Corruption After Exiting Game? JeZxLee 2 1,207 01-06-2019, 05:15 AM
Last Post: SpiKe
  [NEED HELP] Custom Game Modes 3agle427 5 1,490 12-30-2018, 12:44 AM
Last Post: Lyberta
  [SOLVED] Game displays [x] joined the [y] team upon connecting Bloodthorn 3 1,283 09-17-2018, 01:52 AM
Last Post: Lyberta
  [SOLVED] Cannot run game anymore after new git update Bloodthorn 2 1,230 07-25-2018, 07:20 AM
Last Post: Bloodthorn

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-