Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Unable to run Xonotic game in PC-BSD 10.0.2

I am new user but I saw Xonotic game was available in App Cafe of PC-BSD 9.2. This is one of my favourite game. It seems like required libraries are missing. First I thought SDL is missing. But when I try to install it, it says:

sdl-1.2.15_4,2 already installed

Whenever I try to run it from terminal, it says:

pcbsd-user /usr/home/user/Games/Xonotic# sh
ps: illegal argument: pulseaudio
usage: ps [-aCcdefHhjlmrSTuvwXxZ] [-O fmt | -o fmt] [-G gid[,gid...]]
          [-M core] [-N system]
          [-p pid[,pid...]] [-t tty[,tty...]] [-U user[,user...]]
       ps [-L]
Game is Xonotic using base gamedir data
Xonotic Linux 03:08:11 Jun  5 2013 - release
Kernel does not support lowering nice level again - cannot use niceness
Skeletal animation uses SSE code path
DPSOFTRAST available (SSE2 instructions detected)
execing quake.rc
execing default.cfg
execing defaultXonotic.cfg
execing sRGB-disable.cfg
menu: program is not loaded
execing weapons.cfg
execing cdtracks.cfg
execing mutator_new_toys.cfg
execing balanceXonotic.cfg
execing effects-normal.cfg
execing physicsX.cfg
execing turrets.cfg
execing unit_machinegun.cfg
execing unit_hk.cfg
execing unit_hellion.cfg
execing unit_mlrs.cfg
execing unit_flac.cfg
execing unit_fusreac.cfg
execing unit_plasma.cfg
execing unit_plasma2.cfg
execing unit_tesla.cfg
execing unit_phaser.cfg
execing unit_walker.cfg
execing unit_ewheel.cfg
execing vehicles.cfg
execing vehicle_racer.cfg
execing vehicle_raptor.cfg
execing vehicle_spiderbot.cfg
execing vehicle_bumblebee.cfg
execing crosshairs.cfg
execing gamemodes.cfg
execing ctfscoring-samual.cfg
execing notifications.cfg
execing commands.cfg
execing _hud_common.cfg
execing _hud_descriptions.cfg
execing hud_luminos.cfg
couldn't exec config.cfg
"maxplayers" set to "16"
execing data/campaign.cfg
execing config_update.cfg
execing font-xolonium.cfg
Warning: Could not expand $scr_centersize
Warning: Could not expand $scr_centersize
client: program is not loaded
execing autoexec/empty.cfg
execing autoexec.cfg
Loaded public key key_0.d0pk (fingerprint: Xon//KssdlzGkFKdnnN4sgg8H+koTbBn5JTi37BAW1Q=)
Loaded private ID key_0.d0si for key_0.d0pk (public key fingerprint: 8AEWoHwWzey9DiZ8O3/T4EPs5GUXqEK9fh+nWV3rAGQ=)
NOTE: this ID has not yet been signed!
Only need a signature for an existing key...
Signature generation in progress...
Client using an automatically assigned port
Client opened a socket on address
LHNET_OpenSocket_Connectionless: setsockopt(IPV6_V6ONLY) returned error: Protocol not available
Client failed to open a socket on address [0:0:0:0:0:0:0:0]:0
Loading OpenGL driver
Unable to open symbol list for
Unable to load GL driver ""
Desired video mode fail, trying fallbacks...
Loading OpenGL driver
Unable to open symbol list for
Unable to load GL driver ""
Loading OpenGL driver
Unable to open symbol list for
Unable to load GL driver ""
Loading OpenGL driver
Unable to open symbol list for
Unable to load GL driver ""
Loading OpenGL driver
Unable to open symbol list for
Unable to load GL driver ""
Loading OpenGL driver
Unable to open symbol list for
Unable to load GL driver ""
Loading OpenGL driver
Unable to open symbol list for
Unable to load GL driver ""
Quake Error: Video modes failed
Invalid response from keygen server:

As the logs say, you're missing OpenGL drivers. Do you have libgl installed? (The package might be named differently)

When I did search, it retuned the following lines.
pcbsd-user /usr/home/user/Games/Xonotic# pkg search libgl

Do you think libgl is in the list?

I don't know, you know your distro better than I do. Is there no tool to search for a file in package repositories? You're looking for /usr/lib/

It seems like there is still something missing in repository. Xonotic is available in 9 but not in 10. I'll wait.

Xonotic does not have to be available as a package for your system, really. If anything, we prefer that you get the game from our homepage because that will make your setup less exotic and therefore easier to troubleshoot should you ask for further support.

Do you have any driver package installed for your graphics card?

Possibly Related Threads…
Thread Author Replies Views Last Post
  [BUG] wonky user stats (I'm in a game today, by I'm last seen 1 month ago?) snailtrail 6 2,471 09-25-2022, 05:40 AM
Last Post: SpiKe
  [NEED HELP] Menu Won't Load, Game Crashes EdwardHamHam 1 2,598 07-21-2022, 01:44 AM
Last Post: BuddyFriendGuy
Question [NEED HELP] Certain maps crash my game :( flexo 6 3,086 01-17-2022, 08:55 PM
Last Post: flexo
Exclamation [SOLVED] macOS Sierra: -basedir /path/to/game iqxonotic 12 40,739 12-11-2021, 12:46 PM
Last Post: NappyHead
  [SOLVED] reload map changes in game Nyx 6 1,616 08-19-2021, 12:46 PM
Last Post: Julius
  [NEED HELP] cant start the game/ session lock problem skyghost47 1 2,157 10-24-2020, 11:50 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Unable to turn on gamepad for gameplay JJ^4884 1 1,887 10-09-2020, 07:11 AM
Last Post: Freddy
  [NEED HELP] Sound dissapears mid game mastablasta 0 974 10-01-2020, 12:27 PM
Last Post: mastablasta
  [BUG] The game seems doesn't recognize virtual 7.1 noctiveqc 2 1,824 02-17-2019, 02:10 AM
Last Post: martin-t
Exclamation [BUG] *ubuntu 18.04/nVidia v415-Desktop Screen Corruption After Exiting Game? JeZxLee 1 2,759 01-06-2019, 05:15 AM
Last Post: SpiKe

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-