Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Trouble with launch Xonotic on Mac OS X

Oh hi!
I'm trying to play Xonotic first time and I can't launch the game.

I was downloaded a zip file from the main page by this link:

I was unzipped file to "Download" folder, and try to launch I instantly get an error. No loading window, no splashscreen, just the error.
Then I was move the game folder to the Application folder, but I was get the same result.

[Image: download?id=mvQmplMn9qgRWjhh7hEZuBJs12GboR]

I use Macbook Pro with exectly that specs:
OS X Yosemite 10.10.2 (14C109)

If some feedback will help you, feel free to ask me launch something in terminal or make some tests.

May be this information will be helpfull:
— Some time ago I was installed Fallout 1,2 from pirateBay and launcher ask me to install XQuartz-2.7.7.
— I was launch another Quake-based shooter "Warsow" and it was lauch ok.


There is an full error message:
Process:               xonotic-osx-sdl-bin [491]
Path:                  /Applications/Xonotic/
Identifier:            xonotic-osx-sdl-bin
Version:               ???
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           xonotic-osx-sdl-bin [491]
User ID:               501

Date/Time:             2015-03-10 11:25:43.066 +0500
OS Version:            Mac OS X 10.10.2 (14C109)
Report Version:        11
Anonymous UUID:        548FC414-5411-4FC0-3481-735C7E46D90D

Time Awake Since Boot: 440 seconds

Crashed Thread:        0

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @rpath/SDL2.framework/Versions/A/SDL2
  Referenced from: /Applications/Xonotic/
  Reason: image not found

Binary Images:
    0x7fff6ae04000 -     0x7fff6ae3a837  dyld (353.2.1) <65DCCB06-339C-3E25-9702-600A28291D0E> /usr/lib/dyld
    0x7fff862a9000 -     0x7fff8631bff7 (2.0.2 - 1050.10.8) <FDFB1FBE-6A0E-3D63-828C-CD53500FCB0F> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
    0x7fff89986000 -     0x7fff89997ff7  libz.1.dylib (55) <88C7C7DE-04B8-316F-8B74-ACD9F3DE1AA1> /usr/lib/libz.1.dylib
    0x7fff8ba41000 -     0x7fff8ba42fff  libSystem.B.dylib (1213) <90B107BC-FF74-32CC-B1CF-4E02F544D957> /usr/lib/libSystem.B.dylib

Model: MacBookPro10,1, BootROM MBP101.00EE.B07, 4 processors, Intel Core i7, 2.6 GHz, 16 GB, SMC 2.3f36
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In
Graphics: NVIDIA GeForce GT 650M, NVIDIA GeForce GT 650M, PCIe, 1024 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D5434314753364D465238432D50422020
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D5434314753364D465238432D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xEF), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.3.2f6 15235, 3 services, 19 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM512E, 500.28 GB
USB Device: Hub
USB Device: FaceTime HD Camera (Built-in)
USB Device: Hub
USB Device: Hub
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB Receiver
Thunderbolt Bus: MacBook Pro, Apple Inc., 23.4

Hi and welcome - can you check out this thread: ?
Maybe the solution described there works for you.
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!


(03-10-2015, 06:34 AM)Halogene Wrote: Hi and welcome - can you check out this thread: ?
Maybe the solution described there works for you.

Thank you! It is works!

I was download SDL Runtime Binaries from that page:

and copyed files from the package to /Library/Frameworks/

I think the game should install that framework automaticly.

bump for madskillz Smile

(03-10-2015, 07:38 AM)kanatov Wrote: I think the game should install that framework automaticly.

I agree, it should. Hopefully the next Xonotic release will just work.

I've installed SDL,and I don't know where the Library thing is.

Oh,I found it.

Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED] Xonotic won't launch on Win10 noChance79 7 6,141 06-23-2023, 09:49 AM
Last Post: Cofein
  [NEED HELP] Trouble with setting up a non-local private server spaceenfix 3 3,444 03-22-2023, 12:53 AM
Last Post: FAF
  [SOLVED] Trouble unzipping cygiconv-2.dll on Windows 7 (0.8.5) papa 3 4,283 10-19-2022, 05:01 PM
Last Post: mrhip
  [NEED HELP] Cannot launch xonotic-linux64-dedicated server (v0.8.5) in Ubuntu18.04 ff8eyes 3 1,670 08-13-2022, 02:43 AM
Last Post: FAF
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 1,601 04-24-2019, 10:41 PM
Last Post: Space Ace
  [NEED HELP] Segmentation fault on launch Gouldron 0 2,053 04-06-2019, 02:54 PM
Last Post: Gouldron
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 2,665 03-29-2019, 11:19 AM
Last Post: Freddy
  [BUG] Fkeys F-keys F keys not working Mac OS Sierra 0.8.22 Space Ace 8 4,112 10-02-2017, 10:04 PM
Last Post: Space Ace
  [NEED HELP] Mac OSX Crashing very often and randomly -MCSquare- 0 2,103 01-30-2016, 12:08 AM
Last Post: -MCSquare-
  [NEED HELP] Xonotic 0.8 completely froze my Mac a few times Player110 0 2,082 06-23-2015, 02:16 PM
Last Post: Player110

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-