Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] texture shows in NetRadiant but not in game

Question 1:

I'm learning about mapping but I got stuck with this likely-to-be-very-basic problem:

I managed to have 6 custom textures shown in NetRadiant:


but I couldn't figure out why it doesn't show in the actual game:


I'm attaching the pk3 file. (Please ignore the readme file. That was for another game and doesn't apply to this map at all.)

Question 2:

Am I even using the texture wrong? What I'm trying to do is just some calligraphy art on the wall, as decoration.

Question 3:

I understand Oblivian led a discussion on setting the artistic guideline for the game (and I agree at that). I assume it's for the official art/maps only. Unofficial mappers are not discouraged to make whatever, correct?

Attached Files
.pk3   bfg_fly_or_die.pk3 (Size: 789.1 KB / Downloads: 3)

I don´t have a working NetRadiant so I´m not able to have a look at your map but it seems like you are using so called decals the wrong way. Create your walls as usual (with no cut off parts!) and then place a thin brush on top of that wall. You are currently seeing the black background void because your decal shader renders partially transparent (with the opaque part being black too in your case!).

Oh and you might want to turn off gl_picmip. Wink Press Shift+Esc and enter:
gl_picmip_world 0

Thank you, @Maddin. You are right: gl_picmip_world made the shaders visable now (dark transparent, as you said), so at least I know it's getting the right paths. I'll go learn about decals.

It's incredible you can tell where the problem is without even seeing the map!

Thank you! Glad I could help!

Well, I have a couple of years of experience in mapping so I kind of see the all the polygons as I walk through a map... Big Grin It is simply experience which lets you see things, nothing special.

Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 4 384 08-18-2019, 10:11 PM
Last Post: Lyberta
  [NEED HELP] Netradiant looks weird when i try to open it Taplio 0 316 07-07-2019, 02:19 PM
Last Post: Taplio
  [NEED HELP] NetRadiant crashes on Build - Mac (10.12.6) Space Ace 0 405 04-24-2019, 10:41 PM
Last Post: Space Ace
  [NEED HELP] NetRadiant doesn't compile on Mac nokko 3 603 03-29-2019, 11:19 AM
Last Post: Freddy
  [BUG] The game seems doesn't recognize virtual 7.1 noctiveqc 2 472 02-17-2019, 02:10 AM
Last Post: martin-t
Exclamation [BUG] *ubuntu 18.04/nVidia v415-Desktop Screen Corruption After Exiting Game? JeZxLee 2 605 01-06-2019, 05:15 AM
Last Post: SpiKe
  [NEED HELP] Custom Game Modes 3agle427 5 838 12-30-2018, 12:44 AM
Last Post: Lyberta
  [BUG] Checkpoint timer fades too quickly, shows wrong values Bloodthorn 6 973 11-03-2018, 04:24 PM
Last Post: Bloodthorn
  [SOLVED] Game displays [x] joined the [y] team upon connecting Bloodthorn 3 893 09-17-2018, 01:52 AM
Last Post: Lyberta
Exclamation [SOLVED] macOS Sierra: -basedir /path/to/game iqxonotic 8 11,915 09-08-2018, 05:55 AM
Last Post: ComicsNights

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-