Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Textures not showing in NetRadiant

#1
Hi, I've just downloaded Xonotic and NetRadiant to mess around with an old map (converted from BSP to MAP). I can open the map fine, but all textures are missing, so all textures are shown as Shader Not Found. This is not really a problem, as I wanted to retexture the map anyway.

The problem is that when I press 't' and open the texture window, ALL textures are either listed as "Shader Image Missing" or "Shader Not Found" - several "folders" are listed, but not a single texture is loaded correctly, not even the common textures (caulk, clip, etc).

Does anyone know what I am missing? From what I can see, all the configuration settings (paths, etc) should be correct.


Thanks in advance,
Reply

#2
What is the path pointing at? And what does the console at the bottom of NetRadiant say?

Try Texture Browser > Tools > Flush & Reload Shaders.
Reply

#3
Make sure the textures for the map if they are not native xon textures are placed into your_xon_install/data/textures
[MoFo] Servers - North America - Hosted in Montreal Canada - Admin DeadDred [MoFo]
Reply

#4
Hi,

You probably need the mapping-support archive.
You can download it along with NetRadiant here: http://dl.xonotic.org/xonotic-0.8.1-mappingsupport.zip

Simply extract this file, then move "xonotic-20150825-maps-mapping.pk3" to Xonotic/data.
Reply

#5
(10-12-2015, 11:33 AM)SpiKe! Wrote: Hi,

You probably need the mapping-support archive.
You can download it along with NetRadiant here: http://dl.xonotic.org/xonotic-0.8.1-mappingsupport.zip

Simply extract this file, then move "xonotic-20150825-maps-mapping.pk3" to Xonotic/data.

SpiKe!
Thanks for the link, you're right I didn't have the file, but unfortunately that wasn't the solution (for me).

I noticed that in that download, there is a copy of NetRadiant (an older version), I've also tried that version, same result. All textures fail to load!

The first error message I can see in the logs is:
Unable to find default tag file F:/app/NetRadiant/xonotic.game/shadertags.xml. No tag support.

I've reviewed both xonotic.game folders in both version of NetRadiant that I have and that file is missing in both, so I guess it's not really needed!?!?
Reply

#6
This seems to be a common problem...

There are a few solutions in these threads, try them and see which does the trick.
[Image: 230.png]
Reply

#7
Forget what I just posted!

All textures are now loading Smile

I somehow messed up when extracting the support pk3 file...

Thanks SpiKe!
Reply

#8
Hi, I have been trying to map xonotic as well.
I have mapped for Alien Arena, Tremulous, Urban Terror, Warsow (kinda) and recently I have been trying to map for xonotic.
I'm having this same problem, but even when i extract the stuff into the right location (xonotic in my saved games folder) I get no textures at all in NetRadiant.
Am I doing something reaally n00by or is this just a normal problem?
I have been searching the forums for the past 2 hours and tried everything i found but nothing is working.
This is probably not the best place to post this but i didnt want to make ANOTHER thread about the same problem. (spamming reasons)

Please help!

EDIT: I might be using the wrong path ._. What's the path that I should be using?
Reply

#9
NetRadiant on Windows doesn't use the Saved Games folder, it uses the main Xonotic installation directory.
[Image: 230.png]
Reply

#10
Yeah, that's the path I'm using, but no textures pop up.

EDIT:

Never mind, I just read your post wrong. I realized what I did wrong. Thanks for pointing out my general n00by stupidity! ^_^
Reply

#11
Somebody should do a video explaining from head to toe how to extract and launch Netradiant properly, I've myself never gotten through this:

[Image: MKBtwau.png]

It's always this message no matter what I do.
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
Rainbow NetRadiant-custom Garux 25 12,898 03-06-2024, 04:31 PM
Last Post: anoob
  Updated Xonotic gamepacks for NetRadiant and NetRadiant-custom SpiKe 2 1,944 06-25-2023, 06:02 PM
Last Post: anoob
  [NEED HELP] No Spawn Point In NetRadiant Map daspeller 0 24,885 10-19-2022, 07:22 PM
Last Post: daspeller
Information Updated NetRadiant builds illwieckz 7 8,104 06-29-2022, 02:33 AM
Last Post: illwieckz
  Can't get netradiant to work with Xonotic NoClue 2 2,517 06-14-2022, 01:25 PM
Last Post: NoClue
  [NEED HELP] Custom NetRadiant Textures / Textures Not Loading 3agle427 3 4,124 09-03-2021, 01:40 PM
Last Post: HIBANEZ
  Netradiant brush outline in 2D view grid mode Nyx 2 1,686 08-05-2021, 12:27 AM
Last Post: Nyx
  NetRadiant for Xonotic? Betaversion 3 2,506 12-22-2020, 02:35 PM
Last Post: Betaversion
  Textures: evillair's eU Texture Set Julius 1 1,799 11-27-2020, 12:29 PM
Last Post: Julius
  [NEED HELP] NetRadiant Models Not Working 3agle427 7 5,491 06-26-2020, 11:40 AM
Last Post: DarkFox

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-