Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] -basedir /path/to/game

#1
Hi

I cant get Xonotic to run.

Running elementary OS, downloaded game from official website in June 2016, unpacked zip. Game was working fine for 2 weeks before leaving out of state for work for a month. I get back and game wont work.

Attempting to launch game by clicking on either xonotic-linux64-glx or xonotic-linux64-sdl within unpacked folder.
Both result in a page 'You have reached this menu due to missing or unlocatable content/data'

I have tried launching via terminal and notice the following results:

Wow, OK I just attempted launching from terminal to retrieve the error messages I have been getting and the game opened!
So there is something going on here.
I updated and upgraded my distro several times during this issue with no luck but somehow it appears to be working this morning. PC was restarted after upgrades.

Before I was getting an error message, something about being locked and needing to assign a unique sessionid

I performed a rm of the entire Xonotic folder and re-downloaded the game last night. Tried using the updater twice with no luck.
Interesting, after deleting the entire folder and downloading the game again all my user information is still intact (user name, key mappings etc)

Maybe my distro is causing problems?
Could the dashes in the launch name be causing problems 'xonotic-linux64-sdl'
Reply

#2
The problem is that your filemanager does not launch the game with the right working directory.
On linux, you should always use the .sh scripts because they make sure that your basedir is correct.

If you get an error message about lock or sessionid, it means that one xonotic instance is already running. Maybe you started the -dedicated version, which is only the server.

User information is kept in ~/.xonotic
Reply

#3
To elaborate a bit more:

1. There is rarely a need to re-download the game (except for upgrading to the newer version). Once you get it running, it runs. Problems are usually on your setting, not with the game program itself.

2. If you are having lock problem, try this command (when you are not running Xonotic):

Code:
rm -f ~/.xonotic/lock*

And re-run Xonotic again. If it still doesn't work, please run this command and paste the result here for us to see:

Code:
ls -l ~/.xonotic
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Game displays [x] joined the [y] team upon connecting Bloodthorn 3 223 09-17-2018, 01:52 AM
Last Post: Lyberta
Exclamation [SOLVED] macOS Sierra: -basedir /path/to/game iqxonotic 8 8,371 09-08-2018, 05:55 AM
Last Post: ComicsNights
  [SOLVED] Cannot run game anymore after new git update Bloodthorn 2 289 07-25-2018, 07:20 AM
Last Post: Bloodthorn
  [NEEDS INFO] Game Crash On Load Castor 0 530 05-31-2018, 09:06 AM
Last Post: Castor
Photo [NEED HELP] When in game, the guns keep firing, sometimes doesn't fire when pointed at a target. U1Y5Y5 3 827 09-12-2017, 01:28 PM
Last Post: SpiKe
  [NEED HELP] game modes/mods/types clarification BuddyFriendGuy 13 3,867 06-12-2016, 12:18 AM
Last Post: BuddyFriendGuy
  [FIXED] How do I pause game while having the console open? Beagle 8 2,693 05-14-2016, 02:35 PM
Last Post: Beagle
  [SOLVED] -basedir /path/to/game? :P 7 3,863 11-28-2015, 06:57 AM
Last Post: PinkRobot
  [NEEDS INFO] Game crashes while loading - could not load texture "overkillbullet" |OSiRiS| 5 2,681 10-17-2015, 03:44 PM
Last Post: BuddyFriendGuy
  [SOLVED] texture shows in NetRadiant but not in game BuddyFriendGuy 3 2,500 04-02-2015, 05:18 AM
Last Post: Maddin

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-