Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Random failures to register mouse input

#1
I'm encountering random failures to register mouse input recently. It started about this week, I first thought, it would be network issues, but then I tried it locally and it happens there too.

What is happening: mouse clicks don't get registered randomly. Some times the release event doesn't register as well. At one point I even had the mouse going from continuous primary fire (left click) to secondary fire (right click) WITHOUT me even touching the mouse - I was chatting about the weird behavior! This happens a lot, especially but not exclusively in fights. Some times several clicks fail to register in a row, I think 4 or 5 clicks in a row is personal best score. Basically I don't survive an opponent encounter because I am unable to fire a single shot.

I am running Arch Linux on an intel i5 /GTX660 TI. I even did a clean install of Arch linux today and made a fresh clone of Xonotic git. The issue persists.

I tried also with a different mouse.

Now I believe this may not at all be caused by Xonotic, but is someone else maybe experiencing similar issues (even on local games)?
[Image: 249.png] Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out my Newbie Corner!
<ZeRoQL> i think i got 1 proper quad and that cunt halogen fuck me over with a laser
Reply

#2
Hi Halogene,

I encountered the same issue on ArchLinux after Plasma 5.10 update.
If you use KDE/Plasma: disable the left touchscreen action (System Configuration -> Workspace behavior -> Touchscreen -> uncheck the left action).
Restart kwin afterwards, or simply reboot your PC.

I didn't find this solution alone, EACFreddy did.
Thanks Freddy! Smile

Relevant KDE bug report: https://bugs.kde.org/show_bug.cgi?id=380476
Stats | Maps: CTF: disarray, vinegar, metro DM: labyrinth Duel: cucumber, quark.
Reply

#3
AWESOME.

You guys really rock. Thanks for sharing this, you made my day!

Will mark as solved when I can verify it's fixed
[Image: 249.png] Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out my Newbie Corner!
<ZeRoQL> i think i got 1 proper quad and that cunt halogen fuck me over with a laser
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 184 08-18-2019, 03:14 AM
Last Post: FAF
  [NEED HELP] Strange input lag and graphics lag in 0.8.2 mrdoklata 3 2,468 04-21-2017, 11:00 PM
Last Post: -z-
  [NEEDS INFO] Input lag? dylstew 11 5,843 10-06-2016, 05:07 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] Menu mouse cursor stuck in invisible box nAnXiety 1 1,483 09-16-2016, 03:30 PM
Last Post: martin-t
  [NEEDS INFO] mouse lag mumin 3 1,593 03-17-2016, 05:29 AM
Last Post: Maddin
  [SOLVED] Mouse limited to reduced area at higher resolutions / DPI Ishatix 5 3,795 03-14-2015, 06:54 AM
Last Post: Mr. Bougo
  [NEED HELP] GUI Mouse Problem with GLX Slackhead 2 2,291 08-31-2014, 04:22 AM
Last Post: Slackhead
  [NEED HELP] Mouse warping deoxys 0 1,570 12-15-2013, 06:03 PM
Last Post: deoxys
  [SOLVED] Xonotic Random Crashes! PostalDude 7 4,777 06-10-2013, 02:29 PM
Last Post: Mr. Bougo
  [NEEDS INFO] Mouse Accel issue Bolwind 17 10,797 10-09-2012, 12:54 PM
Last Post: Mr. Bougo

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-