Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Having trouble getting transparent textures to work

I'm trying to set up a basic window texture with transparency, but it doesn't appear to be working at the moment.

I originally went with a 32bit .TGA with an alpha channel, but this didn't appear to work correctly. I then tried using separate .jpg images. Neither has worked.

I've currently got three image files:
  • glass-lineframe.jpg
  • glass-lineframe_alpha.jpg
  • glass-lineframe_gloss.jpg
I've also tried a simple shader script (basically taking the hexglass shader and substituting my image name). Still nothing.
       q3map_bouncescale 3
       qer_editorimage textures/map_aeris/glass-lineframe.jpg
       dpreflectcube cubemaps/default/sky
       surfaceparm trans
       surfaceparm alphashadow
       q3map_lightmapSampleSize 64
               map textures/map_aeris/glass-lineframe.jpg
               blendfunc blend
               rgbgen lightingDiffuse
               map $lightmap
               blendfunc GL_DST_COLOR GL_ZERO
               rgbGen identity
The two main things I'm trying to accomplish are:
  • Have the texture render with transparency.
  • Have vis/light allow light through the texture when they calculate lightmaps

Attached Files Thumbnail(s)


Ok - tried that. Doesn't appear to have changed anything :/

Hmm, is there any way to see what shaders are being applied, I've been combing the output from the map build and noticed the following line:
Map has shader script /home/notavi/.xonotic/data/maps/../scripts/q3map2_aeris.shader
But that's not the shader script I created and I can't see it inside that path.... 
It does then proceed to parse the correct script but I've got a sneaking suspiction NetRadiant is being "helpful" and generating a shader script for me which is overriding the one I'm deliberately preparing.
Not sure how to confirm or disprove this theory at the moment though...

There's a 'shaderlist.txt' next to all shaders you need to make one in the scripts folder like this if you haven't:

[Image: 68s8Q58.png]

It actually turned out to be something a lot dumber than that.
In my shader, the path that was typed was 'map-aeris', not 'map_aeris'.
Fixed that and now it's working properly.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Can't get netradiant to work with Xonotic NoClue 2 2,628 06-14-2022, 01:25 PM
Last Post: NoClue
  [NEED HELP] Custom NetRadiant Textures / Textures Not Loading 3agle427 3 4,342 09-03-2021, 01:40 PM
Last Post: HIBANEZ
  Textures: evillair's eU Texture Set Julius 1 1,967 11-27-2020, 12:29 PM
Last Post: Julius
  Textures: Xonotic Items as decals Julius 1 2,061 05-14-2020, 03:03 PM
Last Post: Garux
  Textures: Techy Julius 6 3,635 01-12-2019, 09:05 AM
Last Post: Julius
  Textures: Julius's Light Beams Julius 2 2,498 01-11-2019, 08:30 AM
Last Post: Julius
  Textures: Tabun Decals Julius 2 3,071 12-16-2018, 09:22 AM
Last Post: Julius
  Textures: Nobiax Impacts Julius 0 1,869 12-07-2018, 02:53 PM
Last Post: Julius
  How would i create glass textures? Molnija 2 2,719 10-28-2018, 01:07 PM
Last Post: Molnija
  I need help with textures. [Solved] TapX 5 4,441 05-11-2018, 02:22 PM
Last Post: Julius

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-