Create an account


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[TUTORIAL] Xonotic Server behind OPNSense (and pfSense)

#1
Information 
When NATting behind a OPNSense (or pfSense) firewall, setting up a port-forward is enough to let people manually connect to your Xonotic server when they know the IP and the port. However, the server is not showing up in the in-game server list or dpmaster.deathmask.net. This can be solved.
The description below is based on OPNSense, but it can probably be applied to pfSense too, because they share a lot. Some settings may be in a slightly different place or have a slightly different names though.

First: the port-forward:
  • Go to Firewall - NAT - Port Forward
  • Click +Add
  • Interface WAN
  • Protocol UDP
  • Destination WAN address
  • Destination port range (other) [port of Xonotic Server] (from en to)
  • Redirect target IP Single Host or Network [IP of Xonotic Server]
  • Redirect target port (other) [port of Xonotic Server]
Second: make outbound NAT rule:
This is to disable source port rewriting. Xonotic (and other Quak'ish games don't like it)
Read  more about it here.
  • Go to Firewall-NAT-Outbound
  • Click  on Hybrid outbound NAT rule generation
  • Click +Add
  • Interface WAN
  • Protocol UDP
  • Source Address Single host or Network [IP of Xonotic Server]/32
  • Source port (other) [port of Xonotic Server]
  • Destination address any
  • Destination port any
  • Enable Static-port

Especially the last is very important!
I hope this helps some people.
I'm leaving this here because it took me ages to find this out.
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  I can't see my listen server on server list fnmain 1 787 10-07-2023, 07:28 AM
Last Post: Grimnack
  Server not visible on the server browser for others or me DankoLord 1 1,891 02-21-2023, 08:02 PM
Last Post: ballerburg9005
  Xonotic server running behind UDP proxy not working doombringeroperator 3 4,190 11-21-2022, 11:00 AM
Last Post: Zaphod
  BaI server | South American Xonotic server (located in Chile) z411 0 2,836 01-02-2022, 11:36 PM
Last Post: z411
  how to have blue team only with bots and red team 1 human player and 2 bots billyjoe 7 7,632 09-04-2021, 11:53 AM
Last Post: AndK
  Full server tutorial start-2-finish with maps & config from live server xonotic.us.to ballerburg9005 0 8,877 09-03-2021, 10:21 AM
Last Post: ballerburg9005
  Not listed on Sever browser with OPNsense firewall poVoq 5 2,704 01-17-2021, 07:07 PM
Last Post: poVoq
Question [NEED HELP] Server uses 40% CPU whereas Nexuiz server runs with max 10% e-pig 6 5,104 08-19-2020, 10:17 PM
Last Post: ballerburg9005
  [NEED HELP] Server dont appear in server browser abslimit 0 2,654 03-15-2020, 04:13 AM
Last Post: abslimit
  [SOLVED] Opensuse Leap 15.1 and Server.cfg ldegroot 2 2,648 08-01-2019, 02:52 PM
Last Post: ldegroot

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-