Create an account


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEED HELP] Xonotic on RaspPI - Setting up fonts

#1
Hello, I'm trying to test gameplay on a Raspberry PI Model 4 B (4Gb RAM). I load the game throught darkplaces -xonotic.
I had some trouble with the fonts as they look like unreadable blocks, which does not happen on the other platforms. Searching at the forum I found out a workaround using the loadfont command at the console:
loadfont user0 gfx/vera-sans 12

loadfont user1 gfx/vera-sans 12
loadfont user2 gfx/vera-sans 12
loadfont user3 gfx/vera-sans 12
loadfont console gfx/vera-sans 12
loadfont sbar gfx/vera-sans 12
loadfont notify gfx/vera-sans 12
loadfont chat gfx/vera-sans 12
loadfont centerprint gfx/vera-sans 12
loadfont infobar gfx/vera-sans 12
loadfont menu gfx/vera-sans 12

But as much as I searched, couldn't figure out how to set it up in a .cfg file instead of the default. Tried setting the menu_font_cfg and menu_forced_saved_cvars, but no luck, it comes back to default font-xolonium.cfg.
If I get another font and make a pk3 pack, can anyone enlighten me about where to put it and where to set it up (.cfg)?
Also, I still don't know why does this issue happens at this port. The only posible clue, if it has something to do with this, is this message error at console, but can't be sure:
ERROR: Texture compression is required but not supported.
Expect visual problems.

Thank you very much!


Attached Files Thumbnail(s)
   
Reply

#2
Hi all,

I got the exact same problem while trying to make Xonotic run on my son's Raspberry. Since I don't know how to open the console, I've downloaded and installed the Xolonium ttf fonts on the system... to no avail. Does anyone has a suggestion on how to run by default the font switching command proposed by gilius ?
That's really a pity since the game work like a charm after following the default installation process (apt install darkplaces ; download and install the zip ; darkplaces -xonotic -basedir /usr/local/share/games/Xonotic).

Thanks in advance for any kind of help.

PMA
Reply

#3
Based on the error message, I assume that the generated font
textures are stored in a compressed format, probably S3TC.
I don't know if or how this format can be activated on a Raspberry.
 
Possible workarounds:
 
In the game, open the console with Shift+Esc.
Type r_font_compress 0 and press Enter.
This may require a restart.
 
Alternatively, create a text file called autoexec.cfg
in the ~/.xonotic/data directory, next to config.cfg.
Then add the mentioned loadfont commands in there,
to run them automatically when you start the game.
 
Note that autoecex.cfg should not be included in a pk3 package.
Reply

#4
(12-27-2020, 08:16 AM)sev Wrote: Alternatively, create a text file called autoexec.cfg
in the ~/.xonotic/data directory, next to config.cfg.
Then add the mentioned loadfont commands in there,
to run them automatically when you start the game.
 
Note that autoecex.cfg should not be included in a pk3 package.

Hi, thank you very much. This last solution works perfectly.
Unfortunately I am not skilled enough to test the two other proposals.
Reply

#5
Will the Devs release Xonotic for RaspberryOS?
Reply

#6
[quote pid='86785' dateline='1609074977']
Alternatively, create a text file called autoexec.cfg
in the ~/.xonotic/data directory, next to config.cfg.
Then add the mentioned loadfont commands in there,
to run them automatically when you start the game.
 
Note that autoecex.cfg should not be included in a pk3 package.
[/quote]

This workaround did great! While there isn't compression support I can handle the issue with this.
Thanks!
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Trouble with setting up a non-local private server spaceenfix 1 122 11-22-2021, 10:27 AM
Last Post: Mario
  [NEED HELP] setting up server with custom maps le Bork 2 1,514 01-31-2019, 01:06 PM
Last Post: morosophos
  [SOLVED] No stat ID despite setting checkmarks Bloodthorn 9 3,234 10-06-2018, 07:08 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Setting up Xonotic on my school shared directory Bla1 11 3,940 03-09-2017, 03:15 PM
Last Post: Mr. Bougo
  [SOLVED] Help with setting for campaign (or whatever that is) forseti 14 8,703 02-06-2012, 03:14 PM
Last Post: Mr. Bougo

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-