Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEED HELP] NO Sound in Xonotic-0.86-GLX

#1
Hello!

Last week suddenly i have started to experience a full loss of sound in Xonotic 0.86. In more details, if I start GLX version then after ~ 1-15 minutes the sound is completely lost. In a strange way If I use bluetooth headphones sound is lost after a second. So the easiest way to reproduce the problem is too start a game with bluetooth on and the sound will be almost immediately lost.

Terminal output is

~/Games/xonotic-0.8.6/Xonotic$ ./xonotic-linux64-glx
Code:
Game is Xonotic using base gamedir data
gamename for server filtering: Xonotic
Xonotic Linux 03:14:04 Jun 20 2023 - release
Current nice level is below the soft limit - cannot use niceness
Skeletal animation uses SSE code path
DPSOFTRAST available (SSE2 instructions detected)
execing quake.rc
execing default.cfg
execing xonotic-common.cfg
...
execing cdtracks.cfg
execing commands.cfg
execing config.cfg
"maxplayers" set to "16"
execing data/campaign.cfg
execing config_update.cfg
execing font-xolonium.cfg
client: program is not loaded
execing autoexec/empty.cfg
execing autoexec.cfg
Loaded public key key_0.d0pk (fingerprint: Xon//KssdlzGkFKdnnN4sgg8H+koTbBn5JTi37BAW1Q=)
Loaded private ID key_0.d0si for key_0.d0pk (public key fingerprint: VLYxF3oHlQO7PTukT9II6BapeQkWz17l0a+8N0+e1Tw=)
there is already a signed private key for 0
execing post-config.cfg
Client using an automatically assigned port
Client opened a socket on address 0.0.0.0:0
Client opened a socket on address [0:0:0:0:0:0:0:0]:0
Loading OpenGL driver libGL.so.1
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: NVIDIA GeForce GTX 1050/PCIe/SSE2
GL_VERSION: 4.6.0 NVIDIA 470.223.02
vid.support.arb_multisample 1
vid.support.gl20shaders 1
NOTE: requested 1x AA, got 0x AA
Video Mode: fullscreen 1920x1080x32x0.00hz
NetWM fullscreen: actually using resolution 1920x1011
S_Startup: initializing sound output format: 48000Hz, 16 bit, 2 channels...
SndSys_Init: using the ALSA module
SndSys_Init: PCM device is "default"
Sound format: 48000Hz, 2 channels, 16 bits per sample
CDAudio_SysStartup: open of "/dev/cdrom" failed (2)
CDAudio_Init: No CD in player.
Can't get initial CD volume
CD Audio Initialized
NetWM fullscreen: actually using resolution 1920x1080
]quit


The system is Debian 12 GNOME


Code:
Bluetooth:
Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-10:3 chip-ID: 8087:0032 class-ID: e001
Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter>
Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff
link-mode: peripheral accept service-classes: rendering, capturing, object
transfer, audio, telephony


Audio:
Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
Device-3: Creative Sound Blaster Play! 3 type: USB
driver: hid-generic,snd-usb-audio,
API: ALSA v: k6.1.0-18-amd64 status: kernel-api
Server-1: PipeWire v: 0.3.65 status: active


Will be glad to hear any ideas what can be done.
Reply

#2
GLX only supports ALSA and it works reliably when using ALSA directly, so this means the ALSA emulator in your sound server is broken.
GLX was deprecated and current builds don't include it.
Reply

#3
(03-18-2024, 08:18 AM)bones_was_here Wrote: GLX only supports ALSA and it works reliably when using ALSA directly, so this means the ALSA emulator in your sound server is broken.
GLX was deprecated and current builds don't include it.

Oh, thanks! Pipewire-alsa was missing. Reinstalled it and everything is OK now. Shy

Why it will be deprecated? Is SDL superior? How?
Reply

#4
There's an ever-increasing amount of platform-specific issues and APIs which we don't have the time or interest or hardware to support.  SDL provides us a single platform-independent API for that stuff whereas GLX tried to do SDL's job itself (DP engine is older than SDL so that used to be necessary).  If you want modern stuff like native wayland, native pipewire, monitor selection, raw input, high DPI handling, you'll need to use SDL.
Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] My mouse binds do not work in GLX? FAF 5 1,731 07-29-2022, 08:39 AM
Last Post: FAF
  [SOLVED] No sound in Xonotic Draena 6 2,766 11-20-2021, 05:54 PM
Last Post: Draena
  [NEED HELP] Sound not precached Leeloo 3 5,284 07-12-2021, 10:27 PM
Last Post: cushinga
  [NEED HELP] Sound dissapears mid game mastablasta 0 1,250 10-01-2020, 12:27 PM
Last Post: mastablasta
  [NEED HELP] Sudden loss of sound in Xonotic, can not get it to return. SeveredinTwain 5 4,110 03-26-2020, 05:55 AM
Last Post: FAF
  [NEED HELP] "Nasty" Sound when a lot is going on. Aguaumreal 0 1,793 10-13-2019, 03:27 PM
Last Post: Aguaumreal
  [NEED HELP] Xonotic reverts to Stereo sound after having set it to 5.1 STP_KITT 0 1,916 11-27-2018, 05:35 PM
Last Post: STP_KITT
  [SOLVED] Character Sound Files Castor 7 4,799 06-05-2018, 05:22 PM
Last Post: Castor
  [BUG] SDL version not loading, glx version buggy rendering Halogene 3 3,876 10-19-2017, 06:04 AM
Last Post: Freddy
  [SOLVED] Surround sound refuses to work with C-Media CMI-8788 soundcards Lee_Stricklin 2 2,988 03-06-2017, 08:24 PM
Last Post: Lee_Stricklin

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-