Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] scrollwheel finicky ...

I just updated to mint 13 (64bit kde)

And now when I am playing xonotic ... scrolling the scroll wheel to swtich weapons isn't working right ...

sometimes It works ... sometimes it takes 2 scrolls ... sometimes 3 ...

I have no idea what could be causing the issue (scroll wheel works fine everywhere else ...)


Xonotic 0.6, autobuild (date?), git (likewise?)?

EDIT: Does this happen on a plain X session? Do the following in a terminal. Note that you'll temporarily lose control over your KDE session that will be put in background, you can come back to it by doing ctrl-alt-F7 (or a different F key maybe) or by quitting Xonotic after it's launched. Also note that your keyboard layout or other input settings may be different than what you're using on KDE.
startx /absolute/path/to/xonotic
(you need an absolute path to the program, for example /home/hutty/xonotic/xonotic)

Could it be a sticky mouse wheel? Even if it works fine elsewhere, perhaps Xonotic's ultra sensitive to the scrolling. What settings do you have? You could try taking it apart and cleaning it (if at all possible).

xonotic 0.6 sdl

it appears to be working fine in glx

also whatever you wanted me to do ... it doesn't seem to be working ...

hutty@shanon ~/apps/Xonotic $ sudo startx /home/hutty/apps/Xonotic/./xonotic-linux64-sdl
[sudo] password for hutty:

Fatal server error:
Server is already active for display 0
        If this server is no longer running, remove /tmp/.X0-lock
        and start again.

Please consult the The X.Org Foundation support
for help.

ddxSigGiveUp: Closing log
^Cxinit: unexpected signal 2XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"

      after 7 requests (7 known processed) with 0 events remaining.
hutty@shanon ~/apps/Xonotic $

I didn't tell you to use sudo!!! Don't run Xonotic as root, never!

Try this:
startx /home/hutty/apps/Xonotic/xonotic-linux64-sdl -- :1
(the /./ in the path is superfluous in your log)

this is what I get without sudo

X: user not authorized to run the X server, aborting.

Hah, that's hilarious. See if you can start your session with a different environment from KDE, like a failsafe xterm session or something? If there is such a thing, launch Xonotic from the commandline from that xterm.

Otherwise, it seems that you can allow users to launch X sessions by editing the file /etc/X11/Xwrapper.config from

On a desktop linux setup, I don't see how that can hurt anyone. But you can always change it back after if you want.

ok ... changing the xwrapper file worked ... as in xonotic run ...

the bug is still there though ...

So running sdl xonotic in a separate X session was still buggy?

I guess you'll have to use glx then, that's exactly why we provide the two. If you find a way to reproduce the issue so that other people can test it, feel free to file a bug report. Might be a faulty driver or faulty hardware, perhaps you could test alternatives to see if it still happens?

the reason i was using the sdl client in the first place is because the glx one crashes during a vid_restart (or if you push apply in video settings) ... which is required to switch from fullscreen to not full screen ...

so using glx is not an option ... ill keep testing stuff and bring more info later

How does it crash, though? Perhaps you can provide a gdb backtrace for that, if you use git.

Are you using autobuilds? Have you tested this bug lately?

[Image: 1Z6n6cRi29M2GGafLxwmEh]

im not sure how to do a backtrace ... but this bug existed back in ubuntu 9 (pre 0.5 xonotic)

but this just keeps getting weirder ...
I downloaded warsow recently ...
and it has the EXACT SAME ISSUE ....

meaning ... that the scroll wheel is finicky (inconsistent ) ... but only when switching weapons ...
for all other scrolling panes ... and menus ... it works just fine ...

(both warsow and xonotic show this ,,,)

edit ::

did some googleing ...... found this

Now I know why its inconsistent ... I cant scroll while the mouse is moving ...
turns out there is a bug in xorg ...
its fixed in the upcoming version ...

[solved ish]

"upcoming"? It dates from july! Is Ubuntu still using that bugged version?

[Image: 3hns0l5G9DeqMCeJ3bZMRO]

not necessarily ... im using mint 13 ... which is ubuntu 12.04 (current ubuntu is 12.10)

so i'm technically out of date ...

I recently upgraded to Mint 13, hopefully this saves someone some googling time. It fixes a problem in SDL games where moving the mouse at the same time as the mouse wheel makes it not register/switch weapons. For Ubuntu 12.04/Mint 13

You can either...
  • Run a GLX version of the game.
  • Wait for the xorg update that fixed this issue to trickle down through the repos which will happen, eventually.
  • Patch xorg your self.
  • Or download this guys deb
<[-z-]> have you seen the documentary "happy"?
<Samual_> no
<Samual_> it sounds horrible

I has exactly same porblem and been whinging about it in-game for many months not bothering to research or try to fix all by self..... Fanks for the leg work! Time to go pween harder!

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-