Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Xontic filling all my RAM

After a Kernel upgrade from 3.4 to 3.10, I find that I can't play more than a couple of levels of Xonotic without it filling my RAM. When I stop the game and check with System Monitor, it shows that up to 3.8Ghz of RAM is in use. It appears to fill up while I am playing to the point where it freezes and logs me out of Linux Mint 14, when I log back in again all my RAM is full and the top dozen or so processes have multiplied their usage by 10 times their normal amount. The only way I have found to clear the RAM is to reboot which is obviously not acceptable.

I can't find anything obvious on the forum here so I'm assuming it has something to do with my setup.

AMD FX4100 3.6Ghz, Kingston Hyper X 1600Mhz x 4Gb, Sapphire Radeon 7750 HD Ultimate, Asus M5A78L-M mobo. Xonar DSX (PCIe).

Mint 14 KDE. Kernel 3.10,
Catalyst; Driver Packaging Version, 12.104-130328a-155999C-ATI
2D Driver Version, 13.20.4
Catalyst Control Centre Version, 2.19
RandR Version, 1.3

OpenGL Version 4.2

I haven't tried any other games yet so will do that and report what happens.

Just tried some other games and this is also happening with Nexuiz, it does not happen with Assault Cube or OpenArena.

Does it also happen when using the open source radeon driver (and yes, expect bad speed then)? Or does it not support your GPU?
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud

Another thing that can help finding the cause: when it filled up about 3G of RAM... can you try entering the following commands on the console:


Then wait for a map change.

Then type:

condump console.log

You then will get a file ~/.xonotic/data/console.dump. Please provide this file to us, preferably by sending it via email to me (divVerent| with | replaced by @).
BRLOGENSHFEGLE (core dumped)

The Bot Orchestra is back! | Xoylent Easter Egg | 5bots1piano
My music on Google Play and SoundCloud

In summary, Xonotic shouldn't be using anything like 3.8Gb of RAM. As div already suggested the drivers, perhaps other processes are also gobbling RAM? It would be interesting also to see exactly what information your computer is giving for memory usage. I would suggest using the 'top' utility. Open a terminal window from your desktop and type 'top', then hit enter. Then press Shift + m. This orders the list of processes by memory usage. Maximise the window if you want to see more processes. You can then copy and paste the contents of the window here and that would be interesting to see.

Try this both for after a clean boot and also for after playing the game for a bit. I would expect Xonotic shoudl free up RAM just fine and what div has suggested would allow you to check this but if it is a system problem it may be harder to find.
I'm at least a reasonably tolerable person to be around - Narcopic

Possibly Related Threads…
Thread Author Replies Views Last Post
Sad [NEEDS INFO] Strange bug - my character is moving all the time ! Oncl'Tom 2 3,140 02-12-2017, 06:57 PM
Last Post: organic
  [SOLVED] How to download all maps at the same time? koper 7 9,253 09-15-2013, 03:33 AM
Last Post: Smilecythe
  [NEEDS INFO] Bots get stuck or don't move at all rafallus 7 8,003 01-22-2012, 04:40 AM
Last Post: Maddin
  [SOLVED] all: line 673: syntax error near unexpected token `fi' Mr. Bougo 2 7,355 09-26-2010, 02:41 PM
Last Post: Mr. Bougo
  [SOLVED] Newest Xonotic git displays all black! liberty 9 10,959 08-13-2010, 02:45 PM
Last Post: liberty

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-