Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SDLv2: We need your help!

#1
Bug 
Players and developers out there, we need your help! We'd like to iron out all of the SDLv2 issues in the game in order to cut a new release, but we're lacking on the details of what needs to be fixed. To find that out, we first need to know the specifics of what is going wrong!

This is where you can help. By testing the game using the SDL binaries and providing us feedback, the development team can get a better picture of where we should spend our time. How to test SDL, you say? If you're on git, you can run "./all run sdl". If you're on an autobuild or the 0.8.0 release, you can run the script with "sdl" in the name. If you find something, please file and issue with us on our GitLab tracker. If it warrants a discussion first, please don't hesitate to drop by the development IRC channel (#xonotic on freenode). Please remember that IRC responses may take a while.

Anyway, here's to bug squashing. See you all on the servers, and happy fragging!

EDIT: One of our developers informed me that we need to compile git builds with a specific option for SDLv2 to enable it. You can do this with "SDL_CONFIG=sdl2-config ./all compile". After this is done the "./all run sdl" will use version 2 instead of version 1. Thank you for the tip, packer!
asyyy^ | are you releated to chuck norris?
Reply

#2
SDLv2 supports copy and paste. I wonder whether it's a good idea to enable that in game. Sometimes we are exchanging URLs (forum post, wiki page, IRC, etc.) and I often wish we could use copy and paste.

On the other hand, right now, I start the program from the console, so I can just use my terminal emulator's copy and paste. Also, maybe there's a security concern regarding reading the clipboard?
Reply

#3
That is an enhancement we may want to do in the future, but I think we should focus on fixing the things that are broken before we get to adding new features (which might also become broken!).
asyyy^ | are you releated to chuck norris?
Reply

#4
Wish I could help here but I have no idea what to do when it comes to these types of things. I let smart people like BuddyFriendGuy take care of it for me.
[Image: 38443.png]
Reply

#5
lol, @SPLAT, very smooth. I learned way more from you than I can give back.

@Antibody, I'm actually having an easier time with SDL then GLX. I've been running SDL in the past 2 months and haven't had any problem that's unique to SDL. I didn't add that env variable though. Will start doing so.


For those of you who did not compile with SDL_CONFIG before, remember to do "./all clean" first, so the compiled files that depend on SDL1 will be re-compiled for SDL2.

Code:
$ cd xonotic
$ ./all clean
$ SDL_CONFIG=sdl2-config ./all compile
$ ./all run sdl
Reply

#6
SDL_CONFIG=sdl2-config isn't necessary in Windows.
Reply

#7
I'd like to help, but can someone please post a detailed instruction for the dumber kind of users (like me)?

Like, what should i paste into terminal? :)
Reply

#8
(07-10-2015, 10:32 AM)Base Wrote: Like, what should i paste into terminal? Smile

We are testing the latest version, so first, please make sure you are able to check out the latest code, with this guide. (The details are beyond the scope of this thread, but feel free to ask in another thread if needed.)

Then after the checkout, run the following commands (the first line may be different for your system -- basically it's to change your working directory to where you store the git repository):

Code:
$ cd xonotic
$ ./all clean
$ SDL_CONFIG=sdl2-config ./all compile
$ ./all run sdl
Reply

#9
(07-08-2015, 07:45 AM)Antibody Wrote: If you're on an autobuild or the 0.8.0 release, you can run the script with "sdl" in the name.

There is no need to run xonotic compiled from source. (Except you want to test the latest version, like BuddyFriendGuy suggests.)
You can also use the latest release to test sdl2.

Just run the sdl binary xonotic-*-sdl or script xonotic-*-sdl.sh and verify sdl2 is used.
In xonotic console there should be lines similiar to:
Code:
Linked against SDL version 2.0.3
Using SDL library version 2.0.3

It needs to print SDL version 2.0.*
Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-