Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEED HELP] Xonotic Server crashes TF2 server

#1
Hello, everyone!

I run a TF2 server on a remote server running Ubuntu 14.04. I'm trying to set up a Xonotic server and everything seems simple enough. I managed to download the game and move the server.cfg to the correct folder.

The problem is, whenever I launch my Xonotic server, it crashes my TF2 server and I want to have both running at the same time. How can I solve this?

Thanks!
Reply

#2
Do you have any logs from the TF2 server when it crashes? That might help isolate the cause.

Other simple things to eliminate:
  1. Use of the same port numbers?
  2. Check the free memory when TF2 is loaded only, when Xonotic is loaded only and when neither is loaded (just use 'free' from the cli). It's possible you might not have enough free memory on the remote server?
[Image: 21975.jpg]

Quote:“To summarize the summary of the summary: people are a problem.” - Douglas Adams
Reply

#3
(02-20-2018, 06:35 PM)cefiar Wrote: Do you have any logs from the TF2 server when it crashes? That might help isolate the cause.

Other simple things to eliminate:
  1. Use of the same port numbers?
  2. Check the free memory when TF2 is loaded only, when Xonotic is loaded only and when neither is loaded (just use 'free' from the cli). It's possible you might not have enough free memory on the remote server?

Just checked, the problem is memory Sad
Thanks for pointing that out. I'm new to this game and so far I must say the community is great! So many nice people. I wish I knew about Xonotic earlier Big Grin
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  How to change server cfg on modified server veecho 4 276 04-24-2019, 08:15 PM
Last Post: BuddyFriendGuy
  Server error "Weapon stats writing failed: -404" FlufyBuny 1 167 04-13-2019, 04:36 AM
Last Post: It'sMe
  Dedicated server setup Rec0d 5 262 04-03-2019, 02:00 PM
Last Post: Rec0d
  South American Dedicated Server Professor 3 477 03-03-2019, 07:02 PM
Last Post: end user
Information [TUTORIAL] Xonotic Server behind OPNSense (and pfSense) gurbe 0 310 01-27-2019, 09:07 AM
Last Post: gurbe
  Xonotic server running behind UDP proxy not working doombringeroperator 2 451 01-07-2019, 02:23 PM
Last Post: doombringeroperator
  [NEED HELP] Server show on the browser list, but I can't connect! Professor 1 412 12-19-2018, 11:39 AM
Last Post: Professor
  Server Setup for Dummies litvinenkotea 7 4,000 12-08-2018, 01:20 PM
Last Post: tehjester78
  Local LAN Xonotic game server player Stats animatedjay 3 841 11-23-2018, 12:38 AM
Last Post: BuddyFriendGuy
  Deploying a server across multiple machines ar5n1c 1 430 11-21-2018, 11:08 AM
Last Post: martin-t

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-