Xonotic is a free, open source (GPL) ultra-fast, first-person shooter

Follow Xonotic on

Post Reply 
Pulsing sound on KXStudio (Ubuntu 11.04 - 64bit var)
08-13-2011, 05:48 PM (This post was last modified: 08-17-2011 02:50 PM by BC01.)
Post: #1
Pulsing sound on KXStudio (Ubuntu 11.04 - 64bit var)
Whenever I start the game the sound is nothing but a cyclic pulsing noise about one or so per second (it sounds a little bit like the warp core sound on startrek when the ship is idling). Everything else seems to work but playing without any sound clues is more difficult than playing normally.

My system OS is Ubuntu 11.04 with the KXStudio modifications which at the basic system level consist mainly of funneling everything sound related through jack audio across bridges like the pulse-jack bridge instead of running separate sound servers directly. My hardware is Nvidia 6100 motherboard and I use the onboard sound chipset. More detailed information (from another online game) (it detects the pulse-jack bridge as regular Pulse audio as it should):

CPU: AMD Athlon™ 64 X2 Dual Core Processor 4200+ (1000 MHz)
Memory: 3961 MB
OS Version: Linux 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:07:17 UTC 2011 x86_64
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GT 240/PCI/SSE2

OpenGL Version: 3.3.0 NVIDIA 270.41.06

libcurl Version: libcurl/7.21.1 OpenSSL/1.0.0d zlib/1.2.5 c-ares/1.7.1
J2C Decoder Version: S21J Runtime: 2.0.6
Audio Driver Version: OpenAL, version 1.1 ALSOFT 1.11.753 / OpenAL Community / OpenAL Soft: PulseAudio Software
Qt Webkit Version: 4.7.1 (version number hard-coded)

Is there a way to feed the sound directly to jack? That seems to work better in many applications than running it across the bridge. Nexiuz classic works flawlessly with sound, was there some kind of major change made to the sound system?
Find all posts by this user
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Surround sound refuses to work with C-Media CMI-8788 soundcards Lee_Stricklin 1 232 01-14-2017 05:01 PM
Last Post: BuddyFriendGuy
  Ubuntu 16.0.4 Compile RedScale12 8 858 09-06-2016 08:40 PM
Last Post: RedScale12
  How to ubuntu xonotic server install? Turan 4 1,054 03-17-2016 08:01 AM
Last Post: Turan
  Source Code Xonotic on Ubuntu 15.04 Ryan 2 1,823 09-16-2015 10:48 AM
Last Post: Beagle
  Ubuntu running problem rembak 7 5,068 03-29-2014 04:30 AM
Last Post: adem
  [SOLVED] Ubuntu 12.04 Install Issue Red Viper 6 3,452 03-08-2014 03:20 AM
Last Post: Halogene
  Compiling NetRadiant (Ubuntu 11.10) uDelta 2 2,147 07-15-2013 10:50 AM
Last Post: machine!
  Sound troubles Ubuntu dadx4 15 7,600 02-23-2013 05:12 AM
Last Post: zykure
  Sound doesn't work machine! 13 6,138 02-17-2013 09:31 AM
Last Post: Mr. Bougo
  [SOLVED] Problem with compiling on Ubuntu 12.10 Szustarol 23 7,971 01-05-2013 02:28 PM
Last Post: Mr. Bougo

Forum Jump: