Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] all: line 673: syntax error near unexpected token `fi'

#1
If you guys get this error message when updating from git:
Code:
all: line 673: syntax error near unexpected token `fi'
then don't worry... Just type this command where you would do ./all update:
Code:
git pull
and then run ./all update



If you're using my autobuild pack, type this command into shell.bat before the "git pull" one:
Code:
cd /xonotic
then close the shell window and run build.bat again.
Reply

#2
I managed to fix this error by changing line 671 in ./all from
Code:
elif which catchsegv >/dev/null 2>&1/, then
to
Code:
elif which catchsegv >/dev/null 2>&1/, ; then

(note the semicolon)
Reply

#3
Yep but you now have unstaged changes, and that is kind of bad. Besides, you have to remove the comma.
You'll have to do this now:
Code:
git reset --hard all

Basically, your fix gets in the way of further updates of the script, while my solution makes use of an older "all" script that can then fix itself by updating to the fixed version present in the repository.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [BUG] Command line typing issues teratorn 5 1,480 04-12-2018, 04:02 AM
Last Post: teratorn
  [SOLVED] linux compile/link error BuddyFriendGuy 3 2,133 11-27-2017, 08:55 PM
Last Post: Lyberta
Bug [BUG] Permission Denied line 131 Ubuntu 14 ilyasofficial 3 2,032 10-22-2017, 06:39 AM
Last Post: martin-t
  [NEEDS INFO] Custom map - Host Error: Mod_MAP_Mode: not yet implemented teratorn 6 3,069 03-07-2017, 04:29 AM
Last Post: SpiKe
  [SOLVED] RegisterNotification_Done error Keziolio 5 4,631 08-06-2014, 03:32 PM
Last Post: Mr. Bougo
  [SOLVED] Please help: -sessionid and an unique session name error anish01 2 3,497 05-10-2014, 03:30 AM
Last Post: Mr. Bougo
  [SOLVED] Quake Error "Video modes failed" on 2nd startup RpD 4 7,568 07-19-2013, 04:02 PM
Last Post: RpD
  [SOLVED] Parse error. aa 15 6,711 06-06-2013, 11:09 AM
Last Post: Maddin
  [NEEDS INFO] Netradiant crashing error korfi 4 3,161 05-31-2013, 02:08 PM
Last Post: korfi
  [SOLVED] NetRadiant startup error Smilecythe 11 6,361 02-16-2013, 12:49 PM
Last Post: Mr. Bougo

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-