Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] No maps to choose in singleplayer

There is no maps to choose in singleplayer or when creating a server. When I joined an empty server(no files downloaded). I could see all the items(guns,health ect) though i could not see any walls.
I joined another server with custom horrible checkered map and it downloaded the map and worked. I feel like the maps is somehow corrupted though the md5hash showed the zip downlaoded correctly.

I downloaded from your website the md5sum is eda7e8acadbefaf4b2efcfb70bbe98e2

Further info.
I am running on Linuxmint cinnamon. all latest version.
I extracted the zip to home directory. opened terminal entered the xonatic folder. then executed ./
It started fine with no issues.

Install libcurl.

curl is installed. If i understand correctly curl is only related to downloading files when connecting to a server with non standard files.

Where as it seems to be the all the maps that are meant to be included do not work and the only way to play is to join a server with custom maps to download. Hence when i mentioned it worked when i downloaded a server running a horrible maps with just the default checkered textures.

Which kind of sucks since my internet is spotty and the australian xonotic servers are a ghost town. Plus i want to see the quality maps and what graphics the engine is capable of.

so i went into home .xonotic/data/dlcache/ and found the file that should contain the maps "xonotic-20130605-maps.pk3" is 0 bytes in size.
So i deleted it and tried again. it found the file missing and tried to download from here "" it gives no errors but fails to open the bsp file. and creates a new 0 byte file with the name "xonotic-20130605-maps.pk3". I know the download failed because when you type in the address you get redirected and then a 404 errors at ""
Now there is a file in the original extraced Xonotic folder under data named "xonotic-20130605-maps.pk3" though when copied to the dlcache folder it does not work either. though this file is 310mb it can still not be opened by the archive manager which opens every other pk3 file including the downloaded maps that work. It seems like the xonotic download may be packed with a corrupt file.

The file xonotic-20130605-maps.pk3 says it is 567.7 MB for me, not 310 MB. Did you download the low quality version of Xonotic? Try downloading the normal version that's 993MB in size.
<[-z-]> have you seen the documentary "happy"?
<Samual_> no
<Samual_> it sounds horrible

That's weird. xonotic-20130605-maps.pk3 is supposed to be part of your install. Is it not in the directory you exctracted the zip into? If you exctracted it to home, that should be ~/xonotic/data/xonotic-20130605-maps.pk3

I did download the xonotic zip file from the front page it is 1gb. I have checked the md5hash and it is identical to the hash that was posted in the forums.
The xonotic-20130605-maps.pk3 is in ~/xonotic/data/xonotic-20130605-maps.pk3 . It is 310mb in size I extracted the zip again and the file came out as 95.9mb . I extracted the file by it self and it is 567.7mb . So hopefully it works this time. Strange that the archive manager seems to have trouble extracting all of it at the same time.


Yes it seems to work now. at least it was not something stupid I did.

You should not extract pk3 files, though. They are read by Xonotic at runtime.

With those extracted files, you might run into trouble when updating to the next version.

(01-12-2014, 07:04 AM)Mr. Bougo Wrote: You should not extract pk3 files, though. They are read by Xonotic at runtime.

With those extracted files, you might run into trouble when updating to the next version.
I did not extract the contents of the pk3 I extracted the pk3 file from the originally downloaded xonotic zip. I then copied it into the .xonotic/data/dlcache folder as well the Xonotic/data folder. So it is still a pk3 file.

I do not know if it needed to be in both places but i did it anyway.

For some reason when I extracted the entire contents of the xonotic zip it extracted the maps pk3 file incorrectly, but if i navigate inside the zip and select the maps pk3 file by itself and extract it then it extracts fine.

Why I have no idea. Hopefully this clears it up incase someone else gets the same issue.

It would be neat if the server hosted the maps pk3 hosted it correctly do i do not get a 404 when going there.

That's really not how it should be, though... You should try to put it back in the install directory and paste a xonotic startup log here. Can you start xonotic from a terminal? If so, pass a -condebug parameter to it:
cd ~/Xonotic
./ -condebug
Then quit the game. The log file will be in ~/.xonotic/data/qconsole.log . Note that this log file will contain your username, if you would prefer to redact it.

In any case, you'll never need that pk3 in dlcache so you can remove it from there.

EDIT: The server has no reason to serve the maps pk3 individually, as it's contained in every Xonotic release. Your install is somehow broken, it's the first time I've seen this.

I have already put it in the install directory. That is what I meant by "Xonotic/data"

I do not think it is necessary for a debug log. the problem was it did not extract the maps pk3 correctly from the zip. Which is shown by the small file size. And with it extracted properly everything seems to work.

I meant download the entire pk3 maps incase something like this happens to someone also because in the future if there is a new release with new maps that is compatible with the old servers some servers may still be using the old maps. I found one server that tried to download an older map pk3 already.

While That is a bit of a stupid scenario. It is one that can happen.

Oops, sorry. I had read .xonotic/data instead of Xonotic/data. My mistake.

Glad everything is working as it should, then! Big Grin

As for serving the original pk3 in case this happens to someone else, I don't know... That's really up to individual server admins, because they configure the download URLs themselves.

The incompatibility issue can be dealt with properly using compatibility packages. This has been done before, but it also requires configuration by all server admins.

Possibly Related Threads…
Thread Author Replies Views Last Post
Question [NEED HELP] Practicing XPM in Singleplayer [CISN] Neigdoig 0 1,494 07-15-2023, 11:31 PM
Last Post: [CISN] Neigdoig
  [SOLVED] Can't beat level 21 in singleplayer mode hhyloc 5 11,625 08-24-2012, 02:33 AM
Last Post: hhyloc
  [SOLVED] Teamplay in singleplayer mode soukaina 3 3,933 08-20-2012, 03:16 PM
Last Post: tZork
  [INVALID] [Bug?]No switch teams in techassault - singleplayer rafallus 1 2,864 01-31-2012, 05:55 PM
Last Post: Mirio

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-