Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Please help: -sessionid and an unique session name error


I have downloaded Xonotic on Ubuntu 12.04 and it has been working well up until I opened the

When I opened the normal it did not open. WHen I tried to run it in the terminal I get this error:

Quote:Game is Xonotic using base gamedir data
Xonotic Linux 03:08:13 Jun 5 2013 - release
Current nice level is below the soft limit - cannot use niceness
Skeletal animation uses SSE code path
DPSOFTRAST available (SSE2 instructions detected)
Failed to init SDL joystick subsystem:
execing quake.rc
execing default.cfg
execing defaultXonotic.cfg
execing sRGB-disable.cfg
menu: program is not loaded
execing weapons.cfg
execing cdtracks.cfg
execing mutator_new_toys.cfg
execing balanceXonotic.cfg
execing effects-normal.cfg
execing physicsX.cfg
execing turrets.cfg
execing unit_machinegun.cfg
execing unit_hk.cfg
execing unit_hellion.cfg
execing unit_mlrs.cfg
execing unit_flac.cfg
execing unit_fusreac.cfg
execing unit_plasma.cfg
execing unit_plasma2.cfg
execing unit_tesla.cfg
execing unit_phaser.cfg
execing unit_walker.cfg
execing unit_ewheel.cfg
execing vehicles.cfg
execing vehicle_racer.cfg
execing vehicle_raptor.cfg
execing vehicle_spiderbot.cfg
execing vehicle_bumblebee.cfg
execing crosshairs.cfg
execing gamemodes.cfg
execing ctfscoring-samual.cfg
execing notifications.cfg
execing commands.cfg
execing _hud_common.cfg
execing _hud_descriptions.cfg
execing hud_luminos.cfg
execing config.cfg
"maxplayers" set to "16"
execing data/campaign.cfg
execing config_update.cfg
execing font-xolonium.cfg
Warning: Could not expand $scr_centersize
Warning: Could not expand $scr_centersize
client: program is not loaded
execing autoexec/empty.cfg
execing autoexec.cfg
Quake Error: session lock /home/anish/.xonotic/lock could not be acquired. Please run with -sessionid and an unique session name.

Help will be apreciated. I desperately like this game and would love to play it again...
Thanks! Cool

Okay, I figured out the answer by myself. In the home directory you are supposed to put the zipped file that you downloaded from. My game file was in Downloads. So I copied the ZIPPED file to home directory. Then I launched the game from my Xonotic file in Downloads. It worked!

The .zip file downloaded from the website only contains the game. Once the game's extracted from it, the zip file is not needed anymore. Your solution seems completely unrelated to the problem and looks more like a coincidence.

The lock file mechanism ensures that no two Xonotic processes run at the same time using the same database and key files. You were probably already running a copy of the dedicated server in the background, as you said "nothing happened" when you first tried. The second time you tried to launch it, this time in a terminal, the first one you launched in background had set up a lock file that prevented the second one to start. You probably rebooted or somehow killed the first process between the issue and finding out later that it worked again.

If you want to run two Xonotic sessions at the same time (for example the dedicated server and the client), you will have to follow the -sessionid instructions given to you above.

Possibly Related Threads…
Thread Author Replies Views Last Post
Sad [SOLVED] Segmentation fault (HTTP error 422) at the end of the first map John 1 909 11-04-2022, 10:05 AM
Last Post: John
  [NEED HELP] Is there a training session to learn the mechanics of Xonotic? CyberGhost 2 1,972 12-16-2021, 05:57 PM
Last Post: CyberGhost
  [NEED HELP] cant start the game/ session lock problem skyghost47 1 2,901 10-24-2020, 11:50 PM
Last Post: BuddyFriendGuy
  [NEED HELP] I REPEAT I need Help with Netradiant Taplio 4 3,259 09-23-2020, 12:05 AM
Last Post: fabzor3
  [SOLVED] Can't click on my name in XonStats TheChrississin 4 2,625 03-09-2019, 10:24 AM
Last Post: falco
  Newb seeks help on Oilrig Pallama 7 4,855 10-08-2018, 09:39 PM
Last Post: illwieckz
  [NEEDS INFO] Need help with xonotic on andoird Arctic_fly71 3 3,258 01-17-2018, 07:23 PM
Last Post: Arctic_fly71
  [SOLVED] linux compile/link error BuddyFriendGuy 2 3,521 11-27-2017, 05:18 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Help cant play IdekehBruh 1 2,061 05-05-2017, 08:21 AM
Last Post: Mario
Information [META] Thread Prefixes for Help & Troubleshooting -z- 0 3,975 03-07-2017, 08:19 PM
Last Post: -z-

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-