Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] VSync capping to 60hz on a 144hz monitor

#1
I have a triple monitor setup. My left and center monitors are at 60FPS but my rightmost monitor is at 144 fps.

When I put Xonotic on the rightmost monitor with vsync enabled, it is till only 60FPS. Is there a way to get it up to 144fps?

I run the following xrandr script to set it up.

Code:
#!/bin/sh
#Make sure HDMI Cable is on the right and DP cable is on the left
if [ "$1" ]; then
x_res=1920
y_res=1080
x1=$(echo "$y_res * $1" | bc)
x1=$(printf '%.0f\n' "$x1")
x2=$(($x1 + 3840))
xrandr --output HDMI-0 --mode ${x_res}x${y_res} --scale $1x$1 --rotate left  --pos 0x36 --panning 0x0+0+36 --output DP-0 --pos ${x1}x0 --auto --primary --output DP-1 --mode ${x_res}x${y_res} --scale $1x$1 --rotate normal --pos ${x2}x36 --panning 0x0+${x2}+36 -r 144.0
else
   echo "Usage: $0 [Scale]"
fi
[Image: 5365.png]
[Image: 126092.png]
Reply

#2
It sounds like either the engine doesn't support that properly, or there's some difficulty with the system producing VSync at different levels...

Have you considered just locking the framerate in Xonotic to 150 or so and not using VSync? You can do that with the following:
Code:
cl_maxfps 150
[Image: 230.png]
Reply

#3
To my knowledge the only WM that supports running different screens at different refresh rates is Mutter (Gnome) in a wayland session: https://www.phoronix.com/scan.php?page=n...or-Vary-Hz
A similar feature is worked on for Kwin (KDE), again only wayland: https://www.phoronix.com/scan.php?page=n...Experience
As I understand it, this is a limitation of X11 as it was designed in a time when multi-monitor setups were not of concern.
Reply

#4
(12-16-2020, 10:16 PM)Mario Wrote: It sounds like either the engine doesn't support that properly, or there's some difficulty with the system producing VSync at different levels...

Have you considered just locking the framerate in Xonotic to 150 or so and not using VSync? You can do that with the following:
Code:
cl_maxfps 150

Ahh yup that is what I ended up doing

@Freddy, that is cool, I didn't know that. I am using XFCE, I believe with X11. I'm not sure if everything is being rendered at 144fps, but I'm pretty sure the 144hz monitor is running at 144fps.

Thanks for the help guys!
[Image: 5365.png]
[Image: 126092.png]
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEEDS INFO] How i Can Xonotic play on the second Monitor (not Main) Berputo 3 3,736 08-16-2013, 02:03 PM
Last Post: edh
  [SOLVED] vsync and KDE Halogene 10 6,894 07-18-2012, 04:15 AM
Last Post: Halogene
  [SOLVED] 'bezel' effect with vsync disabled edh 5 4,175 03-31-2012, 01:31 PM
Last Post: edh
  [SOLVED] SOLVED: triple monitor problem Eicca 3 4,518 12-15-2011, 02:31 PM
Last Post: Mr. Bougo

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-