Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Compiling problem

After pulling today, I have found I can't compile it. Anyone got this error?

This is the error:
************ ERROR ************
compilation errors
Error in ../warpzonelib/client.qc on line 296
make[1]: *** [csprogs.dat] Error 1
make[1]: *** Waiting for unfinished jobs....
compiling w_common.qc
compiling ../common/gamecommand.qc
compiling w_all.qc
compiling gamecommand.qc
compiling menu.qc
compiling draw.qc
compiling xonotic/util.qc
compiling ../common/campaign_file.qc
compiling ../common/campaign_setup.qc
compiling ../common/mapinfo.qc
compiling ../common/items.qc
compiling ../warpzonelib/mathlib.qc

************ ERROR ************
compilation errors
Error in ../warpzonelib/mathlib.qc on line 268
make[1]: *** [menu.dat] Error 1
compiling t_items.qc
compiling cl_weapons.qc
compiling cl_impulse.qc
compiling ent_cs.qc
compiling cl_player.qc
compiling cl_client.qc
compiling t_plats.qc
compiling antilag.qc
compiling ctf.qc
compiling domination.qc
compiling mode_onslaught.qc
compiling nexball.qc
compiling g_hook.qc
compiling t_swamp.qc
compiling clientcommands.qc
compiling vote.qc
compiling campaign.qc
compiling ../common/campaign_file.qc
compiling ../common/campaign_setup.qc
compiling ../common/gamecommand.qc
compiling gamecommand.qc
compiling assault.qc
compiling ipban.qc
compiling ../common/mapinfo.qc
compiling t_quake3.qc
compiling t_halflife.qc
compiling t_quake.qc
compiling race.qc
compiling tturrets/include/turrets.qh
compiling vehicles/vehicles.qh
compiling scores.qc
compiling portals.qc
compiling target_spawn.qc
compiling func_breakable.qc
compiling target_music.qc
compiling ../common/items.qc
compiling monsters/defs.qc
compiling monsters/fight.qc
compiling monsters/ai.qc
compiling monsters/m_monsters.qc
compiling monsters/monster_zombie.qc
compiling csqcprojectile.qc
compiling playerdemo.qc
compiling anticheat.qc
compiling cheats.qc
compiling mutators/base.qc
compiling mutators/gamemode_keyhunt.qc
compiling mutators/mutator_nix.qc
compiling mutators/mutator_dodging.qc
compiling mutators/mutator_rocketflying.qc
compiling ../warpzonelib/anglestransform.qc
compiling ../warpzonelib/mathlib.qc
compiling ../warpzonelib/common.qc
compiling ../warpzonelib/util_server.qc
compiling ../warpzonelib/server.qc

************ ERROR ************
compilation errors
Error in ../warpzonelib/server.qc on line 656
make[1]: *** [progs.dat] Error 1
make[1]: Leaving directory `/home/Liberty/src/xonotic/data/xonotic-data.pk3dir'
make: *** [qc] Error 2

Yes Big Grin

./all checkout

(11-06-2010, 07:53 PM)monad Wrote: Yes Big Grin

./all checkout

Thank you very much!

Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED] Problem with setting new origin for func_clientwall Penguinum-tea 5 4,904 04-13-2015, 06:39 PM
Last Post: SPLAT
  Error Compiling NetRadiant on OS X 10.10 cityy 2 4,021 01-02-2015, 12:42 PM
Last Post: cityy
  I updated the "Compiling in Windows" wiki page Mr. Bougo 2 4,302 08-24-2012, 03:39 PM
Last Post: Mr. Bougo
  [SOLVED] Compiling from GIT fails: darkplaces unfa 10 14,947 06-20-2011, 07:58 AM
Last Post: unicornsteak

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-