Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Server not working.

#1
I created a Unreal server to test if it's downloading all of the required packages. When i double click it, it opens for a while and the closes. And if it opens, the maplist is overridden and i can't play the maps that i chose for the server.

Maybe my server.cfg is borken. Here is what i have inside it :

Quote:sv_public 1
sv_curl_serverpackages "unrealsounds-v1.pk3 unrealsounds-v1.serverpackage csprogs.dat progs.dat settings-ut2k4_v1.0.pk3 settings-ut2k4_v1.0.serverpackage"
sv_curl_defaulturl http://dl.dropbox.com/u/67627614/
cl_curl_maxspeed 20000
cl_curl_maxdownloads 10
g_grappling_hook 0
g_antilag 2
cl_curl_enabled 1
sv_motd "The best alternative to Unreal Tournament"
menu_maxplayers 20
g_maxplayers 20
g_maplist_votable 9
g_maplist_nodetail 0
g_start_delay 5
g_dm 1
gametype dm
sv_vote_commands "timelimit gotomap fraglimit kick restart nextmap movetoauto extendmatchtime reducematchtime endmatch cointoss allready"
sv_vote_call 1
hostname "Unreal Xonotic"
g_maplist "deck16][ old-steel-complex"
[Image: 10253.png]
Reply

#2
Can you give us a server log? That server.cfg does not help much.
EDIT: I mean especially the part from the beginning to the first map load, and the part where it stops.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#3
i cant get a shot of it. it stops a lil' fast

EDIT :however when the server DOES work, the maps are not the ones that i want on my server. u can see that in my cfg there are only 2 maps. The server loads all of the maps that are in dlcache and maps folders.

hmm... seems like i get "menu : program not loaded" . at that point the server stops.
[Image: 10253.png]
Reply

#4
The menu thing is normal. You don't "get a shot of it", you uncomment the log_file line in server.cfg so that it writes the log to a file.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#5
then what should this be? that's the only thing that looked a lil' abnormal. the rest is just normal, excepting that i get a lot of warnings from some useless maps. It's complaining about their mapinfos

i just deleted those maps and now it's working. !!such a simple issue.
[Image: 10253.png]
Reply

#6
I can't guess the error, that's why I would like some server logs. Because those server logs probably tell exactly what the error is.

Whatever, you seem to have found a solution.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#7
Most likely won't help but...
1) Don't put csprogs.dat/progs.dat in sv_curl_serverpackages, it's not how you do it. progs.dat is the server code and clients dont need it. Put both in data folder and add "+set sv_progs progs.dat" to the server options (this option might in the end be not needed). Server will push csprogs.dat to clients via engine protocol (tho download to client is somewhat slow).
2) Server scans data folder and put whatever map it finds in the map pool. Then, any of the found maps that is tagged for a given game mode might be played. You can limit this with g_maplist in config. But maps not in g_maplist are still listed by lsmaps and can be voted for. So short of removing maps from the data folder you can't prune map pool.
3) If you have progs.dat in your data dir, and are shure it is used instead of the default progs.dat packed with Xonotic, it might be that some bug in your QC code is crashing the server.
Reply

#8
Oh, I didn't bother reading the cfg :<

You do not even need to set sv_progs to progs.dat, that's the default value already. To see which progs.dat is loaded by the server, type this is the server console: which progs.dat
It will most likely be the one outside of the pk3.
[Image:http://i.imgur.com/4XODR.png]640K ought to be enough for anybody.
     ― Linux Torvalds
Reply

#9
ok. thx for contribution

it's working : progs.dat is file C:\....../xonotic/data/progs.dat

now server works like a charm ^^
[Image: 10253.png]
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  [NEED HELP] Spacebar not working on Erbium Deathmatch. Pallama 2 388 09-24-2019, 03:44 PM
Last Post: Pallama
  [NEED HELP] Decrease server log level falco 1 356 04-17-2019, 06:11 PM
Last Post: BuddyFriendGuy
  [NEED HELP] setting up server with custom maps le Bork 2 526 01-31-2019, 01:06 PM
Last Post: morosophos
  How display server list ? draikhin 2 596 01-21-2019, 07:26 AM
Last Post: draikhin
  [NEED HELP] can't join any server in the list psy31 2 924 11-02-2018, 10:37 AM
Last Post: psy31
  [NEED HELP] Multiplayer server listed twice - causes glitchy play Space Ace 4 1,052 08-10-2018, 08:55 PM
Last Post: Space Ace
  [SOLVED] Custom Server Downloads Castor 4 1,165 05-24-2018, 07:10 PM
Last Post: Castor
  [NEED HELP] Making a Private Server LordIrish 2 3,468 03-06-2018, 10:37 AM
Last Post: LordIrish
  [SOLVED] Can't connect to a server adem 2 1,354 02-23-2018, 06:49 AM
Last Post: adem
  [NEED HELP] Server not accessible? ColonelPhantom 2 1,118 10-03-2017, 05:55 AM
Last Post: ColonelPhantom

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-