Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] vsync and KDE

#1
I noticed a strange behavior when using KDE and Xonotic.

Whenever I started Xonotic under KDE, it felt like very choppy and not smooth at all, even though the fps counter said 60 constantly (I even tried with lowest effects settings). When I start Xonotic under LXDE/Openbox, I get very smooth display at 60 fps.

This made me curious what caused this. First thing I tried to do is to let Xonotic run at higher fps under KDE.

I disabled vsync. Still 60 fps.

I checked for cl_maxfps, it was 0. I set it to 200. Still 60 fps.

I checked the netfps settings and set them up as high as possible, but that was in vain too, as expected.

Then I thought, heck, maybe vsync needs a kick in the butt. I enabled vsync via console, and disabled it via console again. And WOOSH there were the fps at 500 or so. WTF! Display runs smooth! Now I enable vsync, 60 fps again, AND smooth display.

I scratched my head, wondered, shrugged, exited Xonotic. Restarted Xonotic. 60 fps, crappy sluggish choppy display again. WHAAAT, I disabled vsync, enabled vsync, there you go.

This seems to affect my Xonotic installation only when I run it from within KDE. I searched the config.cfg and autoexec.cfg for "60" and "vsync", but not relevant entries found. Any ideas as to what may cause this strange behavior? Not that other KDE users think Xonotic is ugly because it looks choppy even though it displays 500 fps...
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!

Reply

#2
Disable kwin effects before running Xonotic (alt+shift+f12) and everything will be smooth as it should.
My contributions to Xonotic: talking in the forum, talking some more, talking a bit in the irc, talking in the forum again, XSkie
Reply

#3
Interesting thing is that whenever I change graphics settings and click "Apply immediately", I'm back to 60 fps even though vsync says it's disabled, I only get more fps when I enable it via console and disable it again.
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!

Reply

#4
Applying settings restarts the renderer, so that doesn't seem too weird to me.
Reply

#5
Halogene - if you didn't disable kde effects before running the game and you have vsync enabled in the desktop effect settings it might have an effect on Xonotic's renderer.
My contributions to Xonotic: talking in the forum, talking some more, talking a bit in the irc, talking in the forum again, XSkie
Reply

#6
this works for me on Kubuntu:

- sudo kate /etc/environment

- add line to the file:
vblank_mode=0

but dunno why it doesn't work in the big benchmark =(
Reply

#7
You can get Xonotic to run through a Kwin rule to completely disable compositing but it is more convoluted than you might expect. There are some alternatives too. Pressing Alt+Shift+F12 isn't really an acceptable fix. I covered this a bit before after some issues I had originally:
http://forums.xonotic.org/showthread.php?tid=2685
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#8
edh, contact me if you want this thread you linked to be stickied.
Reply

#9
Putting things like that in a Wiki might end up being better in future! Maybe such a thing could be wangled at some point as there will be a lot of support and howtos that would be best put in a Wiki rather than out of date, very long winded, dead forum topics down the line. Any chance the official wiki could have sections for this sort of stuff?
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#10
That's up to you, really. You can get write access on the wiki, just get an account there and somebody can set the flags on your account.
Reply

#11
(07-12-2012, 08:23 AM)Mr. Bougo Wrote: Applying settings restarts the renderer, so that doesn't seem too weird to me.

Well, what seems weird to me is that I get 60 fps then even though the output of vsync in console says it is switched off.
My Xonstats Profile
Latest track on soundcloud: Farewell - to a better Place (piano improvisation)
New to Xonotic? Check out the Newbie Corner!

Reply



Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEED HELP] Xonotic crashes on KDE Magotrap 3 1,733 05-03-2022, 01:08 PM
Last Post: [CISN] Neigdoig
  [SOLVED] VSync capping to 60hz on a 144hz monitor Bla1 3 3,144 12-18-2020, 05:50 PM
Last Post: Bla1
  [SOLVED] 'bezel' effect with vsync disabled edh 5 5,653 03-31-2012, 01:31 PM
Last Post: edh
  [SOLVED] KDE related issue simongaiteiro 7 6,785 03-20-2012, 03:15 PM
Last Post: edh

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-