Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to enable warpzone see-through?

#1
I got picmip settings at over 9000 something and I can't see through warpzones. This can be very irritating in maps like Stormkeep, Glow plant and the fun map Hyperspace. I've used so many commands to disable shit my memory just can't follow, is there a command to enable the see-through effect alone with nothing graphically intense?
Reply

#2
When you load a map which requires warpzones then reflections are set by the map to enabled even if you have them disabled so this can't be the problem unless you also have OpenGL 2.0 disabled in which case reflections don't work. Do you just get a green grid texture or what?

Why do you need a picmip of 9000? What are the specs of your system and how badly is it performing that you need this level of tweaking?
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#3
I can play duel with high graphics, but when there's more than 3 player models visible to the screen my fps starts to drop dramatically, even in these minimum settings. There's something wrong in Xonotic, because this doesn't happen in any other game with engine relatives.

..That and I like simplicity.

No the warpzone entrances looks like solid walls. I have OpenGL 2.0 enabled, I believe it's down to knowing what console writing can enable warpzone effects back, if there happens to be such.
Reply

#4
Right, I think I can hazard a guess what's happening. IIRC warpzones are rendered to a texture. By setting it to gl_picmip 9000 or whatever the picmip value also effects the warpzone rendering. This would mean that you see exactly what you would expect at gl_picmip 9000 - a blur.

Here is a thread I found about warpzones in Stormkeep and what is required for them to work, may be of some interest:
http://forums.xonotic.org/showthread.php?tid=556

The only other thing you could do is check that you have not ridiculously lowered (or disabled) the reflection detail - this effects render to texture only and therefore warp zones as well as reflections. You can find this in the effects menu but it should be overridden when Stormkeep's mapcfg anyway.

Beyond this there is nothing to 'enable warpzones' other than using a more sensible picmip value. What hardware are you running on? I've had very playable warpzones rendered on a Geforce FX before and that's the oldest OpenGL 2.0 supporting generation, testing with Radeon 9600 of the same age did lead to problems with warpzones, not sure if this is relevant.
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#5
Turn reflections on -> r_water 1
[Image: 21.png]
IRC (QuakeNet): #bot.xonotic | #xonotic.pickup | #xonotic | #xonotic.cup
Steam | Twitch.tv | YouTube
Movies: Mirification #1 | #2 | Mirificaption #1 | #3 | #4 | [BOT] Clan #3 | #5 | #6 | #7 | [BOT] Clan #4 | #8

Reply

#6
Having checked with very high gl_picmip values I can't get them to interfere with reflections (the r_water cvar Mirio listed and I'd alluded to earlier in the effects menu).

It's strange if you have somehow got reflections switched off as the mapcfg for Stormkeep specifically sets r_water to 1 and would override any configuration where OpenGL 2.0 is enabled. Also if you disable reflections you don't get a blurred texture, you get a green grid so you probably don't have them disabled.

All of the cvars to control reflections, refractions and warpzones are all r_water* so have a look at these and reset to the defaults until something works properly. The mapcfg also specifically sets the reflection detail too so you shouldn't have a problem with that. If not, it's your picmip value causing problems and that shouldn't really be interfering. Again, more details on the hardware would be interesting and why it does not perform so well.
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#7
Some guy told me the command a long time ago, it was something in the lines of 'showsurface', ring any bells?
Reply

#8
Code:
apropos surface

Type it in console.
[Image: 21.png]
IRC (QuakeNet): #bot.xonotic | #xonotic.pickup | #xonotic | #xonotic.cup
Steam | Twitch.tv | YouTube
Movies: Mirification #1 | #2 | Mirificaption #1 | #3 | #4 | [BOT] Clan #3 | #5 | #6 | #7 | [BOT] Clan #4 | #8

Reply

#9
r_showsurface 0 gives me back my warpzone effects, but also puts my fps down from 120 to 80, this is very crucial because when my fps would normally drop to 60 it would now drop to 20, that is unplayable and it happens to me when there's too much stuff in same screen simultaneously.

Somehow I need to get rid of these surface effects:


.jpg   17y7i9.jpg (Size: 45.33 KB / Downloads: 172)

without taking the warpzones too. I want the surfaces to be like this:


.jpg   15n4mea.jpg (Size: 41.95 KB / Downloads: 173)

Anything specific for this?

Edit by PinkRobot: Something weird happened to those screenshots. I resaved them as JPG and uploaded them here for you.
Reply

#10
gl_picmip_world 1337
[Image: 230.png]
Reply

#11
(01-06-2013, 03:30 AM)Smilecythe Wrote: r_showsurface 0 gives me back my warpzone effects

Right, so you were using r_showsurfaces 3 probably. That's really intended for very slow hardware like the EeePC and not for serious use. You can't really play the game well on that but you've basically been running in OMG effects level.

Neither of those images you linked to show up for me, can you repost them somewhere?

So what hardware and software are you running on? I'm beginning to wonder what kind of hardware supports OpenGL 2.0 enough to render warpzones but does it so badly. Is this a laptop? Can you try running The Big Benchmark so that we can have some numbers to compare with?

Maybe take a look through my thread here:
http://forums.xonotic.org/showthread.php?tid=2685
I'm at least a reasonably tolerable person to be around - Narcopic
Reply

#12
So, finally another one wondering how to get warpzone see-through. Problem is, some work (like on spaceelevator), and many don't (like on geoplanetary, or the weirdcube dm map. Any suggestions what might fix it?

And for the record: reflections are enabled (r_water is 1).

   
   
Reply

#13
So, I went to your server with a 0.7 and 0.8 client and it works fine for me.
That means it is likely something with your client. Tongue Do you have some files in your data folder? Maybe something is causing this. I would try to move all pk3's out of the data folder and test it again - respectively you can also move out your config file and try with a fresh one.
[Image: 21.png]
IRC (QuakeNet): #bot.xonotic | #xonotic.pickup | #xonotic | #xonotic.cup
Steam | Twitch.tv | YouTube
Movies: Mirification #1 | #2 | Mirificaption #1 | #3 | #4 | [BOT] Clan #3 | #5 | #6 | #7 | [BOT] Clan #4 | #8

Reply

#14
The problem here is a bad map pk3 on the server applying its own (old) common.shader file in its scripts folder.
When you see the error again, maybe try this in your console: which scripts/common.shader

You will need to modify the pk3 of the map and give it a new name so clients redownload it (name the pk3 something like mapname_shaderfix.pk3 - no need to rename the .bsp or anything).
[Image: 230.png]
Reply

#15
Okay, seems something in my client's data folder broke it. I removed all *.pk3 files and downloaded them from the server again, and now I have see-through warpzones. Thanks M[ia]rio Wink
Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-