Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[NEEDS INFO] Running Xonotic in linux for the first time


I just found this game and have extracted the files and got it installed on Fedora 19 64bit. However I have yet to make it run properly.

Here is what has happened:

1) Blindly clicked on one of the start scripts (not the dedicated server) hoping that it didn't matter which version I ran. (found no documentation on which version was what).

2) Poof... My main screen was disabled, and Xonotic starts up on my secondary monitor. (well that's a pain...). It asks me to create a player name. So I try to hit backspace to remove the characters, and nothing happens (i hear an error sound). I found a little x above the player box and that cleared it. Whew. Try typing, and nothing happens (found out later I was typing in the browser window I had open behind the game). So I click out the user name I want using the letters provided and then click ok.

3) I am now faced with the main screen. I decide I definitely want this in windowed mode, so I go to the settings, then the video tab and then uncheck the full screen option. I hit Apply! And it crashes. well shoot. I open up my display manager and manually re enable my primary screen as it is still saying its disconnected. my screens are now backwards and the secondary is trying to be primary and I do a bunch of clicking and jiggering and finally get back to the original configuration.

4) Ok so I made it windowed so it should be good this time. Double click the start script, Poof... away goes my primary monitor, full screen on my secondary, and im immediately taken to the main screen this time (i assume it must remember my user name, however the full screen setting... not so much). So I go back to settings and sure enough, there is the full screen setting, sitting there all smug like and still checked.

5) I uncheck the box and click apply and... poof... crashed again. Ok, time to reset my screens again.

6) so maybe I clicked on the wrong start script... I'll go with the other one... *double click* Poof... there goes my primary monitor...

7) hmm... I think its time to ask the professionals... lets log onto the forums...

Basically, how do I get it out of full screen mode? And what are the different start scripts for? Do you guys have a wiki hidden away somewhere that has documentation for running this on linux? also, why does the game not respond to any keyboard presses??

I guess I might just have to manually compile it. but that seems rather harsh...


That's messed up :X Do you have some information to share about your graphics setup? nvidia?

There should be two scripts, glx and sdl. They use different libraries for display and input, you are meant to use the one you think works best for you. I don't think you'll have to compile it yourself, no worries.

You can disable fullscreen in two ways, pick the one you're the most comfortable with. But first of all, let me mention that I would love to see the error log from the crash. To do so, you will have to start Xonotic from a terminal and reproduce the crash, then see if there's any error near the end of the whole lot of text that is left in the terminal. Now, here are the two methods to disable fullscreen:

First method: command line parameter. Launch the startup script from a terminal and add to its arguments the following: +vid_fullscreen 0. For example:
./ +vid_fullscreen 0

Second method: edit the file ~/.xonotic/data/config.cfg (if it does not exist, create it (including the directories if needed)), and at the end of it add the following line:
seta vid_fullscreen 0

This should let you start with fullscreen disabled. Please do report any errors!

PS: I'll also mention that generally, netwm fullscreen works best on Linux OSes. When you get the game working in windowed mode, try to open the Xonotic console by pressing shift escape and type in there
vid_netwmfullscreen 1
, then try to enable fullscreen again.

Okay first of all I have to say that I never had any problems running Xonotic on Linux (Ubuntu with Unity / now KDE). But then again I wasn't using two monitors Wink

As for the keyboard issue, I found that you seem to have the mouse cursor on top of the input field to be able to enter any text. That was somewhat weird in the beginning, but now I'm using the console (and aliases from my config) mainly, so that problem doesn't occur to me too often. Honestly I don't know if it even still exists.

You can make the game start in windowed mode either by editing the config.cfg file (in ~/.xonotic/data) or by appending a flag to the start script: The flag for fullscreen is vid_fullscreen, so either look that up in config.cfg and set it to 0, or start xonotic by /your/xonotic/directory/ +vid_fullscreen 0.
That brings me to an idea... did you run the SDL or the GLX version? Any way, try using the other one; each has its own start script.

Hope to see you ingame soon! =)

EDIT: Dammit, MrBougo was faster .. as always Big Grin
[Image: 9216.png] Web:[unconnected]
IRC: #uc.xonotic #xonotic #xonotic.pickup

I'm running Ubuntu 12.04 64-bit and I also have dual monitors.

I haven't had so many dual monitor issues lately but when I did I found that using xrandr to set your display resolution ahead of time help keep things from getting screwed up (like backwards monitors). My configuration is a 1920x1080 monitor beside a 1280x1024. When I want to play xonotic I run:

xrandr -s 1920x1080

In terminal, then start the game. When I'm done and want two monitors back I type

xrandr -s 3200x1080

I use the xonotic-linux64-sdl executable directly, not through the launcher .sh scripts. Hope this helps.

Possibly Related Threads…
Thread Author Replies Views Last Post
Sad [SOLVED] Segmentation fault (HTTP error 422) at the end of the first map John 1 908 11-04-2022, 10:05 AM
Last Post: John
  [NEEDS INFO] Xonotic settings file on linux ArchBerrie 2 5,015 07-15-2021, 03:18 AM
Last Post: ArchBerrie
  USB Mouse input on Linux dagelf 1 2,284 10-07-2020, 06:14 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 1,637 08-18-2019, 03:14 AM
Last Post: FAF
  [NEED HELP] Missclick on Linux Mint Mate 19 RanDoom 4 3,080 04-23-2019, 01:41 PM
Last Post: RanDoom
  [NEEDS INFO] Linux install Old_Geekdad 7 4,532 01-16-2019, 06:03 PM
Last Post: Zoommair
Exclamation [SOLVED] Graphics issues on Intel Kaby Lake (HD630) hardware on Linux cefiar 9 9,513 04-19-2018, 02:42 AM
Last Post: cefiar
  [SOLVED] linux compile/link error BuddyFriendGuy 2 3,520 11-27-2017, 05:18 PM
Last Post: BuddyFriendGuy
  [NEEDS INFO] W key are not working in fedora24 linux akillah 2 3,337 03-06-2017, 08:35 PM
Last Post: -z-
Sad [NEEDS INFO] Strange bug - my character is moving all the time ! Oncl'Tom 2 3,087 02-12-2017, 06:57 PM
Last Post: organic

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-