Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] sv_public not working?

I need some help understand the setting for sv_public. This is from the source code:
  • 1: advertises this server on the master server (so that players can find it in the server browser);
  • 0: allow direct queries only;
  • -1: do not respond to direct queries;
  • -2: do not allow anyone to connect

When I ran a test server (in the cloud, not locally), I set it to 0, but my server still appears in the master server. I got a few visitors as well.

Then Sl@ve told me that it should be -1 (thank you again!) if I don't want it to show in the master server list. I set it to -1, and successfully made it private -- the only way I could connect to it is by typing the IP by hand.

The darkplaces code suggests that the only difference between 1 and 0 is that 1 responds to heartbeat query but 0 doesn't. It seems that 0 still connects to the public list.

What's the use of 0 then?

Found some answer here:

Quote:If you server already sent a heartbeat to the master, it'll stay in the server list for serveral minutes after you set sv_public 0. If you want to enshure your server is not in the list, use sv_public -1 (that'll make your server ignore any status requests, people who know the ip are still able to cconnect) or sv_public -2 (allows only local connections, so except for you no one can connect, even if they know the server's ip)

OK, this is not working again. I'm trying to setup a private pickup server (that accepts IRC pickup bot's query), but whenever I set sv_public 0, my server shows up in the game menu.

EACFreddy suggested me to set it to -1 first and then set it back to 0, but whenever I switched back to 0, it starts to appear in the game menu.

Any advice?

OK. It started to work again (sv_public 0).

It seems that Xonotic HQ will cache my server for a while, and whenever it queries my server, it will reset the cache timer. Therefore, for the HQ to forget my server, I have to configure the server not to respond to the HQ (sv_public -1) for a while (I did a day).

Possibly Related Threads…
Thread Author Replies Views Last Post
  Xonotic server running behind UDP proxy not working doombringeroperator 3 4,451 11-21-2022, 11:00 AM
Last Post: Zaphod
  cl_forwardspeed not working ? kindlyfire 1 2,644 10-15-2016, 09:12 AM
Last Post: Mario
  How can I get AES encryption working? Espionage724 9 7,814 11-02-2015, 03:44 PM
Last Post: BuddyFriendGuy
  maps downloaded from not working W4RP1G 13 14,706 04-13-2012, 06:20 PM
Last Post: W4RP1G

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-