Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Source Code Xonotic on Ubuntu 15.04

So, today. I talked on a server with 4 devs, and one gave me the link to the source code.
I downloaded the source code (as a zip) from
I extracted the file to my desktop, and tried to run the game to test it.
I have made no modifications to the source code.
I go into the terminal, cd to the directory, and try to execute the xonotic-glx .sh file.
Here's is my terminal log as follows.

god@Ryan-PC:~$ cd Desktop/xonotic-master-08f0ef07ea5d58525ac59ad405598e88713f955c/
god@Ryan-PC:~/Desktop/xonotic-master-08f0ef07ea5d58525ac59ad405598e88713f955c$ ./
./ 131: exec: ./xonotic-linux64-glx: not found

Apparently, it can't find the sh file.
Help would be appreciated.
-Ryan Tongue

Hi Ryan,
The "not found" you're seeing is the engine as it hasn't been compiled in the barebones zip you downloaded
The recommended way to checkout the source is with git. There's a guide here:
[Image: 38483.png]

I run Linux mint 17.2 Cinnamon 16 bit/Ubuntu the command I use is ~/Xonotic/xonotic-linux64-glx -basedir ~/Xonotic

Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVED] Input flickering in Ubuntu 20.04 NAPALM 3 1,511 03-28-2021, 11:38 AM
Last Post: SpiKe
  [SOLVED] No stats for the player Ubuntu 19.04 - just don't use the flathub version Fiorentino 2 2,912 04-20-2020, 07:42 AM
Last Post: Fiorentino
Exclamation [BUG] *ubuntu 18.04/nVidia v415-Desktop Screen Corruption After Exiting Game? JeZxLee 1 2,974 01-06-2019, 05:15 AM
Last Post: SpiKe
Bug [BUG] Permission Denied line 131 Ubuntu 14 ilyasofficial 2 3,011 10-22-2017, 06:39 AM
Last Post: martin-t
  [SOLVED] Ubuntu 16.0.4 Compile RedScale12 8 6,004 09-06-2016, 08:40 PM
Last Post: RedScale12
  [SOLVED] cannot compile git code dingus 5 4,727 07-27-2016, 05:13 PM
Last Post: sev
  [NEEDS INFO] How to ubuntu xonotic server install? Turan 4 5,216 03-17-2016, 08:01 AM
Last Post: Turan
  [SOLVED] Ubuntu running problem rembak 7 9,823 03-29-2014, 04:30 AM
Last Post: adem
  [SOLVED] Ubuntu 12.04 Install Issue Red Viper 6 7,689 03-08-2014, 03:20 AM
Last Post: Halogene
  [SOLVED] How to get Xonotic to work with the open-source Radeon driver? MirceaKitsune 16 18,839 11-19-2013, 06:49 AM
Last Post: MirceaKitsune

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-