Create an account


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Map-Hosting failure

#1
Hi there,

I'm trying to set up a new map hosting server because the old one has just 200kbit averaged.

current server setting:
sv_curl_defaulturl http://xonotic.square7.ch/maps/

this URL works just fine but the server is very slow.


When I change that URL to my new Webspace
sv_curl_defaulturl http://ni108111_1.vweb03.nitrado.net/maps/
xonotic isn't downloading any maps. (Black map error, and I have to clear my dlcache folder.)

Idk why D: . Maybe someone can help me

Thanks
[Image: xonotic_shoutli.png]
xonotic.shout.li - listed xonotic minstagib server
Reply

#2
(06-04-2013, 08:09 AM)thunderbug Wrote: Hi there,

I'm trying to set up a new map hosting server because the old one has just 200kbit averaged.

current server setting:
sv_curl_defaulturl http://xonotic.square7.ch/maps/

this URL works just fine but the server is very slow.


When I change that URL to my new Webspace
sv_curl_defaulturl http://ni108111_1.vweb03.nitrado.net/maps/
xonotic isn't downloading any maps. (Black map error, and I have to clear my dlcache folder.)

Idk why D: . Maybe someone can help me

Thanks


I had problems when using

sv_curl_defaulturl

so instead create a file called curl_urls.txt.

In that file put in

* http://ni108111_1.vweb03.nitrado.net/maps/

and upload it to .xonotic/data
[MoFo] Servers - North America - Hosted in Montreal Canada - Admin DeadDred [MoFo]
Reply

#3
(06-04-2013, 09:19 AM)end user Wrote: I had problems when using

sv_curl_defaulturl

so instead create a file called curl_urls.txt.

In that file put in

* http://ni108111_1.vweb03.nitrado.net/maps/

and upload it to .xonotic/data

Thanks for your answer Smile

I tried your solution but it is still not working.
[
What I did:
- created the file curl_urls.txt and entered the text mentioned above. uploaded it to xonotic/data/ > did not work
- deleted the sv_curl_defaulturl property completely from the server.cfg > did not work either Sad
]
Every downloaded map in my dlcache folder has a size of 0bytes and I still have the black map bug.

Do I need to set up anything on my webspace?
[Image: xonotic_shoutli.png]
xonotic.shout.li - listed xonotic minstagib server
Reply

#4
(06-04-2013, 09:43 AM)thunderbug Wrote:
(06-04-2013, 09:19 AM)end user Wrote: I had problems when using

sv_curl_defaulturl

so instead create a file called curl_urls.txt.

In that file put in

* http://ni108111_1.vweb03.nitrado.net/maps/

and upload it to .xonotic/data

Thanks for your answer Smile

I tried your solution but it is still not working.
[
What I did:
- created the file curl_urls.txt and entered the text mentioned above. uploaded it to xonotic/data/ > did not work
- deleted the sv_curl_defaulturl property completely from the server.cfg > did not work either Sad
]
Every downloaded map in my dlcache folder has a size of 0bytes and I still have the black map bug.

Do I need to set up anything on my webspace?

Do you have a copy of your maps also in .xonotic/data ?

Also for linux make sure its not xonotic/data but ./xonotic/data Thats the hidden folder in your home directory.
[MoFo] Servers - North America - Hosted in Montreal Canada - Admin DeadDred [MoFo]
Reply

#5
(06-04-2013, 09:50 AM)end user Wrote: Do you have a copy of your maps also in .xonotic/data ?

Also for linux make sure its not xonotic/data but ./xonotic/data Thats the hidden folder in your home directory.

thanks for your reply again Big Grin

But please keep in mind that it is already working with my old webspace provider (which is just too slow). So when I change the server.cfg to
sv_curl_defaulturl http://xonotic.square7.ch/maps/
then everything works just fine. When I change the sv_curl_defaulturl to the new URL it doesn't download anything.

In other words: Yes I have uploaded all necessary maps in the right directory Smile

So the problem should be located somewhere at the new webspace. But I don't know where.... I can download the map files with my browser just fine :S
[Image: xonotic_shoutli.png]
xonotic.shout.li - listed xonotic minstagib server
Reply

#6
Can you either give us the server name or IP, or send us a demo file of the map failure? That will help troubleshooting.

Also, please look at the client console when you get the black map problem, it might give you precious information.
Reply

#7
thanks for your answer Smile

The server ip is xonotic.shout.li . It's currently a not listed server because I don't want any user downloading corrupt map files.

Here's an example map which I just got from the server.

And a screenshot of the ingame console after getting a black map:
[Image: xonotic_mapbug.png]

thanks for trying to help!! Smile
[Image: xonotic_shoutli.png]
xonotic.shout.li - listed xonotic minstagib server
Reply

#8
The http server seems to work fine... Can you try to remove the corrupt file from your dlcache and try again?
Reply

#9
I tried it very often.. and it's still not working Sad (just deleted the map and reconnected)

You can try it yourself. I set that it is always the same map on the server (biolab - you can also download it from the webserver, it's working there).

IP: xonotic.shout.li
[Image: xonotic_shoutli.png]
xonotic.shout.li - listed xonotic minstagib server
Reply

#10
Yep, I found the problem. Your HTTP server is faulty. Sending the exact same request to the HTTP server without the Referer header works, but otherwise it just closes the connection without sending any data at all.

Here's the request that my client sent:
Code:
GET /maps/biolab_v1.pk3 HTTP/1.1
User-Agent: Xonotic Linux 12:17:05 Mar  2 2013 xonotic-v0.6.0-182-g97eea25 debug git
Host: ni108111_1.vweb03.nitrado.net
Accept: */*
Referer: dp://78.143.18.87:26000/
Sending the same request without the Referer line makes it work. Talk to your provider's tech support.
Reply

#11
(06-04-2013, 04:21 PM)Mr. Bougo Wrote: Yep, I found the problem. Your HTTP server is faulty. Sending the exact same request to the HTTP server without the Referer header works, but otherwise it just closes the connection without sending any data at all.

Here's the request that my client sent:
Code:
GET /maps/biolab_v1.pk3 HTTP/1.1
User-Agent: Xonotic Linux 12:17:05 Mar  2 2013 xonotic-v0.6.0-182-g97eea25 debug git
Host: ni108111_1.vweb03.nitrado.net
Accept: */*
Referer: dp://78.143.18.87:26000/
Sending the same request without the Referer line makes it work. Talk to your provider's tech support.

Woho.. Big Grin Thanks for spending so much time to solve my problem Smile
(also thanks to end user for helping)

I just contacted my hosting provider. I hope they'll respond soon and I can tell you what happened.
[Image: xonotic_shoutli.png]
xonotic.shout.li - listed xonotic minstagib server
Reply

#12
Yeah it's working now. My webspace provider has a DDoS protection system which automatically blocked "dp://". They put that scheme on their whitelist and it's working now.
Thanks again everyone for helping especially Mr. Bougo.
[Image: xonotic_shoutli.png]
xonotic.shout.li - listed xonotic minstagib server
Reply

#13
Neato! Glad we worked that worked out.
Reply



Possibly Related Threads...
Thread Author Replies Views Last Post
  Server Hosting Issue Saevus 3 850 11-11-2020, 02:53 PM
Last Post: :[:{b_e*r^f}:]:
  Free hosting for Xonotic servers MarisaG 9 2,872 09-18-2018, 07:06 PM
Last Post: MarisaG
  Server hosting? neXus 11 10,180 04-22-2012, 02:31 AM
Last Post: W4RP1G
  North America game server hosting suggestions? nifrek 5 6,436 03-12-2012, 01:00 AM
Last Post: nifrek

Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-