Create an account

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Compiling for Win under Linux?

I'm currently running a compiled version of the GIT repository. It compiled without any problems on my Ubuntu 10.04 system and I currently play from my linux machine without any issues. However my most powerful PC is a windows based system and I thought it would be a bit easier to compile the game for windows from my linux system since it is already compiling fine. Seems like a duplication of effort to reconfigure a build environment on my XP box.

Any possible insight always appreciated.

Automated Xonotic Git build system

works fine for me but i get sometimes error with mem_alloc out of memory (i have 4gig and quadcore.... O.o)
but i can fix this with deleting the settings cfg in .../users/me/documents/mygames/xonotic/data

Thanks _para, I'm reading up right now Smile

took some time to download but the compile went very smoothly. Tested it out and it seems to work very well, I like the new logo as well.

Thanks for the link _para, worked like a charm and saved me the hassle of configuring a cross compile environment, yay!
"My right foot's bigger than the other one is like a regular zombie hoof. "

no problem ;D

Possibly Related Threads…
Thread Author Replies Views Last Post
  [NEEDS INFO] Xonotic settings file on linux ArchBerrie 2 4,082 07-15-2021, 03:18 AM
Last Post: ArchBerrie
  USB Mouse input on Linux dagelf 1 1,994 10-07-2020, 06:14 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Compiling on Elbrus DJs3000 1 1,303 07-03-2020, 04:57 AM
Last Post: poVoq
  [NEEDS INFO] Corsair Strafe input lag in Linux Mint? FAF 1 1,342 08-18-2019, 03:14 AM
Last Post: FAF
  [NEED HELP] Missclick on Linux Mint Mate 19 RanDoom 4 2,550 04-23-2019, 01:41 PM
Last Post: RanDoom
  [NEEDS INFO] Linux install Old_Geekdad 7 3,606 01-16-2019, 06:03 PM
Last Post: Zoommair
Exclamation [SOLVED] Graphics issues on Intel Kaby Lake (HD630) hardware on Linux cefiar 9 8,406 04-19-2018, 02:42 AM
Last Post: cefiar
  [SOLVED] linux compile/link error BuddyFriendGuy 2 3,127 11-27-2017, 05:18 PM
Last Post: BuddyFriendGuy
  [NEED HELP] Netradiant compiling? Raxno 2 2,718 11-11-2017, 04:50 AM
Last Post: It'sMe
  [NEEDS INFO] W key are not working in fedora24 linux akillah 2 3,004 03-06-2017, 08:35 PM
Last Post: -z-

Forum Jump:

Users browsing this thread:
1 Guest(s)

Forum software by © MyBB original theme © iAndrew 2016, remixed by -z-